4 Replies Latest reply: Dec 12, 2007 4:17 AM by Sven Eberhard
Sven Eberhard Level 1 Level 1 (5 points)
The Softwareupdate has installed the iMac EFI Firmware Update 1.2 on 6 iMacs in our Company.
When i tried to install this Update, it first appears the Screen with the Manual and Shutdown Button.
After i click on Shutdown and type in the Admin PW the following Error occours:
"Could not install the Update (0)..."
The Firmware Version is not up to date and i have this Problem on all of this iMacs.

Does anybody knows a Solution?

Thanks!

iMac 2,0GHz late 2006, Mac OS X (10.4.11)
  • Dave Marsh Level 2 Level 2 (325 points)
    After running the installer on the Mac, actually installing the update generally requires that you restart the Mac by HOLDING DOWN THE POWER BUTTON until you hear the flat tone that lets you know the firmware update is going to proceed. The installer usually says this before your select the restart option. After releasing the power button, the screen then usually displays a progress bar that proceeds slowly, but seldom more than a few minutes. When the firmware update is done, the Mac will restart on its own and return you to the login screen. Once it returns to the Desktop, a dialog will display noting that the firmware update was successful.

    Firmware updates may NOT be interrupted once started, or the chip being updated will be corrupted and the Mac won't restart AT ALL after that, requiring an AppleCare service. If your Macs are still working, you probably haven't completed the firmware installation process.
  • Sven Eberhard Level 1 Level 1 (5 points)
    Dave, i have already made many Firmware Update and know the Procedur.
    But my Problem is, that the Updater ask me for the Admin PW bevor the iMac Shuts down.
    After i type in the PW the Error occours and the Mac wont Shut down.
    When i shut down manually and start again and press the Start Button, the Update is not starting.
  • David in AZ Level 4 Level 4 (1,280 points)
    Good morning,

    This typically is the sign of a larger underlying problem that you weren't aware of.

    I'd suggest running a 'Repair Permissions' on your drive as the first step and try running the Firmware again. If that doesn't take care of it, we'll move onto more drastic measures.

    Hope this helps! 

    David
  • Sven Eberhard Level 1 Level 1 (5 points)
    Hello Dave,

    thanks for your help. Repair Permissions was one of a few things i tried, but nothing solves the problem. On this Friday i try to boot the six iMacs from a external HD and try again to install the FW-Update.

    Thanks
    Sven