10 Replies Latest reply: Nov 26, 2007 3:11 PM by Mr. Eeee
Mr. Eeee Level 1 Level 1 (5 points)
Hi,

I have a problem with watching streaming video on Firefox. I asked about this yesterday and thought the problem was solved, but another thing has now come up. I couldn't watch streaming video on Firefox w/ Quicktime (I just got a question mark over the quicktime symbol on streaming video windows). It was suggested that I install the latest flash plugin and was kindly provided with a link to the plugin. I duly installed it and it worked. I thought the problem was completely solved. But today when I opened Firefox again to rewatch a video...I got the question mark thing again. I reinstalled the flash plugin yet again, and again...it worked. Then as a test, I closed the browser and then reopened it. I got the damned question mark thing yet again! It seems that every single time I close the browser, something happens with the plugin and it doesn't work anymore.

Can somebody here please tell me what is going on...and (hopefully) what I can do to solve the problem permanently?

Thanks a lot.

iMac G5, Mac OS X (10.4.11), It's much too nice!
  • Mr. Eeee Level 1 Level 1 (5 points)
    Oh...I forgot to mention...I have Quicktime Pro v7.3 and installed "Flash Player 9 OSX".
  • QuickTimeKirk Level 9 Level 9 (50,960 points)
    Something isn't "sticking" after your Flash install.
    Use the Disk Utility app (utilities folder) to "Repair Permissions" and restart your machine.
  • Mr. Eeee Level 1 Level 1 (5 points)
    Thanks a lot for the reply Kirk. I appreciate it very much.

    I was quite hopeful that it was going to work too as when I ran the permissions repair as you suggested, all the items on the list involved flash. I hate to say it though, but the same exact thing is still happening. I tried installing flash, then running the permissions repair and then restarting. And I tried running the permissions repair, then restarting and then installing flash. All to no avail.

    The same thing occurs every time.

    I have Xupport installed on my iMac as well and I also tried running the full Maintenance Pilot routine with it...which not only does a permissions repair, but also does a system optimization and periodic system tasks (which runs OSX maintenance scripts--removing old temporary & junk files, rotates log files and updates "man- whatis- and location database").

    That didn't help either. The plugin still stops working each and every time I close the browser. I just don't get it.

    On the positive side however, reinstalling flash only takes about 1 minute and streaming video works just fine on Safari. I really do prefer using Firefox though, because--as I'm sure you're well aware--many sites don't code for Safari and they won't work right with it (such as not being able to download files, etc.).

    If you have any other ideas on what I might try, I sure would appreciate hearing them.

    Thanks again.
  • QuickTimeKirk Level 9 Level 9 (50,960 points)
    Something (beyond my skill levels) is still wrong with your OS and User account.
    Since the permissions repair "pointed the finger" at Flash and yet you still have issues after repairing then something else is causing it.
    I would restore default settings by deleting the Firefox .plist files and then try again.
  • Mr. Eeee Level 1 Level 1 (5 points)
    Well...I used AppZapper to delete Firefox along with it's plist (and a couple of other related files which I can't remember) and then reinstalled it along with Flash 9. I don't think either of us is very surprised to hear that the problem remains.

    I ran a permissions repair again while Firefox and Flash were deleted and it was completely clear. Not one single item came up on the repair window. After reinstalling Firefox and Flash...all of the same items DID show up again when I ran a permissions repair yet again.

    It weird though. I have no problems with anything else on my iMac. Every other program I have works perfectly and like I said, the permissions repair was totally clear w/o Flash 9 installed. This certainly is a mystery. I'm totally lost. Anyways...I timed it, and installing Flash takes only 40 seconds. I guess I'll just have to live with that. I don't actually watch streaming video that often anyway and 40 seconds is not very long to wait.

    I'll leave this topic open though and keep checking on it. Maybe you will think of something else or perhaps somebody else will give me some advise too. I guess I'll also try asking about it on the Mozilla/Firefox forums as well.

    Many, many thanks for taking the time to try and help me Kirk. ~Aloha from Hawaii.
  • Baby Boomer (USofA) Level 9 Level 9 (56,785 points)
    Use your System Install Tiger DVD to run repair disk/permissions from the Utility Menu.

    If the above does not work, then maybe the following will:
    Thanks to Vincent Marks for providing the following............

    If you need the QUESTION MARK AND THE QUICKTIME LOGO GONE,
    Please try the following.

    UN-INSTALL FLASH PLAYER.

    http://www.google.com/support/youtube/bin/answer.py?answer=56115

    EMPTY TRASH.
    NOW DO A RE-START.
    (if somethings appear in the trash, empty again)

    OPEN YOUR APPLICATIONS AND MOVE ADOBE READER INTO TRASH CAN.

    EMPTY TRASH.
    DO ANOTHER RE-START.

    FROM THE SAME WEB SITE (www google) INSTALL THE NEWEST FLASH PLAYER 9.

    FROM THE ADOBE WEB SITE(below) , FIND YOUR RUNNING SYSTEM FOR THE ADOBE READER AND INSTALL. (with 10.3.9, I could not install anything greater than Adobe Reader 7.0.9)

    http://www.adobe.com/

    DO A THIRD RE-START.

    AND FINALLY, NOW OPEN DISK UTILITY AND DO A PERMISSIONS REPAIR.

    This should be the permanent repair. It made mine like brand new! And remember, the Re-starts and the Disk Permissions Repairs should be tried in sequence from above though considering different running systems, third party software, etc, .... well e-mail back if the above does not work.
  • Mr. Eeee Level 1 Level 1 (5 points)
    Thanks a lot for the reply Baby Boomer.

    I went ahead and opened a topic on the Firefox support forums and according to them...this is a problem with the Firefox-Mac program which has yet to be resolved.

    But you said that the steps you posted made your system like brand new. Did you have this very same problem?

    If so...I will go ahead and do everything you advised, but if you had some other problem...I don't really want to dump all those programs and reinstall since the Firefox guys say it's a problem with their program. If you did indeed have this very same problem and your steps fixed it...I will pass along the info to Firefox since a bunch of other people have the same problem and they haven't come up with a fix themselves yet.

    Thanks again!

    BTW...I've never sent an email to anyone through these forums before so maybe I didn't do the right thing, but I clicked on the email icon in your post to send you this message by email as well and it didn't work. The recipient & email address boxes were empty. I thought that this was security feature to keep members email address private, so I just clicked on "send" with the boxes empty. I got a notice to fill in those fields though.
  • Baby Boomer (USofA) Level 9 Level 9 (56,785 points)
    "But you said that the steps you posted made your system like brand new. Did you have this very same problem?"

    The Adobe solution was posted by *+Vincent Marks+* another forum user. I indicated this in my posting.

    I much prefer that you post all questions to the appropriate discussion forum. This allows other users and other helpers to have a chance to view and respond to your post. *That way, everyone benefits from the exchange.*

    Sorry, I do not give out my email addy.
  • Mr. Eeee Level 1 Level 1 (5 points)
    First of all, the way your post read, it seemed to me that Vincent Marks gave you the answer to a problem that you were having. Perhaps YOU should be more clear when YOU are answering a post.

    Secondly, when I opened my topic I thought it was a problem with Quicktime...and this IS the appropriate forum for that...is it not?

    Thirdly, I don't appreciate being talked down to like that. I always do my best to be nice, courteous and understanding to everyone. Maybe you should consider doing the same.

    Please stay out of my topic from now on.
  • Mr. Eeee Level 1 Level 1 (5 points)
    A very smart guy at the Firefox forums has solved my problem!!! I will post his solution here so that people here at these forums may benefit from the advise...

    [quote]Quote:
    QuickTime Plug-in 7.3

    File name: QuickTime Plugin.plugin
    The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
    ...
    application/x-shockwave-flash Flash media swf Yes

    It seems that flash is enabled for the Quicktime plugin. It is conflicting with Adobe's plugin.

    First thing, close Firefox and check for the option to "Enable Flash" on the Advanced panel in the Quicktime preferences. If it's enabled, disable that and restart Firefox. Test Flash.

    Failing that:
    I was looking for the location of the plugin file, the bit I put in bold in the quote, but a setting needs to be changed for that to appear:
    Enter about:config in the address bar.
    Enter plugin.exposefullpath in the filter
    Set that preference to true.

    Now when you view about:plugins, the path of the plugin file should be displayed.

    Try making a back-up of that file and delete it. Then reset the mime settings while all your browsers are closed.[/quote]

    BTW...I sent in a complaint to the forums administrators about your last post Baby Boomer. Learn some manners dude.

    Message was edited by: Mr. Eeee

    Message was edited by: Mr. Eeee