Previous 1 2 Next 16 Replies Latest reply: May 1, 2008 3:03 AM by penmanila
Peggy Lynn Level 4 Level 4 (2,470 points)
The Restore button is grayed out on when I launch Time Machine nearly all of the time. I tried several times yesterday and today to do a Restore following the directions in Help. The Restore button showed up only once and restored perfectly but it's been grayed-out since. Files copy perfectly when I drag them in the Finder.

I went through two levels at Apple and they have sent it to engineering. Has anyone else experienced the problem? Any guesses as to what might be causing it? I did an erase and install using Setup Assistant to bring over only users/settings and docs.

Mac Mini, 1.42 GHz, 1 GB RAM, 80GB HD, SuperDrive, Mac OS X (10.5.1), Maxtor One Touch 160GB, HP LaserJet 1320n, Epson R800
  • BarryXSharp Level 5 Level 5 (7,875 points)
    Peggy:

    I do believe Apple has some bugs to fix in their TM browser feature. My Restore has been working flawlessly for me so far! However, at time the browser acts weirdly and I just Cancel out and restart it.

    Let's hope these anomalies get resolved over the next few 10.5 updates.
  • Peggy Lynn Level 4 Level 4 (2,470 points)
    I can live with the Restore button issue but the product specialist checked and said it had not been previously reported. It seemed like it might be a good idea to post here to see if I might be able to elicit any more information that might prove to be helpful to the engineers. Can you recall any specifics about the odd TM machine behavior you have experienced?
  • laurik Level 1 Level 1 (0 points)
    I have the same problem. The Restore button in Time Machine remains grayed out no matter which of the past backups I choose on the right side bar. The backups are on an external 500 GB LaCie drive, connected by a Firewire 800 cable.
  • Peggy Lynn Level 4 Level 4 (2,470 points)
    Oddly enough my issue seems to have mostly resolved itself. Only rarely will the Restore button be grayed out now. I haven't heard back from Apple yet and will probably wait before nudging them again. As long as the files are accessible through the finder I would much prefer that they prioritize more graceful error handling and more informative error reporting for Time Machine.
  • ledwatch Level 1 Level 1 (0 points)
    Can someone please explain to me the use of a backup application that has no RESTORE???? I have needed to use time machine because not the other incredibly reliable mac application MAIL now crashes each time I try to send an email and now TIME MACHINE DOES NOT WORK EITHER????

    Are we some kind of unpaid beta testers? I paid for this junk!

    I suppose it's too much to expect a mail application that works and for a backup program to restore as well. I forgot to mention my .mac IMAP has not worked for 4 hours either. Come back Windows XP - all is forgiven!!!!!!!!!!

    All looks great when you're in the apple store, dosen't it, wait until you try to use it and then the fun begins.
  • BarryXSharp Level 5 Level 5 (7,875 points)
    ledwatch:

    I understand your feelings but not everyone shares them.

    Yes, a backup feature is really quite useless if the restore function does not work.

    Does your Restore not work ? You don't actually say so as what you've posted is simply "TIME MACHINE DOES NOT WORK EITHER". What exactly is your problem. Can't help you unless you provide some further details. Sorry. :-((

    IF you're having problems with Mail.app suggest you post them in the Mail forum.

    Good luck and do post problem details in the future.
  • adamdesautel Level 1 Level 1 (0 points)
    OBVIOUSLY his Restore button is grayed out. THAT'S THE NAME OF THE FORUM WE ARE IN.

    Mine is too, and it's making me a LITTLE ANGRY because I was trying to see if I could run my iTunes off of just the external hard drive, and so I DELETED all of the songs off my computer, it didn't work, and now I find out that I CAN'T RESTORE MY DATA BECAUSE I CAN'T CLICK THE RESTORE BUTTON.
  • adamdesautel Level 1 Level 1 (0 points)
    Next time just assume that anyone who says "yeah mine isn't working either" in a discussion forum DEVOTED to "restore button grayed out" has a grayed out restore button. The sarcasm/high horse attitude really does not help anything.

    Why not just provide an answer to the discussion instead of picking on details of the question?
  • adamdesautel Level 1 Level 1 (0 points)
    Apple MADE Time Machine. Somewhere in the Time Machine application programming code there is something that says "If X then gray out the restore button." There is OBVIOUSLY a reason that the button is grayed out, because Apple apparently made a function to gray out the restore button if "something" happens.

    But even tech support doesn't know what it is? Seriously? Nobody knows? It is completely unknown to man why it doesn't work? The team in charge of creating Time Machine would look at this problem and say "We have no idea"?

    I highly doubt this. But YET, even though this page has received over 300 views, indicating that a lot of people most likely had this problem and just didn't post something saying "I have this problem also," and even though this page has been around since NOVEMBER, NOBODY has offered a solution.

    So what are we supposed to do? Just start over? We bought this product so we could back up our data, and now that something went wrong, we want to go back (like the program is intended for), but we can't. Why? NOBODY KNOWS.

    I am very dissatisfied with this product. DO NOT trust Time Machine to back up your data. It will back it up, sure, but you might not get to ACCESS the data, which is, in effect, the same thing.
  • glrnet Level 1 Level 1 (0 points)
    I also have the same problem, the restore button is greyed out on EVERY back up date. Lacie firewire 500gb drive.

    I have also recently started to experience mail problems, especially at start up.
  • Tainter Level 1 Level 1 (0 points)
    I have the same problem here. I have a g-drive with backups on it , but the time machine button restore is greyed out no matter what i try . VERY strange indeed ....
  • Adam Rickets Level 1 Level 1 (10 points)
    My Restore button was greyed out as well the first time I attempted to use Time Machine to restore something - that's how I found this thread. Finding no answers here I looked elsewhere and along with a bit of trial and error and good luck I solved the problem for me.
    I think that Time Machine was always working perfectly - it was just that I did not understand exactly what it did and how it did it.
    I was selecting one of the previous back-ups and attempting to click on Restore in order to restore my whole computer back to how it was. This is not what Time Machine does when using the "Restore" button.
    What it does is restore specific files from previous back-ups. If you navigate in your standard finder to the file you wish to restore (or to where it previously was) and then enter Time Machine you can navigate around in any of the back-ups - select a file and then click on the Restore button - which should now be white.
    If you have no file selected when you enter Time Machine then you can not navigate around the back-ups and choose a file to back-up - and hence the Restore button is greyed out.
    It is possible to restore the whole computer to a previous back-up - but it is not done from within Time Machine. A complete restoration to a previous back-up is done by booting off your Leopard Install DVD and in the screen that appears after the language selection screen,choose Utilities>Restore System From Backup. Click on continue,select your Time Machine back-up disk, click Continue and choose which back-up to restore.

    This is just what happened for me due to the fact that I did not understand how Time Machine works.I agree that this is not exactly how I expected or hoped it would work and that its workings are not made clearer but it seems that this is how it is.
    I hope this helps others.
    If you already know all this and you therefore have an additional problem/bug then I'm sorry for pointing out the obvious and wish you luck.
    Best wishes
    Adam
  • Nick Greeves Level 1 Level 1 (5 points)
    What an excellent post. I had the "problem" of the grayed out Restore button until I selected the file I wanted to restore.

    We just misunderstood what Time Machine does. It does not offer you the choice of having your machine as it was in the past, it allows you to retrieve past versions of FILES.

    I had totally missed this point and I AM an unpaid beta tester.
  • corinne333 Level 1 Level 1 (0 points)
    I cannot click "restore" in time machine, even if I click on a file.
    I have NO idea why.
    I can access the backups in finder and do it that way, but isn't the point of time machine to be easier than that??
    Is anyone else still having this problem?
Previous 1 2 Next