5 Replies Latest reply: Feb 4, 2008 9:07 PM by khealy
jcnlaca Level 1 Level 1 (0 points)
My stock widget is not updating on my 3 Macs, all running Leopard. It just has a blank green space where the quote should be. I've tried restarting and removing and adding the stock widget back to no avail. Someone in another thread said the quote service changed its web address; don't know if that's the problem. Never any problems with the old Tiger. Please help. Thanks!

G5 Desktop, Mac OS X (10.5.1)
  • gprent101 Level 1 Level 1 (0 points)
    I have the same problem with mine. It works for regular stock symbols, but it no longer works for the major indexes like the Dow, S&P 500 or Nasdaq. I have tried using other symbols for these indexes that I found on the Yahoo Financial web page, but these don't work either.
  • gprent101 Level 1 Level 1 (0 points)
    I just found and update for the iStocks widget that solves my problem. The update is for iStocks Widget version 0.2.2 and is found here: http://www.versiontracker.com/dyn/moreinfo/macosx/33421
    This version has a brown page background compared to a blue background on my original version.
  • BobP1776 Level 3 Level 3 (695 points)
    A few days ago I removed the preferences (plist) file for the stocks widget -- which of course just gets recreated from scratch -- and the stocks widget seems to be working much better now. The blank numeric results are gone.

    This trick did NOT work a few weeks ago, so the service presenting the data to the stocks widget has apparently made a change since then which only takes effect if you discard the now-outdated plist file.

    The one remaining issue is that the time line for the charts is still one hour off -- as if we were still on daylight savings time.
    --Bob
  • ShellNJigs Level 1 Level 1 (0 points)
    How did you figure out which plist file was for the stock widget? I searched through Spotlight and there's lots of plist files and I can't distinguish which one is for the stock widget.

    Any help is appreciated? 'Cause this hour off, and NO index quotes is making me crazy!!

    Thanks!
  • khealy Level 1 Level 1 (15 points)
    Go to user>library>preferences>
    It should be named "widget-com.apple.widget.stocks.plist" or something. Just delete it and empty it from your trash bin and it should work. It worked for me! Yaaay