13 Replies Latest reply: May 22, 2008 11:55 PM by David Goodson
Shilo_js Level 1 Level 1 (0 points)
Hi - using a MBP 2.2, Leopard, iLife 08 and an 8gb iPhone. iPhoto used to import photos from the iPhone no problem - now it won't import it at all. Says it's an unreadable file (though a normal jpg).

What gives? Same issue trying to import two jpg's rec'd via email (and dragged to my desktop).

Any suggestions?

MB Pro 2.2, Mac OS X (10.5.1)
  • itman79 Level 1 Level 1 (0 points)
    Hey Shilo!

    Try refreshing your phone and your sync history.

    REFRESH PHONE

    Hold down the power button and the home button until the Apple appears on the screen, then let go.

    REFRESH SYNC HISTORY

    Find iSync under Applications and Open it.

    On the top menu click on iSync and choose Preferences.

    Under the Advanced Section click on Reset Sync History. (It may appear as nothing happened, but something did in the background, the history was reset)

    Go ahead and close iSync and then try importing your photos with iPhoto again.

    Best of Luck and Happy Holidays
  • Camelot Level 8 Level 8 (46,450 points)
    I had this. For some reason resetting my .Mac account fixed it.

    Open System Preferences -> .Mac and click Sign Out, then Sign in again.

    I can't see why a valid .Mac connection should make any difference, but it worked for me.
  • Ben Abbott1 Level 1 Level 1 (70 points)
    You advice worked for me.

    Thanks
  • Saint Podoreo Level 1 Level 1 (0 points)
    I'm having the same problem...I can't import photos from my iPhone into iLife '08 anymore after upgrade to 10.5.1. It used to work great...now this. Sad, sad, sad I am.

    I tried the "FIX" of refreshing phone and sync history, but it DID NOT WORK for me. HELP!

    Please help, somebody.

    Saint Podoreo
  • ravelgrane Level 1 Level 1 (0 points)
    I have this problem now. I have MacOS 10.5.1, iPhoto '08, and iPhone running 1.1.2.

    In my "camera roll" on the iPhone are 260 photos, all the pics I have taken since I got the phone. I imported some of them weeks ago with no problems into iPhoto. But now iPhoto can't import anything from the iPhone.

    iPhoto does know there are photos on the phone, because there is set of blank thumbnail squares that I can select to import. When I look at the photo info, I can see the file name, size, date, but all the other info is missing or incorrect. It doesn't have camera maker or model. Most worrying though is the height and width of the pictures are zero.

    I am thinking that there is some cache file on the phone that got corrupted somehow. Resetting to factory settings might help, but I really don't want to lose all the photos that I took from the holidays.

    I've tried the above suggestions and no avail: logged out and into the .Mac account; powered down the phone; reset the iSync history (interestingly, iSync does not recognize my phone when I do a device scan).

    I did try removing some stuff to make room, but still no dice.
  • You™ Level 1 Level 1 (25 points)
    I think I have the same issue as ravelgrane. Neither iPhoto nor Image Capture will allow me to grab the pictures from my iPhone. I've tried trashing iPhoto prefs, resetting Sync history and refreshing the iPhone. Funny thing is: yesterday, I had to replace my iPhone because my original stopped charging all of the sudden. My replacement phone was refreshed from a backup and everything seemed fine except now I can't get the pictures off it again.

    iPhoto appears to mount the iPhone (though it doesn't automatically launch when the iPhone is plugged in anymore), but no pictures on the iPhone are available to import (no thumbnails appear). Image Capture does not recognize any photos available to import either.

    I have found one possible solution: Google's "Disk for iPhone" allows me to at least mount the file system and manually copy the photos to my hard drive. But I worry this may be part of the problem. Any suggestions?
  • Saint Podoreo Level 1 Level 1 (0 points)
    i'm going to call APPLE this week and see if they can help with this issue. i'll post a reply if they do. in any event, i am still forced to import photos through image capture --> that does work for me, however, i then have to import those pictures into my iphoto '08 library in order to create new events, etc. this is way too may clicks and turns - i wish our "complaints" here would solicit a "fix" from APPLE.
  • LarryHN Level 9 Level 9 (70,560 points)
    i wish our "complaints" here would solicit a "fix" from APPLE.



    Unfortunately these are NOT Apple support forums - they are User forums - the Users are really good about explaining how thing work - even it they work wrong - and in some cases, work arounds to problems

    NO ONE here can FIX anything - you have to tell Apple to get things fixed - call support or send in a feedback form - http://www.apple.com/feedback/iphone.html

    LN
  • You™ Level 1 Level 1 (25 points)
    I think my problem is solved. I began to suspect the problem wasn't the iPhone. I suspected it was iPhoto ignoring the roll of photos on the iPhone because it assumed that's what I wanted it to do. Perhaps I dismissed a dialog box asking me to import some images at one time - I don't know for sure. My laptop is not the computer where I usually download my photos - but I thought that didn't matter. Any compatible copy of iPhoto should be able to work with any iPhone. So I plugged the iPhone into a different computer, downloaded and deleted the pictures, shot some new ones in a new "roll" and viola, everything works as expected again.

    I don't know if you will find this helpful, but maybe you can try connecting your iPhone to another computer, downloading the pictures and deleting the originals, then see if iPhoto will let you import newer rolls of images.
  • Adam Tyree1 Level 1 Level 1 (25 points)
    It's definitely a problem with iPhoto. When I connect my iPhone to my iMac, the computer that it's synced to, iPhoto says that there are no pictures in the camera roll. However, when I connect it my MBP, the pictures show up in the camera roll. I tried the suggestion by "You," to erase the pictures from the camera roll then try again, but that doesn't seem to work. Has anyone found a definitive reason/solution yet?
  • You™ Level 1 Level 1 (25 points)
    Yeah, using the method I describe above, iPhoto only seems to work for the first time I plug the iPhone in and download photos after connecting that iPhone to another computer and downloading the pix there; on subsequent connections, iPhoto again shows the iPhone but not the photos contained within. Fortunately I have other Macs around to retrieve the pix. I'm eager to learn what the solution turns out to be.
  • katieglauds Level 1 Level 1 (0 points)
    I am having the same problems as listed above...except iphoto recognizes that there are photos there but when I click import it says reading photos or something then goes straight to finishing import with out downloading my photos. My regular camera is the same way so I think it is iphoto that is to blame...any suggestions?