10 Replies Latest reply: Feb 15, 2008 12:27 PM by dusteddaily
Steven Whatley Level 1 Level 1 (95 points)
Hi all,

I have a Mac Pro running Leopard and a 1TB Buffalo Terastation on my home network. I am able to access with the Terastation from the Mac by going though Finder. To do so, I have to click on the name of the TS on the left side of Finder and then click on the "share" folder in the next column. This mounts the network share as /volumes/share.

This is OK but I currently have my iTunes library on the Buffalo TS. However, if my iPod is already docked before I power up the Mac, iTunes can't find its library because the share isn't mounted. I have to manually make Leopard mount the share by the procedure in the above paragraph.

Is there a way I can get the Mac to auto-mount the network share like I can under Windows or Linux? Since MacOS X is Linux based, can I use the Linux method for auto-mount the share by editing a fstab file?

Any info will be appreciated. I've tried searching and have tried a few tips but haven't got it working yet.

Thanks,
Steven

2.66MHz Mac Pro, 5GB RAM, ATI X1900, 3x 250GB HDs, Mac OS X (10.5), Dual Dell 2405FPW LCDs + Klipsch Promedia Ultra 5.1 speakers
  • Jeff Greenberg Level 3 Level 3 (585 points)
    Steven,

    I don't have a complete solution either but here are some tips. I know you have a network disk, but if you are using another Mac as a server you need to have your external disks mounted at boot time and they need to stay mounted. You can set this default by using:

    sudo defaults write /Library/Preferences/SystemConfiguration/autodiskmount AutomountDisksWithoutUserLogin true

    Then you need to have the disk autmounted on the client. You can edit the /etc/fstab file and add an entry that mounts the external disk:

    Disk:/Disk x url net, automounted,url==afp://foo:bar@server/Disk 0 0

    That will cause "Disk" at "server" to be mounted in the /Network/Servers directory at boot time using credentials foo & bar. However, I haven't been able to share an external disk so that a guest can successfully mount it.
  • caglassc Level 1 Level 1 (0 points)
    Steven,

    This might work. Try mounting the disk on your desktop. Then, using system preferences - . accounts add the disk to your startup items. I have used this method and it works. I just have other problems with my AEBS.

    Hope this works.
  • Jeff Greenberg Level 3 Level 3 (585 points)
    caglassc wrote:
    Steven,

    This might work. Try mounting the disk on your desktop. Then, using system preferences - . accounts add the disk to your startup items. ....


    That method works by mounting the disk at login, not at boot. It also has the side effect of showing the share window when the volume is mounted. Finally, if more than one use is logged in (i.e. if you use fast-user switching) the path to the mounted volume will depend on who logged in first.
  • Stephen Tolton Level 1 Level 1 (40 points)
    I'm not sure if this solution works or not, to be honest.

    I've added my mounted sharepoint to my login items aswell as editing the file you described:

    MacProBU:/MacProBU x url net, automounted,url==afp://admin:admin@"AFP on Tolton2TB.afpovertcp.tcp.local/MacProBU" 0 0

    MacProBU is the name of the Sharepoint and drive, once it is mounted.

    AFP on Tolton2TB.afpovertcp.tcp.local/MacProBU is the location of my sharepoint when I 'Get Info' on my mounted drive.

    My Network drive now seems to mount and be ready to use at login, however a Finder window now opens every time, showing my the contents of the Share.

    Not too much of a problem, but a bit annoying.

    I've read tons of articles about auto-mounting shares, AFP and SMB etc drives

    All seem a bit mis-matched with no idea what's going on. And a lot are complaining about the removal of NetInfo in leopard.
  • NekoLLX Level 1 Level 1 (10 points)
    if i may ask, how do you mount a networked drive. In Tiger our networked drive just loaded to the desktop when we connected to it but now its in the shared side bare and i want to get it back on the Desktop
  • Stephen Tolton Level 1 Level 1 (40 points)
    Well for me, when I load my sharepoint it mounts as a drive - and thus, like any other drive (i.e FireWire, USB) it is displayed on my desktop.

    I know that in Leopard now, however, you can't have another users Hard-drive or userarea on your desktop like you used to be able to have in Tiger.
  • Jeff Greenberg Level 3 Level 3 (585 points)
    Stephen Tolton wrote:

    I've added my mounted sharepoint to my login items aswell as editing the file you described:
    +misc deleted....+
    My Network drive now seems to mount and be ready to use at login, however a Finder window now opens every time, showing my the contents of the Share.


    The reason the Finder window opens is because you have placed your sharepoint into your login items. There is no need to edit the /etc/fstab file AND to add a login item. Use one solution or the other. With the login item you get your share mounted at login, not boot time and, as you've notice, you also get that annoying Finder window.
  • Stephen Tolton Level 1 Level 1 (40 points)
    Also, if you use iSlayer's iStat Menus (or any custom apple menu 'gadgets'), if your network drive is NOT switched on when you log-in, Finder will complain it can't find it and get stuck on that login item. Thus, iStat Menu's don't load, therefore I get no clock etc and it near enough crashes the entire Apple menu bar.

    And editing the fstab file produced errors in disk utility, and that the file was being ignored. (It's an issue Apple is aware of, as in the documentation is says not to worry about them).

    :/
  • Jeff Greenberg Level 3 Level 3 (585 points)
    Stephen Tolton wrote:
    And editing the fstab file produced errors in disk utility, and that the file was being ignored. (It's an issue Apple is aware of, as in the documentation is says not to worry about them).

    :/


    Leopard provides a command-line utility for safely editing /etc/fstab called vifs.
  • dusteddaily Level 1 Level 1 (0 points)
    Neko,

    from Finder > Preferences, click on the "General" tab and check "Connected Servers" under the "Show These Items on the Desktop:" heading.

    This preference is deselected by default in Leopard.