Previous 1 2 Next 16 Replies Latest reply: Dec 6, 2007 2:22 AM by ZBurnett
ZBurnett Level 1 Level 1 (90 points)
I've got a Powerbook that will not stay up after a boot from a CD with the Hard Drive removed. Actually, it only will boot once when cold and then it locks up.

I've been over on the 10.3 forum getting advice and now that we're convinced that it's totally a hardware issue, I thought I'd try over here. I don't know how to paste a link here, but the Topic was:
"Security updates killing a Lombard..." This topic was because my problems started when I did an Apple update.

Still, I'm curious about a few things about the hardware. There are some screws that are off to the left of the memory, are they soldered in? This is just in front of the PCMCIA slot. I may be tearing this thing apart as an educational experience. This thing has served us well.. Right now I get a mix of black screens or just frozen up when I try to boot after it has warmed up. If I boot from the hard drive I get a grey circle/slash because I think my last install didn't really work. I did a clean install and I thought it finished when it booted at the end the screen stayed black.

Lombard, Mac OS X (10.3.x)
  • jpl Level 7 Level 7 (28,285 points)
    ZBurnett,

    As you have experienced, the Lombard will boot nicely to an optical disk without the HD. How long does the Lombard run from the CD and then what happens...freeze?...no display?...etc?

    You certainly have a hardware problem if it will not stay running when booted to a CD. I might suggest this approach to narrowing down the possible culprits:

    1. Remove the main battery and optical drive; now connect just the power adapter and power up. Do you get the expected flashing '?' on a gray screen?

    2. Next, lift off the keyboard, then carefully disconnect the keyboard ribbon cable; a bad keyboard can cause no-starts, freezes, etc. Test the Lombard by inserting the optical drive with bootable CD, then power on. Technically the powerbook should pick up the CD as a bootable volume and boot to it, but I can't be certain.

    3. I would next disconnect the PRAM battery and leave it disconnected for the duration of testing; the 'book will run fine without it. If the rechargeable PRAM battery is failing internally, it can play havoc with the power manager. Now test your 'book.

    4. Remove the top memory module, then test.

    5. Lift out the microprocessor card, turn it over and remove the bottom memory module; now reinstall the microprocessor card (bottom slot empty) and reinstall the original top memory module (if it made no difference when removed earlier). Now test...

    If you are trying to boot a Jag/10.2 CD, it may boot with just a 64MB module but I don't think Panther/10.3 will. I mention this since I don't know what your RAM specs are. If you have any MacOS 8.6 > 9.2.2 compatible CDs, it may be a little easier to troubleshoot.

    If your main battery is dead, don't rule out the possibility of an intermittently failing power adapter. The PB1400, 3400, any black G3, and first generation iBook adapters are interchangeable, so it might be worth a try.

    Here is a nice disassembly guide:
    http://www.ifixit.com/Guide/Mac/PowerBook-G3-Lombard/31/
  • ali brown Level 7 Level 7 (26,465 points)
    Hello Again ZBurnett!

    "I don't know how to paste a link here,..."

    I'll do it for you! Security updates killing a Lombard....

    And you also might find these Tips useful, for future reference!

    How to post a link (URL) in "Apple Discussions"
    How To format A Link To A Post Within a Thread

    ali b
  • ZBurnett Level 1 Level 1 (90 points)
    Wow Thanks... this is very helpful! but I want to reply first...

    1- Yes, I get the OS8/9 style grey screen with a question mark.
    2- Oh - you have to take the Modem out first! It says that on the Processor board step - Those are the screws I was asking about... a little more torque and I got those out. Found a few hairs and crumbs rattling around.
    3-OK -unplugging the PRAM battery has the machine sitting at the install screen and running fine.

    I think the hard drive cable and PRAM battery are suspect here... can you run without a PRAM battery?

    I tried to boot once after putting a bunch of stuff back together and it went to the hard drive even thought I had the C down... Do you have to bring the C down after the chime? I vacuumed out the keyboard...good thing my vacuum has a way to turn down the suction. No keys lost

    I did go down to the bottom memory module and pulled it out, but then I thought... It worked fine with that plugged in, so I went back and started an install with the modem and the PRAM battery out. and it's installing! Yeaaaaa!
  • ZBurnett Level 1 Level 1 (90 points)
    Well ... the install got all the way to asking for the 2nd disk, and through the boot to the registration screen. I started working on that and it died. It's been up and down ever since. I booted from CD and repaired the disk which it said it did repair... I haven't gone back and done all the other fixes yet.

    Is there a way to install the OS on an USB external drive and boot from there?
  • jpl Level 7 Level 7 (28,285 points)
    ZBurnett,

    The Lombard was the first-generation New World ROM powerbook and did not have all the features of the following 'book, the Pismo. As such, it does not have FireWire, does not support booting OS9 through the USB port (no PPC Mac supports booting OSX through USB) nor does it support Startup Manager via the option key at startup. There is no way to boot/run any external OS on the Lombard except from an older SCSI HD.

    Since your Lombard is still dying, here are a few comments and suggestions.

    -Again disconnect the keyboard ribbon cable and plug in a USB keyboard. You mentioned the 'book quit as you were typing out the registration form. This may just be coincidence, but a bad keyboard can be intermittent so you have to eliminate it by using the 'book without the built-in keyboard.

    -The modem does not really have to come out; iFixit is showing you a complete disassembly, but that is just one more piece of hardware to eliminate as a troublemaker.

    -Yes, the powerbooks can run just fine without a PRAM battery.

    -There is always the possibility of a hairline crack in one of the boards or a bad solder joint somewhere that opens when heated or stressed.

    -Does the aluminum heat shield/heat sink or the top of the CPU have a thin piece of material called a thermal transfer pad where heat from the CPU is transferred to the heat shield? Is the screw closest to the CPU in the heat shield present and tight?

    Since you were able to install OSX and reboot, apparently the 'book will run for a period of time, at least until you start working on it. Pressure from your hands or heat or a bad keyboard may cause a freeze or shutdown. I would give the installed OSX another chance without the keyboard and see what happens.
  • ZBurnett Level 1 Level 1 (90 points)
    Thanks for all the suggestions, and the answer to the remote boot. Oh- I have an older external SCSI with something on that... hmmmm I probably have better things to do than dig THAT out.

    I'm becoming convinced heat is the culprit one way or another.

    my point on the modem (I think this little board is the modem) was that you have to take it out to remove the keyboard all the way, It's on top of the cable there would be no way to pull on it with that board in place.

    Yes, actually I had put the heat shield back a little quick at one point, and did see that the screw next to the processor was not tightened well. By this time I had started over with an idea to partition the drive, since it continues to repair drive issues, so I started a new install. It got to where it needed disk two, but stayed up all night it was frozen (but hot) in the morning, and now it won't reboot via CD with the keyboard, modem and PRAM battery out. The heat shield was cranked down as good as I could.

    Is there anything else that can be done at the open firmware prompt. It seems like there should be more than: reset-nvram and reset-all
  • jpl Level 7 Level 7 (28,285 points)
    ZBurnett,

    There are other commands in Open Firmware but I am not familiar with them nor do I think they would help in this case.

    From your first post I was under the impression you had successfully been running 10.3 on this machine since you came from the Panther Discussions, but I should not have made this assumption. If this is a first-time effort running OSX, you may have one of the Lombards that will not run any version of OSX with memory in the top slot. The symptoms include one or more of the following: A failure to boot the OSX CD/DVD or if it does boot, a failure to install or complete an install, or if you get the install, a failure to restart to the HD, or if successful in restarting, random freezes and crashes.

    The upper memory slot will take low-profile or standard height 2.0" modules while the lower slot requires low-profile modules 1.5" or less in height. This measurement is the distance from the pins to the opposite edge. If you have a low-profile RAM module and it is 128 or 256MB, place it in the lower slot and leave the top/upper memory slot empty, then test.

    If you are concerned about the HD, boot to the 9.x CD > launch the Drive Setup in the Utilities folder on the CD > select your HD in the Drive Setup window > select Test Disk from the menu. If it fails, open Drive Setup Help from the menu and follow the instructions for zeroing all data, then run Test Disk again; repeat zeroing/Test Disk once more if it fails.
  • ali brown Level 7 Level 7 (26,465 points)
    Hi jpl,

    To familiarize yourself with the situation, perhaps you would like to review ZBurnett's other Topic Security updates killing a Lombard..., regarding this issue.

    ali b
  • jpl Level 7 Level 7 (28,285 points)
    Ali,

    Thanks for the link. I should have headed over there day-one for all the background. Unfortunately, it appears he has a hardware problem and was probably just coincidence he was involved with updates at the time.
  • ali brown Level 7 Level 7 (26,465 points)
    You're Welcome jpl!

    ali b
  • ZBurnett Level 1 Level 1 (90 points)
    Yes ... I had clarified that on the other forum. I've owned this machine for about a year and it ran 10.3 flawlessly the whole time. Prior to that, I would bet it was upgraded fairly quickly after 10.3 came out... I believe it went through all the major releases.

    I was still trying to attempt booting with the other keyboard, but I've got two problems there: 1) I have to take another computer down and my family keeps wanting the working machines to work! & 2) I lose the cmd-option-power reset capability so I have to yank the power when it gets stuck. Which sadly it still does/did last I tried.

    My theory on the updates is that something was marginal, and the updates exercised something more than it had been and it went down. I'm still wondering if this could be software induced. For example what controls the fan? Shouldn't that go on sometime? Maybe it's hard to tell if its running.

    Oh - I just realized that without a battery in the laptop, it is susceptible to power fluctuations, so I think I should plug one of those in while it's testing things. So is there no "Test Disk" function on the OSX disk? or are you mentioning this only because of the erroneous assumption that this never ran 10? The 9.X CD wanted to "initialize" the disk first so I did that... It's over there "Scanning for bad blocks..."
  • ZBurnett Level 1 Level 1 (90 points)
    Test disk found no bad anything... but I decided to finish the 9.2 install and while it was booting up it said:

    The built-in memory test has detected a problem with cache memory. Please contact a service technician for assistance.

    I also should mention that I repeatedly ran the TechTools Pro 3 tests with no issues found!

    It seemed to reboot to a workable OS9.2 screen... MacOS Setup Assistant - Oooo here's a trip down memory lane.

    So if I want to go to OSX should I first install 10.2 and then 10.3? Or just stay on 9? It will be tough to have this many OS's running in one house.
  • ZBurnett Level 1 Level 1 (90 points)
    Actually I meant to say that I had previously run TTP... not just now.

    All this ancient Internet stuff drives me crazy - I really don't want to remember how to operate OS9
  • Grant Bennet-Alder Level 9 Level 9 (51,750 points)
    The built-in memory test has detected a problem with cache memory. Please contact a service technician for assistance.


    I have never seen that error on a processor module that eventually proved to be just fine. Every time I have seen that message on a Mac, the situation has deteriorated over time and eventually the processor (or cache, if separate) had to be replaced.
Previous 1 2 Next