Previous 1 2 Next 26 Replies Latest reply: Aug 16, 2008 6:59 AM by wvfgolden
deepknight Level 1 (0 points)
Airport Extreme USB Disk Connection Issues

Like many on here I am experiencing various issues keeping USB hard drives mounted. I am using an Intel MacBook, OS X 10.5.1, Airport Extreme base station with the latest updates. I have three USB drives and one printer connected to the base station via a powered USB hub.

My issues are several...I have seen all of these conditions:

- USB Disks do not show up in finder at all, but DO show up in the Airport Extreme setup utility.

- USB disks show up in finder under the base station entry in Shared, but DO NOT mount when clicked on, or show up as empty.

- USB disks show up in finder under the base station entry in Shared and the first one clicked on mounts (shows up on the desktop) but the rest disappear from the list.

- Upon clicking on the base station entry in Shared in finder I get a "Connecting..." message that never connects or goes away.

All this is very frustrating and I have not found a way to work around it. I have tried connecting the drives directly to the computer (they connect almost instantly). They usually require repairing with the disc utility. I have also tried dismounting the drives before sleeping the computer. This works sometimes, but not consistently. They usually do not remount again after waking. Even rebooting the base station and computer doesn't fix this.

Does anyone know if Apple is aware of and working on this issue? I replaced my flawlessly working Linksys router with an Airport Extreme for the disk access feature alone. Any help is appreciated! Thank you.

Intel MacBook, Mac OS X (10.5.1)
  • GreyWullf Level 1 (25 points)
    Hi, I am experiencing exactly the same issues. I had everything working fine until I upgraded to Leopard. Up until last Sunday I had everything configured and ran like a charm.

    I have been experimenting with resetting the Airport Extreme, changing the settings, so far no luck.
  • QCSmith Level 1 (0 points)
    Grrrr.... Same issue, which is very frustrating since I was using the USB drive to house our iTunes library. Now iTunes thinks all the music is gone and the library will need to be rebuilt.
  • jason mead Level 1 (25 points)
    i have the same macbook and airport extreme. i am able to access all functions in finder. they no longer show up on the desktop at all, but access to printer and stored files is working well. this was not always the case. when i first upgraded to leopard i lost all wireless connectivity to the usb powered port and the printer and drives. i spent a few hours on the phone with apple and they could not find any solutions. we tried several work arounds.

    literally two weeks later after i unplugged the powered port, turned off all external drives and printers, reset my cable modem and airport, and restarted all computers it works flawlessly. their is no real reason in my mind for this to be a "solution". i just thought maybe this may work for you.

    Apple is aware i would assume based on my phone call....

    good luck.
  • GreyWullf Level 1 (25 points)

    I tried powering off everything (including the cable modem), reconnecting everything and then powering up (the airport extreme last). I have a belkin usb hub connected to the Airport. So my printer and usb drives are connected to the belkin.

    So far the printer works and my 500mb usb flash drive works as well. However my 500gb usb external drive still doesn't work.
  • GreyWullf Level 1 (25 points)

    I went to Finder >> Preferences >> General >> and under "Show these items on the desktop" checked the box beside "Connected Servers"

    Icons for my 2 USB drives connected to my Airport Extreme showed up instantly and are completely accessible.
  • deepknight Level 1 (0 points)

    I have had some success forcing a relaunch of the Finder, about half the time it will connect to at least one of the three disks. Still not very reliable...still trying...
  • kbuzz Level 1 (0 points)
    Ive had all the issues noted above. This really *****...tis the only reason i bought the extreme. OTOH both times i called mac they admitted its a "known issue" and were working on a fix
  • drmike5000 Level 1 (0 points)
    You all are missing the other thread where this issue is discussed in depth and solutions are offered. It's under "Bug Found in Airport Disk......" Anyway, there are 263 responses.

    The solution is basically to revert to Airport disk utility 7.1.1. This allows you to connect to the USB disk again. The problem seems to have come from the updated version 7.2.1 which seems to destroy AEBS functionality.

    You can get version 7.1.1 on if you don't have it.
  • Marcin Rogalski Level 1 (105 points)
    I'm still not connecting through Finder. It seems like some random updating of settings and rebooting of AEBS or unplugging and reconnecting the USB disk sometimes gets it working. Otherwise, it just hangs on connecting through the Shared sidebar.

    The only sure way of always connecting for me is just Go-Connect to server. Then just entering my AEs address allows me to log in as User or if just a disk then you can log in with the AEBS password. So Connect, then afp:// or 172... or 192..., whichever private DHCP you have. And it mounts for me.
  • Tom Alperin Level 3 (720 points)
    The bug seems to activate when a computer connected to the drive changes IP numbers while connected to the drive. This happens, for example, if your computer is asleep when the routers DHCP lease expires. If you remember when your drive decided to flake out on you, you'll probably remember it was right when you woke the computer up. Some drives are very stubborn about remounting after this, even when you reboot the router and need to be plugged directly into a computer to make them mount again. This is a bug that I am sure Apple is aware of and it should be fixed, however for now, here's some workarounds that have made my drive access very stable:

    1. Manually allocate IPs to as much hardware as is practical.
    2. Go to the DHCP tab in the AEBS unit and "reserve" IP numbers for the rest of your hardware based on their MAC addresses.
    3. Also on the DHCP tab, set the least time much higher than it is. At least a month, instead of just 4 hours.
    4. If you use your drive remotely, dismount the drive before leaving home or whenever you change networks. I have gotten into the habit of turning off my computer at these times as this correctly dismounts the drive.
  • Robert BeauprÚ Level 1 (65 points)
    the version tracker page for 7.1.1 gives a page not found response when you click on download. Any ideas?
  • ABarrow Level 1 (0 points)
    Tom seems to have hit the nail on the head. Everyone else here is talking about downgrading your firmware and changing the name of your wireless and such. The real issue (that I have at least) is that if my computer looses contact with the drive without unmounting it, then the drive will not come back online again unless I unplug it from the AEBS and into my computer directly. Then the drive can mount on my computer, but the folders will not show up in the finder (they will show up in the /Volumes directory in my console, however). A restart of the Finder fixes this.

    I have changed my DHCP settings on the router to give the same ip address to my laptop by the MAC address. We'll see if this makes a difference.

    Update: unfortunately now my hard drive seems to stay connected, but the Airport itself drops out after about 5 minutes if the drive is mounted. Then only a complete reset of the base station makes it come back online... and of course then I have to unplug the drive from the base station, mount it on my computer, then back into the base station. This product does not seem to work as advertised...
  • aggiecavediver Level 1 (0 points)
    This seems to have worked for me. computer hasn't gone to sleep yet, but it works ok for a now, will update if this doesn't keep working.
  • Henry B. Level 9 (78,690 points)
    Version 7.1.1 of the firmware is no longer available as a download from Apple's web site. Therefore, the link provided to it in Versiontracker is dead since Versiontracker does not itself keep files stored onsite - it merely provides links to where software can be found on the copyright holder's web site.

    Unless you have previously downloaded 7.1.1 - so that the file resides on your own computer already - the only other way to get it is for someone else to email it to you.
Previous 1 2 Next