Skip navigation
This discussion is archived

Sopcast on Mac OSX - Solution confirmed

109994 Views 30 Replies Latest reply: Jul 5, 2008 5:17 AM by kiwilegal RSS
1 2 3 Previous Next
sigoodwin Calculating status...
Currently Being Moderated
Dec 2, 2007 8:15 AM
Hi everyone, first post on these forums but Ive managed to get something working that a lot of mac users seem to be desperate for - sopcast.

You need a few different bits of software but I now have sopcast working perfectly on my macbook.

You will first need to download "Crossover"

Once installed, open the program and install internet explorer 6 (the programme automates this process for you)

Then go to the Microsoft website and download the .exe file for Media player 7.

Open crossover again and select "install unsupported application" - browser to the media player 7 .exe and install

Return to microsoft and download media player 9 and repeat the steps above.

Finally download sopcast .exe file from the sopcast site and install as above.

Sopcast can now be run from the applications folder!
MACBOOK, Mac OS X (10.5.1)
  • ncturk Calculating status...
    Currently Being Moderated
    Dec 8, 2007 3:11 PM (in response to sigoodwin)
    thank u so much never knew suck program existed
    imac intel, Mac OS X (10.4.11)
  • redshane Calculating status...
    Currently Being Moderated
    Dec 12, 2007 9:44 PM (in response to sigoodwin)
    Thanks so much... I have been looking for weeks to get this problem solved. However, I am still not up and running yet. I done everything you said...all downloaded. I get the sopcast working through the "crossover" folder, but it just says "playing" after I choose a TV link and screen is black!! Have you managed to get it working...anything else I need to do??

    Thanks
    S
    Macbook, Mac OS X (10.5.1)
  • moyooo Calculating status...
    got the same problem, says its playing, but its a black screen with some flickering.. i must say though, its the closest i've got so far since screwing everything up while trying to run lynux or windows to get sopcast... oh, the pain!
    thanks for the effort, hope someone figures out whats going wrong:)
    macbook, Mac OS X (10.5.1)
  • moyooo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 26, 2007 1:00 PM (in response to redshane)
    I GOT IT..... by pure accident..... it seems you need to download a codec to get it working perfectly.. if you click on the second icon to the left of the play button (while trying to watch a stream on sopcast), it opens windows media player.. the stream tries to play in wm player , but then a message pops up to inform you that a codec needs downloading.. follow the prompts and it directs you to the right page, then, YOU GOT IT.......
    MANY THANKS TO ORIGINAL POSTER x
    macbook, Mac OS X (10.5.1)
  • saimnsv Calculating status...
    Currently Being Moderated
    Dec 26, 2007 6:55 PM (in response to moyooo)
    Thanks moyoo and sigoodwin...i followed the instructions provided by both of you and sopcast now works on my mac!
    MacBook, Mac OS X (10.4.11)
  • ritesh_416 Calculating status...
    Currently Being Moderated
    Dec 26, 2007 10:26 PM (in response to moyooo)
    I was facing the same black-screen problem, but now it's working fine after installing the codec, as suggested.

    Thanks a ton to all.
    MacBook, Mac OS X (10.4.10)
  • Kybosh08 Calculating status...
    Currently Being Moderated
    Jan 1, 2008 11:06 AM (in response to moyooo)
    Hey,
    when I click that icon nothing happens...I was wondering did you have any suggestions? I have followed all instructions as above but it's not prompting me to install a codec and as a result I can't see anything!
    Macbook, Mac OS X (10.5.1)
  • rakery Calculating status...
    Currently Being Moderated
    Jan 5, 2008 4:14 PM (in response to Kybosh08)
    Kybosh08,
    Persevere. I followed the prevoius steps and met with some success obtaining live sopcast streams. I fished around as directed and the codec link did eventually appear. My problem now seems to be in the buffering, at about 30% the broadcasts are very difficult to watch. Does anyone have a solution?
    MacBook Pro, Mac OS X (10.4.1)
  • nerowolfe Level 6 Level 6 (13,070 points)
    Currently Being Moderated
    Jan 5, 2008 6:25 PM (in response to sigoodwin)
    Hi and welcome to the Apple forums. Always good to "see" a new face here.
    Happy New Year.
    Dual G5, MacBookPro 15, MacBookPro3,1 17 Core2Duo, Mac OS X (10.5.1), Vista Ultimate 64-bit on MBP/17", homebrew 3GHz PC, Dell Inspiron8k
  • neilg11 Calculating status...
    Currently Being Moderated
    Jan 6, 2008 9:11 AM (in response to Kybosh08)
    I also push the button to open media player and download the codec and nothing happens. Can anyone help me with this? My CrossOver shows that all the apps are installed, although when I installed Media Player 9 it told me "no available updates", although it still seems to be there.
    ANy help would be amazing. I am desperate!!!
    Thanks.
    MacBook Pro, Mac OS X (10.5.1)
  • moyooo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2008 12:31 PM (in response to neilg11)
    ok... all i can let you know is how it went down for me.. i'm not too techno minded.
    followed original instructions. nothing but black screen when sopcast should of been playing something. launched WMP by clicking the icon. WMP informed me that codec was required. followed the prompts and watched it download.. restarted crossover. launched sopcast.. still seemed to be the same problem. launched WMP by clicking the correct icon again and WMP asks if i want to install the codec. i clicked yes and it all started working correctly... even when it says playing, be patient, you should see something in about 30 seconds- provided there is nothing wrong with the selected channel.. hope it works for ya! i was over the moon when it worked for me..

    as for streaming quality, i guess it's all about the channel your trying to watch. but i usually go to http://livetv.ru/en/ via internet explorer and search for stuff on there. all the sports i watch seem to be easily found, and a streaming rating is given. i choose the highest rating for a sopcast compatible streaming of the event i want, and i'm as happy as a pig in *****,... with a beer in hand:) good luck!
    macbook, Mac OS X (10.5.1)
  • Hub\' Calculating status...
    Currently Being Moderated
    Jan 16, 2008 8:00 AM (in response to nerowolfe)
    To those who installed all good but to who nothing happens when they click on the left-icon to launch windows media player and install the plugin:

    I had the same problem, did the installation several times, was not working. Then, a little bit desperate, I clicked lots of time in a row on the famous left-icon, and wow miracle! It launched WMP and installed the plugin. Now Sopcast is working perfectly!

    So the solution is very simple, even stupide lol, but works very well: Just click like 10 times very quickly, like if you'd do a double-click, on the left icon, and normally it should work. If you have done the installation in a proper way, of course. All the softs must be in the same bottle (win98) !

    Sorry if my english is not perfect, Im not a native speaker.

    Hop it will work fine for you !

    Hub'

    Message was edited by: Hub'
    MacBook Core 2 Duo 2.2 Ghz 1Go, Mac OS X (10.5.1)
  • znoopyznoop Calculating status...
    Currently Being Moderated
    Jan 19, 2008 9:40 AM (in response to sigoodwin)
    Hi all!

    Ive managed all steps but the last it seems. When clicking the famous button to open up windows media player it keeps telling me the H264 plugin is missing. I keep installing FFdshow as suggested but keeps getting this error.

    Any suggestions?....

    Thanks!
    Mac OS X (10.5.1)
  • thg711 Calculating status...
    Currently Being Moderated
    Feb 12, 2008 7:31 PM (in response to Hub\')
    I got it to work - I have all the files ( zipped ) needed - if anyone has a server to host the files that would be great. let me know. 1 download instead of 4.
    Mac OS X (10.5.2), a windows convert 12/07
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.