Previous 1 2 3 Next 30 Replies Latest reply: Jul 5, 2008 5:17 AM by kiwilegal
sigoodwin Level 1 Level 1
Hi everyone, first post on these forums but Ive managed to get something working that a lot of mac users seem to be desperate for - sopcast.

You need a few different bits of software but I now have sopcast working perfectly on my macbook.

You will first need to download "Crossover"

Once installed, open the program and install internet explorer 6 (the programme automates this process for you)

Then go to the Microsoft website and download the .exe file for Media player 7.

Open crossover again and select "install unsupported application" - browser to the media player 7 .exe and install

Return to microsoft and download media player 9 and repeat the steps above.

Finally download sopcast .exe file from the sopcast site and install as above.

Sopcast can now be run from the applications folder!

MACBOOK, Mac OS X (10.5.1)
  • ncturk Level 1 Level 1
    thank u so much never knew suck program existed
  • redshane Level 1 Level 1
    Thanks so much... I have been looking for weeks to get this problem solved. However, I am still not up and running yet. I done everything you said...all downloaded. I get the sopcast working through the "crossover" folder, but it just says "playing" after I choose a TV link and screen is black!! Have you managed to get it working...anything else I need to do??

  • moyooo Level 1 Level 1
    got the same problem, says its playing, but its a black screen with some flickering.. i must say though, its the closest i've got so far since screwing everything up while trying to run lynux or windows to get sopcast... oh, the pain!
    thanks for the effort, hope someone figures out whats going wrong:)
  • moyooo Level 1 Level 1
    I GOT IT..... by pure accident..... it seems you need to download a codec to get it working perfectly.. if you click on the second icon to the left of the play button (while trying to watch a stream on sopcast), it opens windows media player.. the stream tries to play in wm player , but then a message pops up to inform you that a codec needs downloading.. follow the prompts and it directs you to the right page, then, YOU GOT IT.......
  • saimnsv Level 1 Level 1
    Thanks moyoo and sigoodwin...i followed the instructions provided by both of you and sopcast now works on my mac!
  • ritesh_416 Level 1 Level 1
    I was facing the same black-screen problem, but now it's working fine after installing the codec, as suggested.

    Thanks a ton to all.
  • Kybosh08 Level 1 Level 1
    when I click that icon nothing happens...I was wondering did you have any suggestions? I have followed all instructions as above but it's not prompting me to install a codec and as a result I can't see anything!
  • rakery Level 1 Level 1
    Persevere. I followed the prevoius steps and met with some success obtaining live sopcast streams. I fished around as directed and the codec link did eventually appear. My problem now seems to be in the buffering, at about 30% the broadcasts are very difficult to watch. Does anyone have a solution?
  • nerowolfe Level 6 Level 6
    Hi and welcome to the Apple forums. Always good to "see" a new face here.
    Happy New Year.
  • neilg11 Level 1 Level 1
    I also push the button to open media player and download the codec and nothing happens. Can anyone help me with this? My CrossOver shows that all the apps are installed, although when I installed Media Player 9 it told me "no available updates", although it still seems to be there.
    ANy help would be amazing. I am desperate!!!
  • moyooo Level 1 Level 1
    ok... all i can let you know is how it went down for me.. i'm not too techno minded.
    followed original instructions. nothing but black screen when sopcast should of been playing something. launched WMP by clicking the icon. WMP informed me that codec was required. followed the prompts and watched it download.. restarted crossover. launched sopcast.. still seemed to be the same problem. launched WMP by clicking the correct icon again and WMP asks if i want to install the codec. i clicked yes and it all started working correctly... even when it says playing, be patient, you should see something in about 30 seconds- provided there is nothing wrong with the selected channel.. hope it works for ya! i was over the moon when it worked for me..

    as for streaming quality, i guess it's all about the channel your trying to watch. but i usually go to via internet explorer and search for stuff on there. all the sports i watch seem to be easily found, and a streaming rating is given. i choose the highest rating for a sopcast compatible streaming of the event i want, and i'm as happy as a pig in *****,... with a beer in hand:) good luck!
  • Hub' Level 1 Level 1
    To those who installed all good but to who nothing happens when they click on the left-icon to launch windows media player and install the plugin:

    I had the same problem, did the installation several times, was not working. Then, a little bit desperate, I clicked lots of time in a row on the famous left-icon, and wow miracle! It launched WMP and installed the plugin. Now Sopcast is working perfectly!

    So the solution is very simple, even stupide lol, but works very well: Just click like 10 times very quickly, like if you'd do a double-click, on the left icon, and normally it should work. If you have done the installation in a proper way, of course. All the softs must be in the same bottle (win98) !

    Sorry if my english is not perfect, Im not a native speaker.

    Hop it will work fine for you !


    Message was edited by: Hub'
  • znoopyznoop Level 1 Level 1
    Hi all!

    Ive managed all steps but the last it seems. When clicking the famous button to open up windows media player it keeps telling me the H264 plugin is missing. I keep installing FFdshow as suggested but keeps getting this error.

    Any suggestions?....

  • thg711 Level 1 Level 1
    I got it to work - I have all the files ( zipped ) needed - if anyone has a server to host the files that would be great. let me know. 1 download instead of 4.
Previous 1 2 3 Next