Previous 1 8 9 10 11 12 Next 170 Replies Latest reply: Dec 9, 2008 2:29 PM by kid02155 Go to original post
  • jdonlin Level 1 (0 points)
    Same problem here. The problem lies in the wireless drivers provided by apple and only affects the laptops using the broadcom card. I called apple and they said that they did not even recognize it as a problem. We need more people to call in and complain about this issue and hopefully a driver update will come out soon.
  • Gr8h8m Level 1 (5 points)
    Hi there all,
    no I haven't lost interest in this topic - but have been way too busy to give it much attention for a while. Turning the WiFi radio off and disabling Kdbmgr make my XP set-up work ok for me though in the meantime.
    For avoidance of confusion however, despite what Jdonlin (hello!) has said above, this issue is not exclusive to Broadcom cards - my MBP uses an Atheros AR5008 f'rinstance...
  • holdypaws Level 1 (0 points)
    I have the same pop/crackle issue in XP SP3. If you load up "Latency Checker" ( it becomes obvious that there's a real problem that Apple is not yet addressing.

    There are multiple issues causing the latency. Nerds on the audio forums have almost completely eliminated it by doing the following:

    1. Disable your wireless adapter
    2. Kill the KbdMgr.exe process
    3. Disable write combing in Display Properties, Advanced, Troubleshooting
    4. Disable PowerMizer in the nVidia control panel

    More information can be found here...

    In my case, the wireless driver is the #1 culprit. This means that before I can listen to music, watch a movie, etc. I need to disable wifi or else tolerate pops and clicks every few seconds. Still seeking a better solution..

    Good luck.
  • Gr8h8m Level 1 (5 points)
    Heheh....well yes you're quite right holdypaws, which is the reason for this very topic. As it stands I can't totally disable my Wi-Fi card within Device Manager without the computer locking up.....same as most of the above...
  • jammy101 Level 1 (0 points)
    Hi All,

    i've got nothing much useful to add here except to say that i have the same irritating problems with my Macbook Pro as most here, but after reading silent_argus's post about certain programs starting the annoying latency stuttering problem i thought i'd add that on my MacBook Pro a combination of Firefox (2 or 3) and Windows Live Messenger usually starts the stutters off. especially if there's a high volume of Messenger traffic (two or three conversations at once will almost certainly bring it on fast).

    this seems to be exclusive to Windows XP for me ... i've never had any problems with lockups or stuttering under OSX, but then i use Windows a lot more than OSX so the problems may be there and i've just not noticed them yet. now there's something to look forward to.


    MacBook Pro 17"
    core2 T9300 2.5Ghz
    crappy broadcom WiFi

    running Windows XP SP2 + OSX 10.5.4 via BootCamp 2.1
  • holdypaws Level 1 (0 points)

    Perhaps you could try an alternative to Live Messenger that's lighter, such as Miranda.

    Just curious. Without Firefox and Live Messenger running, what does Latency Checker report for you?

  • holdypaws Level 1 (0 points)
    Here is a workaround that works for me.

    I use VMWare Fusion (2.0 Beta 2) to load my Boot Camp partition inside OS X. Fusion is free, for now, and it works pretty well.

    When running my XP partition as a virtual machine and using wireless, I can play music without skips in BOTH the XP VM and OS X.

  • Gr8h8m Level 1 (5 points)
    Hi holdypaws - neat that you've managed to work around the issue with Fusion, but unfortunately that has too many drawbacks at the mo - biggest being lack of Firewire support, plus I just want to running XP natively, utilising 100% of the CPUs horsepower.
  • jammy101 Level 1 (0 points)
    Hi Randy,

    i finally got round to running the DPC Latency checker. with Firefox 3, Live Messenger, Outlook Express and AVG Free running under XP SP2 the average Latency is about 2000us with spikes off the scale every so often.

    with none of those programs running though the latency was ...exactly the same (even after a reboot, not just shutting them down). which is odd.

    so i disabled the WiFi, the Ethernet and the Bluetooth and that did precisely nothing to the latency graph.
    then i killed the keyboard manager process and the latency dropped down to 250 and has been there ever since, with occassional spikes up to 3000 or so.

    so i take back all the nasty things i said about messenger ... although it still might be causing the spikes. i'll have to have a play around with various program combinations.

    sick of computers.
  • tlou37 Level 1 (10 points)
    Just found this thread and am having the same problems as the rest. Enabled WiFi and voila, no more hangs. I'm wondering if Gr8h8m has heard anything back from the powers that be in Cupertino.
  • Gr8h8m Level 1 (5 points)
    Hi there. No, I haven't had any further updates to share from Apple - haven't heard anything in months actually after doggedly getting this problem flagged up by the powers-that-be. I should probably double-check that they really have flagged it up - maybe you should too!
  • jdonlin Level 1 (0 points)
    I have found drivers that solve this problem. These are specifically for Windows XP and provided by HP.

    I have uploaded them to my filefront page. 4c729a8ad4d6aede53e440e4a654b2ba424e0ea949
    If you do not trust the fact that it is an executable, scan it on

    With these, I no longer have random disconnections or jittery audio//video from time to time. Best of all, I can disable the wireless.

    Good luck.
  • Gr8h8m Level 1 (5 points)
    That is big news if true! Downloading to test out now.. brb...
  • Gr8h8m Level 1 (5 points)
    Ok..knew I shouldn't have got excited. Just so you know, these are Broadcom drivers and not *Atheros AR5008* drivers. Back to living in hope...
  • Irukichan Level 1 (0 points)
    The broadcom driver previously linked seems to do some good as far as audio pops go but it doesn't entirely eliminate the problem for me. T_T I was very hopeful. However, I've not managed to lock up my system disabling the wireless since I installed the driver so that's one positive effect I guess?

    Come on, apple, step up and fix it @_@ The representative that I talked to also said they didn't recognize it as a problem, even when they looked at the forums. :Y