Previous 1 2 Next 16 Replies Latest reply: Dec 4, 2007 4:19 PM by baltwo
John NYC Level 1 Level 1
Apple removed the key shortcut for strike through in Text Edit. It is now only accessible as a Font Style via the pulldown menu.

OK, so this strikes many people as a minor change, but Text Edit can no longer be used as it is for editing / revisioning text documents, and for making task lists (which many people used with the strike through to indicate completed tasks).

Seems like a completely unnecessary change to me.

PowerBook G4
  • varjak paw Level 10 Level 10
    You can make suggestions to Apple regarding Mac OS X by submitting feedback here:

    http://www.apple.com/feedback/macosx.html
  • baltwo Level 9 Level 9
    Better is to send a bug report (or enhancement request) to Apple via its Bug Reporter system. Join the Apple Developer Connection (ADC)—it's free and available for all Mac users and gets you a look at some development software. Since you already have an Apple username/ID, use that. Once a member, go to Apple BugReporter and file your bug report/enhancement request. You'll get a get a Bug ID number; thus, starting a dialog directly with engineering.
  • baltwo Level 9 Level 9
    Interestingly, I just launched TextEdit 1.4 from Tiger, while booted into Leopard and can see no way to do a strikethrough. It's not under styles nor under styles->other. I must be doing something differently, but I don't see it in either version.
  • Al Van Malsen Level 6 Level 6
    I could not find it either on my G-5 iMac which is running Tiger or my Intel iMac which is running Leopard. I didn't know that you could do a strikethrough with Text Edit but if you can that would be very useful.
  • Computer Arts Level 2 Level 2
    You have to roll your own.

    1. Make a new document
    2. Choose Strike Through from the pull down menu as you have been doing manually
    3. Back in the the new document pull down the Format menu, then Fonts then Style and *Add to favorites*
    4. Give the style a name, Strike Through
    5. Now when you need to use a strike through choose it from the Styles menu.

    Yes, it is a more steps than we are used to. Hopefully Apple will add it back or someone will come up with a way to add it to the menu. I imagine that we could use Automator, I am in the midst of project right and I will see what I can do in that regard later.
  • baltwo Level 9 Level 9
    And, how does one do step 2? I can't find a *strike through* option or setting.
  • varjak paw Level 10 Level 10
    First you need to set the Preferences to show the ruler (you need to open a new document or reopen the one you're working with). Then find the Styles pulldown in any Text Edit window, left side of the window, just above the ruler bar (at least in Leopard; I don't have a Tiger system to check that version) and there's a "Struck through" selection.
  • baltwo Level 9 Level 9
    Show ruler is enabled. Select the Styles pulldown and only these are visible:

    Default
    Bold
    Italic
    Outlined
    Shadowed
    Other

    There's no Strikethrough; nor is there one in Tiger. Maybe you've applied some hack in a earlier version to the .plist using the defaults write command.
  • Computer Arts Level 2 Level 2
    baltwo wrote:
    And, how does one do step 2? I can't find a *strike through* option or setting.


    Sorry, it is an icon and not a label per se, but "Strike Through: will pop-up when you mouse over it. Anyway, here is more detail on finding it:

    Pull down the Format menu and then *Show Fonts*. A window will open showing fonts installed and sizes. You will, or should see, above the font list, some icons in a horizontal row; a "T" with an underline, "T" with a strike through it, a "T" with a color along side of it (click on that to change font color), and a page icon where you can set the paper color. From those options you can set a number of styles.

    Pull down the strike through icon and you have some choice including a color strike through.

    Mess around in that window and you will see the things that you can do.

    Gotta run, I have dinner calling me
  • baltwo Level 9 Level 9
    Ah! Thanks for the clarifying details. So, simplest way to apply is to select the text, CMD+T, click the icon, and select an option.

    *For the OP*

    As noted earlier, I think that's the same behavior as was in Tiger. I don't know of any way to add it to command key or add it to the styles menu.
  • Michael Conniff Level 7 Level 7
    baltwo wrote:
    Show ruler is enabled. Select the Styles pulldown and only these are visible: …
    There's no Strikethrough; nor is there one in Tiger. Maybe you've applied some hack in a earlier version to the .plist using the defaults write command.

    You're missing "Struck through" and "Underlined" from that list, below "Shadowed" and above "Other", at least in Leopard. In Tiger I see what you listed.

    (and no hacks here )
  • baltwo Level 9 Level 9
    That's correct. *Struck through* and Underlined are missing.

    *For the OP and other posters:*

    I just figured out how to add them. Select some text, CMD+T, select underlined or strikethrough option, go back to text document, click in the selected text to unhighlight it, click on the styles dropdown, select other, click on add to favorites, give a name (as above), and click OK. Quit TextEdit, relaunch, and those styles persist. However, I see no way to delete them.
  • Al Van Malsen Level 6 Level 6
    Thanks for explaining that. I never would have figured it out!!
  • baltwo Level 9 Level 9
    Glad to help. I just learned how experimenting with TextEdit based on this topic. Sometimes you just have to try various things until something works out. Now, if only Apple would document this stuff properly; there's only cryptic BS in the help files. Now, hopefully, the OP pops back in, notes the solution, and marks the topic, accordingly.
Previous 1 2 Next