2 Replies Latest reply: Dec 20, 2007 3:17 AM by rollmyown
Michael Fuller1 Level 1 Level 1 (5 points)
After upgrading to Leopard from Tiger, I loss the ability to print to a network printer (HP LaserJet 2100M). I can set up the printer and it shows up as idle when first set up. But when I try to print a document the printer mode shifts to "paused". If I hit the "resume" button, it simply reverts back to paused mode. In other words, I can't take the printer out of paused mode. I can see the document in the queue.

I try downloading and installing the current version of the driver from HP, and I set up the printer using it's IP address for location and choosing the new driver. I also tried deleting the printer from the printer list and adding it back again, but the problem remains.

Any ideas?
Mike

MacBook 2GHz Intel Core 2 Duo, Mac OS X (10.5.1), 1 Gb 667 MHz DDR2 SDRAM
  • casey.goose Level 1 Level 1 (0 points)
    I have almost the exact same problem (except with a different printer). I am also running Leopard and trying to print to a network printer. I can print the first document just fine but after this the printer is paused and will not resume. If I restart my computer I can then print the document, but I really don't want to have to restart every time I need to print something! Any suggestions?
  • rollmyown Level 1 Level 1 (0 points)
    hi mike

    i just worked my way out of what seems like a very similar situation with my network printers and a brand new macbook pro.

    the original network was simple: there were 3 macs sharing 2 HP printers, all running Mac OSX Tiger 10.4.11. the printers were connected to the network by motorolla wireless print servers which have two ports: a parallel and a usb. each printer was connected via usb to a separate print server (only because it was hard to find a wireless print server with two usb ports; otherwise, there's no need for two separate print servers).

    the macbook pro replaced one of the 3 original macs and came factory-loaded with leopard...so it was a clean install. leopard recognized each printer instantly when connected directly to the macbook pro via usb (pretty sweet how fast this process was too...it took all of 3 seconds!).

    the problem occurred when i went to set up the printers to print wirelessly. the printers/printservers are both on fixed unique IP addresses which i assigned for simplicity in locating the print servers when i need to fix something. on the tiger machines, these printers were installed as IP printers using the line printer daemon (LPD) protocol. the queue name was left blank/automatic.

    leopard has made some changes to the ways in which printers can be added to the system. tiger allowed you lots of options: system preferences, from certain applications, and also from the printer setup utility. apple seems to have wanted to streamline this process with leopard, so they nixed the printer setup utility and print center.--i was used to setting up the printers from the printer setup utility, so the changes threw me at first. the interface in leopard when going through the add-printer process is very different and just slightly more limited in terms of your setup options. i went through the setup process, entered the information i could in the fields provided, swallowed, and the tried to print a test page.

    the result was very similar to your situation. everything looked good, green lights, no flashing errors...but nothing happens! the print job hung in limbo, waiting for the printer to connect. after a long while (i waited a few minutes and checked at all the cable connections in the meantime), the printer queue dialog read 'paused'. so i hit the resume button, but then the document status went from 'printing' to 'stopped'. i hit resume on the printer status and resumed the document as well. back to 'paused'. i tried pinging the print server IP addresses. perfect, no lost packets--obviously the computer and the printserver could see eachother, but something was mucking up the communication connection.

    i then did some tests: i cancelled the document that was hanging, then went to make sure the printer could print from the tiger machines. perfect--which meant the printers and network was functioning normally. i tried printing again from the leopard machine, this time from several different applications...no printing, hanging jobs and paused print status.

    there seemed to be several possibilities:

    1) the printer driver i was using was either bad/corrupted or incompatible somehow with leopard.

    2) the printer setup had not been configured properly.

    3) the installation of the leopard OS was somehow corrupted or damaged.

    it didn't seem likely that there was a problem with the OS, because the machine is brand new with a factory install of leopard. but it was possible that the driver was incompatible, or corrupt in some way. it was also very possible that i had somehow mucked things up by the way i setup the printers (human).

    i tried everything easy: i restarted, zapped the PRAM, tried logging in as a different user (didn't make a difference), trashed the printer preference files, logged out/in to rebuild them, added another printer queue making sure i didn't make any obvious mistakes, etc.

    then i tried more time-consuming things, like resetting the printer system, restarting, adding the printers again, test printing, checking software updates for both the mac itself and the printer driver, downloading fresh copies of the current driver, saving them just in case i wanted to change the driver out.

    on the tiger machines, i had been using a linux printer driver (hpijs) without issue. the mac is built on unix, and uses CUPS (Common UNIX Printing System) to manage printing devices. the hpijs driver is made for CUPS, so i knew that these drivers worked in my network configuration. it didn't make sense that an upgraded version of my driver would change whether or not i got any print out at all. the problem didn't seem to be with the driver or the printer or the computer or the operating system. it was more like a communication error. it was more like ringing someone's phone and you can hear it ringing, but at their place everything's quiet, and no one knows you're trying to reach them.

    i went back to the system preferences print/fax pane and looked for options in the setup process that might help. i tried a lot of different things, all to the same, printless result. while scanning tech board and support articles to look for a solution, i stumbled on to a web-based CUPS interface for managing the printers. since macs use CUPS, you can manage your printers from a web page and skip leopard's system preferences interface. the CUPS interface is really simple and direct (and I think, in this case, not as pretty, but easier to navigate). i tried adding my printer here in the CUPS interface...now there are no automatic settings here, so i was forced to think about each field as i entered the printer name, the location, and the printer's queue name. thing is, i had been letting leopard automatically format my queue name, so i really didn't understand how the name was supposed to be formatted. i knew that the protocol was line printer daemon (LPD) and that the IP address of the printserver was the 'host name'. the thing is, there had to be some kind of way to let the server know that i was trying to print to the USB port and not the parallel port. that's when i remembered somewhere that the parallel port was named l1 and the USB was named l2. after appending the l2 to my queue name, i tried printing a test page, fingers crossed.

    click. zhhhh. yes--printer heaven.

    so what does this all mean? in leopard the printer setup doesn't necessarily do everything properly for your setup when you leave certain things to 'automatic'. the things you should look at are:

    1. know your printer driver is compatible. leopard has a lot of drivers that come with the OS on the OS DVDs. Do the additional installs option on disc 1; here you'll be able to choose drivers by your printers' manufacturer to install on your machine. or if your printer isn't supported, i'd point you toward an-open source UNIX driver like the ones at *http://www.linux-foundation.org/en/OpenPrinting* there are lots of drivers here to match all kinds of printers, especially good for finding drivers for older printers that aren't getting updated by the original manufacturer.

    2. add your printer through the CUPS interface and skip the printer preferences pane. you can get to the CUPS interface by opening Safari and pointing it to this address: *http://localhost:631/*
    just be careful when naming your printer because you cannot enter any spaces in the printer name field. you cannot use spaces, # or/ symbols in the name. for example, in my case, HP_7200 was the name i gave my +HP OfficeJet 7200+. then you'll select a device type. if you're using a printer/printserver that has an IP address assigned automatically or specified by you, you'll likely want to choose 'lpd/lpr host or printer'.

    3. you'll also need to specify a queue name, and it needs to be formatted properly. the CUPS interface actually shows you examples of how it's supposed to look. in my case, because the printer protocol was LPD, the queue name should be something like lpd://hostname/queue the hostname was the IP address of the printserver and the queue was the port, in this case USB port, or l2. so the queue name looked like this: lpd://123.456.7.8/l2 you should know how many ports your printserver has, and which one you're trying to print to. if you only have one, it's likely named l1.

    4. send a test print from the CUPS interface. if you formatted the setup properly, you should be a happy camper again.

    that's what happened in my case, and hopefully will give clues on how to fix your situation (sorry this is so long-winded, it's just very satisfying to have solved this little pickle...plus my machine can print now!)

    peace. gotta go catch some shut-eye.