3 Replies Latest reply: Dec 6, 2007 8:07 AM by dpwaters72
dpwaters72 Level 1 Level 1 (0 points)
Okay, I bought the Airport Express Base Station because it supports Vista to play my itunes on my home stereo. I am completely lost here. The device came with a version of software (v4.2) that doesn't support Vista and when you try to update the software, it complains because my Airport Utility is to old. Why has Apple made it so hard to us this device on a Vista machine when they advertise that it works with Vista?

Any help would be greatly appreciated.

Gateway, Windows Vista
  • Tesserax Level 8 Level 8 (48,940 points)
    Interestingly, Apple doesn't provide the new AirPort Utility as a download since it's provided on the installation CD that comes with the new 802.11n AirPort Extreme Base Station. Have you tried contacting Apple for a replacement CD?

    As an option, here's a workaround...
    o Download a copy of the Less_MSIerables utility to the Windows Vista desktop, and then, extract it to a folder of your choice.
    o Download AirPort Base Station Update 2007-002 for Windows to the Windows Vista desktop.
    o Use a program like winrar or winzip to uncompress that file to a new folder
    o Next go to the folder in which you extracted Less_MSIerables.
    o In a subfolder you will see a file called lessmsi.
    o Right-click on this file, and then, click "Properties."
    o Click on the "Compatibility" tab.
    o Enable the option "Run this program in compatibility mode for: Windows XP (Service Pack 2)."
    o Click "Apply," and then on "OK."
    o Right-click on the lessmsi file again.
    o Choose "Run as administrator," and then, after the program starts click on the "..." button to browse to the folder where you unzipped AirPort521Update.
    o Select "APSetup," and then, click "Open."
    o Select "APUtil.exe," and then, click "Extract" to extract the file to the Vista desktop.
    o A file folder will appear with a name like cab#APSetup.cab1.
    o Open that file folder and you will see a file named: APUtil.exe.
    o Either run APUtil.exe from it's present location, or copy it to its final destination.
  • dpwaters72 Level 1 Level 1 (0 points)
    Yes, this only works with Airport Admin Utility 5.0 or higher. The install CD came with Airport Admin Utility 4.2 and I can't find an update no where for it.