6 Replies Latest reply: Dec 6, 2007 8:36 PM by cornelius
vray56 Level 1 Level 1 (0 points)
Need some help/advice here. Been organizing and deleting several years worth of old stuff on a couple accounts and an external 40G firewire. Everything secure empty trashed just fine from my admin account. Transferred a bunch of stuff to another standard account. Organized and trashed gigs worth of stuff between this standard account and the external f/w. Secure empty trashed fine on the standard account. Then tried to secure empty trash on f/w. Most items went away fine but process then got stuck on 108 items. The disk just keeps grinding away, sounding like a secure delete, but nothing further gets deleted. It'll sit like this for hours, spinning away with zero progress. I stopped the process and removed all the items except one empty folder from trash, thinking I'll narrow the offending file down one at time, but all that happened was all the removed files copied to desktop and the single remaining folder did not delete. I put the new copies from desktop into trash and now I have double the untrashable. Tried regular empty trash to the same effect. What did I do, or what can I do?

PbookG4, Mac OS X (10.4.10)
  • cornelius Level 6 Level 6 (17,825 points)
    vray56:

    Welcome to Apple Discussions.

    Putting too many items in the Trash to be deleted at once can fill up the caches as the Trash needs to count all items to be trashed. Try this:
    Create a folder on Desktop and name is something like 2BTrashed
    Move all items in Trash to folder
    Shut down computer completely (not Restart)
    Start up computer and log in
    Open folder on Destop and drag a few items into Trash and delete. If it refuses to delete hold down the Option key as you delete.
    Continue this process of deleting a few items at a time (not more that 8-10) until you have deleted them all.

    If you run into further issues please do post back and detail exactly happened and at what point.

    Cheers

    cornelius
  • vray56 Level 1 Level 1 (0 points)
    Thankyou. Was wondering if i had overdone it a bit. I'll give it a shot, but won't have a chance til a little late this eve. It'll be a couple hours but I'll let you know.
  • vray56 Level 1 Level 1 (0 points)
    Ok, tried to remove items from trash but only copied them to desktop folder, the original items stayed in Trash. Tried shutdown/reboot and same thing, items stayed in Trash. I could delete some of the trash copies that wound up in the desktop folder, but the original trash items remain there, immovable. Could this be a permissions issue?
  • cornelius Level 6 Level 6 (17,825 points)
    vray56:

    +Could this be a permissions issue?+
    Could be. I am not sure. No harm in Repairing Disk Permissions in Applications > Utilities > Disk Utility.

    I am not sure how you went about removing items from Trash. I just tested it. All I did was open Trash basket by selecting it in the Dock. When the window opens I simply selected the item to move to the desktop and dragged it there. It moved it completely.

    Can you tell me exactly what you did?

    Cheers.

    cornelius
  • vray56 Level 1 Level 1 (0 points)
    Good evening again. Well, the situation is not yet resolved. Last nite i tried to drag items from external f/w trash to standard account desktop folder as you advised. But still, it will only copy the trash items to folder, will not move them to folder, thus I'm unable to try your suggestion of deleting a few at a time. I found that I could delete the items from the standard account trash. I thought perhaps corrupted disk or file permissions. So tried to verify/repair disk permissions on my 40G internal after verifying disk. Disk Utility immediately says:

    "Disk Utility stopped verifying permissions on “HD37.25” because the following error was encountered: No valid packages"

    I posted on this message last nite and turns out there's no basesystem.pkg in my library/receipts so I couldn't run DU. The recommendation i received was to archive and install, which would put the basesystem.pkg back in its appropriate folder, and that's what I'm preparing to do tomorrow. So this has grown into a couple issues i guess. It's been a couple years since I did any real maintenence or organizing and I think this shows i shoulda been a little more diligent with the maintenence and more carefully organized.

    So I'm thinking I'll take one at a time, archive/install to get the basesystem.pkg, so I have a clean system and canrun DU again, perhaps this will fix whatever the trash issue is. But that's tomorrow, is there anything i can try tonite on the trash?
  • cornelius Level 6 Level 6 (17,825 points)
    I am having a bit of a problem understanding your setup. For example when you say, "i tried to drag items from external f/w trash to standard account desktop folder", are you saying that you are booted from an external firewire HDD? Where is the "standard account desktop folder"? Is it on the firewire HDD or on the internal HDD? Excuse my obtuseness; it may be because I am not a night person and it is getting past my bedtime. In other works, can you clarify your computer setup from which you are working, please?

    In terms of the Archive and Install, I suggest that you make sure you have a good up-to-date backup before attempting any major operation. You don't want to complicate the issue any further.

    It may be possible to use Pacifist to extract whatever you need to install from the disk and install it in your OS. It will save a bit of hassle.

    You may also want to take a look at Dr. Smoke's FAQ Solving Trash Problems to see if it offers any clues to your situation.

    I think I will clock out for the night.

    Good luck.

    cornelius