7 Replies Latest reply: Dec 20, 2007 3:07 PM by dustinvbu
Don Louv Level 1 Level 1 (15 points)
I can't seem to get any other machines to successfully connect to FTP.

The ONLY thing that seems to work, is FTP access from the server itself to itself. (ftp://username:password@server in safari opens a finder window)

From anywhere else, the connection times out. "Server took too long to respond"

Clean install of Mac OS X Server 10.5 (upgraded to 10.5.1)
LDAP users.

Anonymous or User authenticated. Neither works.
Turn off Firewall entirely. Didn't help.
Server::Settings::Access - All Services accessible by all users and groups.
Server::FTP::Settings::Advanced - tried all three options (FTP Root & share points. Nothing worked.

FTP.error.log contains many of these line. nothing else:
launchproxy [37815]: /usr/libexec/xftpd: connection from <ip address> on port: 55592

FTP.transfer.log is blank. (no surprise)

This used to work fine on my 10.4 server.

What other logs should I be looking at for clues?

Mac Mini, Mac OS X (10.5.1)
  • Don Louv Level 1 Level 1 (15 points)
    More info:
    I've tried access via other 10.5 machines, Windows 2000 & XP machines, and "appliance" devices that use ftp. I've tried Safari, Firefox, IE, and ftp clients (transmit, cyberduck).
  • Don Louv Level 1 Level 1 (15 points)
    anyone wanna suggest logs I can watch to see why it just times out? please? help...
  • dustinvbu Level 2 Level 2 (170 points)
    I host six websites -- five I manage internally, and one is for a friend who obviously does not live in my home and therefore does not share my network.

    I can login to the FTP server fine from the local network, but I my friend who is accessing it externally is having the same, exact issue that you are. Firewall configured correctly, as is DNS. I have no idea what's going on, so any help for us would be appreciated.

  • Jack Zahran1 Level 1 Level 1 (50 points)
    On Tiger Server, FTP clients required Active FTP connections (as opposed to Passive). That means that you have to set the FTP client to Active. And, you need port 20 open on your firewall. I don't know if Leopard removed this limitation.
  • dustinvbu Level 2 Level 2 (170 points)
    figured it out. In addition to active FTP, the client has to use secure FTP to work.
  • Don Louv Level 1 Level 1 (15 points)
    Was "insecure ftp" support removed from Leopard?

    My "client" can't use Secure FTP. It is an internet camera that has it's own firmware ftp client. I can't exactly ask them to upgrade their firmware to support secure FTP because Macs don't work.
  • dustinvbu Level 2 Level 2 (170 points)
    About that, I don't know. I am completely new to the Mac OS X Server environment and was kind of befuddled when standard FTP simply did not work. The only solution we could find was to use secure FTP, which does solve the problem.

    It doesn't seem right to me that (despite its insecurity) standard FTP does not work, but I am, unfortunately, not knowledgeable enough about the server environment to fix it any other way.