Previous 1 2 3 Next 67 Replies Latest reply: Mar 23, 2008 12:10 AM by skicolorado1718
Jacob Rome Level 1 Level 1 (25 points)
Hi,

I am getting errors connecting to WiFi networks with my iPod Touch. This had affected a Touch I got a couple months ago. Initially, the WiFi worked perfectly on my WEP network and several others. Then, one day, I couldn't get any WiFi. After standard troubleshooting steps (forget network & re-enter, reset network settings, restart, restore iPod, etc.), it still wouldn't work. I returned the iPod and bought another. At first it also worked perfectly on any WiFi network I joined.

But now I'm affected by the same issue. This time, I went to the router settings and saw that the router (a Linksys) had assigned the iPod Touch an IP address. Yet, in the settings pane on th iPod Touch, the iPod had no IP address. I just ahead and reset all network settings, forget the network, reset the update and still nothing. And this was recently after updating to 1.1.2 firmware.

Given that this has now happened to iPod Touches, I'm concerned that it may be an issue that is affecting others. Any suggestions? The error I get in Safari is "Safari can't open the page because it can't find the server."

iPof Touch 16GB, Other OS
  • Bresaur Level 1 Level 1 (0 points)
    I have had the same exact problem with my Ipod touch. Could not connect to home network with Linksys router. Linksys tech support was no help to me, and Apple couldn't help either.

    In wifi settings I tried wiping out the address in the DNS field and input instead the same address there as was in my router field.

    This worked for a few days and I was able to get online. Then yesterday it stopped working, mysteriously all the wifi settings were wiped clean. I wound up doing a full reset erasing all data and trying again. So far wifi has been working.

    It is clear to me that Apple needs to respond with a software patch for this issue.
  • Touch This Level 1 Level 1 (0 points)
    Having a similar problem. Ipod finds the network and the signal is really strong. But when I go to Safari to open a page I get "Safari can't open the page because it can't find the server." It seems that this problem only started after the last update.
  • manuelrimora Level 1 Level 1 (0 points)
    i got my ipod on sunday. Since then i've been trying to use the wifi. I have not seen that safari work.
    ?????????? What should i do????????
  • mingliang Level 1 Level 1 (0 points)
    I have the same problem as you people. I just bought the ipod touch few days ago in Taipei. The wi-fi signal at my home is strong, as indicated by the signal icon. When I got "Safari can't open the page because it can't find the server." error.
  • MusicAllTheWay20 Level 1 Level 1 (0 points)
    I had the same problem...went to the apple store and the tech said that if you're using WEP security on your wireless router, you had to enter your password in a hex-something. I don't know. Anyway, it didn't work so he said to switch your wireless router security to WAP and make a new password. Connects perfectly with no problems now and the internet works on my iPod touch. Try it.
  • Bresaur Level 1 Level 1 (0 points)
    Don't want to discount what apple told you but my iPod accepts my hex key code using wep. I even had this issue with wep turned off. As stated in my prior reply I was able to successfully browse with safari when I wiped out the DNS settings and input the router address in DNS settings.

    This also worked with my son's touch as well.
  • Help with iPod Touch Level 1 Level 1 (0 points)
    I am having the same trouble and I am not able to figure out the password to dlink. Do any of you all know it?
  • Jlap16 Level 1 Level 1 (0 points)
    Where can i find the DNS on my lynksis router?
  • CWCooper810 Level 1 Level 1 (0 points)
    having the exact same problem. got the network working from my linksys but when i open safari it says cant find server. i dont understand how to do any of the things you guys did to fix yours. can someone please help?!!!!
  • dakota369 Level 1 Level 1 (0 points)
    I attempted to use my WI-FI network DLINK router with WEP HEX password - I also can not get the iPOD Touch to connect - I was able to connect with a couple other routers in the neighborhood which do not have security turned on.

    I was unable to determine how to set the WEP for HEX or ASCII? Does anyone know if there is a way?

    It was easier to connect my TiVo to my home network.
  • naniwe Level 1 Level 1 (0 points)
    same problem!it connects to the linksys(not always,but miracles happen),and it can't load any page. it's really anoyingi. actually remember that the first day i bought it could've connect to linksys,but then my dad just helped me to acces our network and i didn'try to use it. but when i was in neighbourhood and wanted to open safari, it found me a link sys,but couldn't load anything. like nothing,even thou the signal was pretty strong...and i tried to do something like this in different places and buildings,the only place where i could actually connect is home with my network,that's it!
    i don't want to return my ipod,but it really drives me to it..=/
    is there anything that i can do?
    tnks.
  • Bresaur Level 1 Level 1 (0 points)
    If you can connect to your network but safari cannot open a page as it can't find the server then do the following:

    Home - settings - wifi - choose the network with the checkmark next to it - you'll see a router ip address and a DNS ip address, if they are not the same exact address then x out the entire DNS address and input the ip address found in the router field as your new DNS ip address. If it doesn't work right away try turning iPod off then back on again.

    good luck
  • Alex250P Level 1 Level 1 (0 points)
    That hasn't worked for me. It says I have a really strong connection and my ip address is there and everything but I just get the can't find server message. I wish apple would get a patch already!!!!!
  • Alex250P Level 1 Level 1 (0 points)
    I've Done it!!!!!!!!!!!!!!!!!!!

    I had all my codes there i just turned http proxy off!
Previous 1 2 3 Next