Previous 1 2 Next 15 Replies Latest reply: Apr 13, 2008 10:47 PM by Luis Santizo
Scott Fairbairn Level 1 Level 1 (10 points)
I just bought a MyBook 1TB external drive to use as a vault for Aperture. It comes formatted FAT32, however, it appears you can't use FAT32 for vaults. So I have tried to reformat it to MacOS extended, and MacOS extended journaled, however it fails after a few seconds with the message "File system formatter failed".
I am using Leopard, iMac20", 2.33ghz intel core 2 duo, 2gbRam. Any ideas , or is there some other third party software I could try?

Mac OS X (10.4.8)
  • BobP1776 Level 3 Level 3 (695 points)
    In disk utility, check the partitioning type of your drive. Click on the hardware description line for the drive in the column on the left. In the info on the bottom you want GUID as the partition type (for your Intel based Mac). If this is not correct, you can repartition the drive in Disk Utility.

    Then try to format it Mac OS X Extended (Journaled). If that doesn't work you may have a faulty drive.
  • Scott Fairbairn Level 1 Level 1 (10 points)
    YEEEESSSSSSSSSSSSSSS! It worked ! Thank you very much, I have been ripping my hair out for hours trying to figure out why this bloody thing wouldn't format! I sat on the phone to Western digital for 1/2 an hour and never got to speak to a person, who probably wouldn't know anyway!
  • BobP1776 Level 3 Level 3 (695 points)
    Cool! And thanks for the green star.
  • hotdoggyurkeyam Level 1 Level 1 (0 points)
    Hey Scott, did u get urs at Best Buy? I just got the exact same one this weekend and was having the same trouble! Thanks alot Bob!
  • Jonathan Tyler Level 1 Level 1 (0 points)
    Maybe I'm not seeing it right, but where is the hardware description line? I'm having the same problem.
  • BobP1776 Level 3 Level 3 (695 points)
    Open up Applications / Utilities / Disk Utility.

    In the column on the left there will be several lines for each storage device that presents itself to the system as a "disk". The first such line for any drive names the manufacturer and describes the drive hardware. That's the hardware description line.

    Now a hard drive might be partitioned into several "logical volumes", each of which looks like a separate disk to the operating system. Each of those will be listed just under the hardware line for each of your drives -- indented a bit.

    For drives that support removable media (such as your DVD drive), there will only be a volume line if there is currently media inserted in the drive.

    Your main hard drive, the one you boot from, likely is partitioned into only one volume so there will only be one line following the hardware line and it will bear the name of your boot disk -- most likely "Macintosh HD".

    Click on the hardware line to see the partitioning information for that particular physical disk drive at the bottom of the window.

    Click on one of the volume lines indented below it (e.g., the "Macintosh HD" line) to see how that particular volume is formatted in its particular partition of the physical disk drive.

    Partitioning is how the total physical space on the disk drive is divided and organized into one or more logical volumes. Formatting is how a given logical volume is structured for use by the operating system.

    For PowerPC based Macs, the "default" partitioning should be Apple Partition Map (APM). For Intel based Macs the "default" partitioning should be GUID.

    In either case, the "default" formatting should be Mac OS X Extended (Journaled).
  • einfallslos Level 1 Level 1 (0 points)
    Fantastic, this finally gave me the answer I was looking for, after whole 2 minutes of thinking and 10 seconds of searching.

    Just for clarification reasons: click on the line of the drive, not the partition, and click the tab "Partition", then look on the bottom for "Options", click that, and do as he explained (select GUID for Intel Macs).

    Thought that might be helpful, I still had to look around a short while.. but maybe it's just me
  • Calm Level 1 Level 1 (0 points)

    I get the same error message with a Seagate FreeAgent 750GB external drive. I am not seeing the "GUID" partition type. Mind you, mine is not an Intel based Mac. My "Partition Map Scheme" indicates "Master Boot Record". Like Scott before me, emails and phone calls to the drive mfg. are fruitless.

    Thanks for any help you can provide.

  • David DeCristoforo Level 5 Level 5 (6,175 points)
    PPC Macs do not use the GUID partition scheme. For PPC Macs, you want "APM" (Apple Partition Map).

  • Michael McLennan Level 1 Level 1 (30 points)
    Between the original gentleman's response and your clarification this solved my problem. This is what makes these forums worthwhile, thanks to both you all. If I knew how to add another green star, I would have done so. Thanks.
  • Marc Vanlerberghe Level 1 Level 1 (5 points)
    I'm seeing the same problem with my 750GB Seagate external drive. I can't click on 'options' in the partition tab (greyed out) because I have an active partition called disk2s1. I tried to erase that partition but the operation fails with a weird error: 'newfs_hfs" /dev/rdisk2s1: partition size not a multiple of'
  • Riz E. Level 1 Level 1 (0 points)

    Not sure if you received an answer yet, but I encountered the same thing on my 750GB Seagate. What you need to do is change the "Volume Scheme" from "Current" to "1 Partition". The "Options" tab, as well as the other fields and buttons, will become available, and you will be able to repartition your drive.
  • Jeff Swayze Level 1 Level 1 (140 points)
    I was in the same boat as you. Just bought a 1TB MyBook from Costco. I'm running on Leopard (10.5.1)

    To get to the point, once you select "1 Partition" from the "Volume Scheme" pulldown, the "Options..." button under the partition pane becomes active. Click the button and you'll see "GUID..." as the first radio button (of 3) you can select.

    I did this and everything worked fine.

    Good Luck!
  • arrowem Level 1 Level 1 (0 points)
    I too have been pulling hair out after buing a Best Buy Mybook 1TB drive- I even returned it (thinking it was faulty) for a Seagate 1TB.

    This is what it took!!!!

    Thank you to all who helped.
Previous 1 2 Next