6 Replies Latest reply: Feb 15, 2008 12:02 PM by Robin Blomquist
brenttstewart Level 1 (0 points)
Well, I have Wi-Fi at the house, and I have WEP encryption. I can't get the phone to piggyback onto the network, and I'm not thrilled at the idea of having an unencrypted network. Does anyone know how to get the phone to work on the WEP encryption? If I use my passkey or the proper one (of four) 26-digit codes, still...no luck. Thoughts? Thanks.

iPhone, Other OS
  • DaVBMan Level 6 (9,265 points)
    Well others may be able to help more. But many use the iPhone on WEP networks (I do). Those with problems usually find after it joined, it failed to get proper DNS or Gateway values. Or that the firmware of the router needed to be updated. Check out the settings that gets assigned to your phone when you join (click the blue arrow next to your network name) and post them here. Also check out your routers manuf. site for firmware updates.
  • Lawrence Finch Level 7 (34,005 points)
    I've been able to use both WEP and WPA encrypted routers. First make sure you have the latest version of the firmware on the router. Then go to the iPhone WiFi setting, tap the right arrow on your network and tap "forget this network".

    When the iphone prompts again enter the 26 digit Key 1 (26 digit keys can have only one key). Make sure it is a hex key and not a passphrase.

    If it accepts the key see if it works. If it says "unable to connect" try again, being more careful entering the key. Be sure you don't hit a RETURN after entering the key.

    If you are absolutely sure the key is correct the next thing to check is MAC filtering. You can set up a router to only allow certain devices to connect. if you have this enabled you must enter the MAC address of your iPhone into the Allowed table in the router.

    If it connects without error try it out. If it doesn't work go to WiFi settings and tap the right arrow; check the IP address and DNS server. If the IP address begins 169.254 your router did not supply an address. Be sure DHCP is enabled on the router. If DHCP is not enabled look at the IP addresses of the other computers on the network and manually enter an address that does not conflict with any of them. The first 3 triads should be the same, the last should be different. For example, if your computers are and you could set the iPhone to, or even better, something far away like

    Let us know if any of this helps.

    Added note: If you have not changed the default name of the router (e.g., it is still "Linksys" or some other name it came with) this would be a good time to make it something unique ("bilbobaggins", for example). The reason is that if you ever encounter another network with the same name the iPhone will "steal" the settings of that network and won't work on yours when you get home.

    Message was edited by: Lawrence Finch
  • Kevin on Vashon Level 1 (0 points)
    Rejected Passwords on WEP: This discussion does not make clear how you are supposed to enter your hex code. It's not obvious and perhaps it's different for the various brands of routers. I found this solution on another forum that allowed me to connect right away to a Dlink and apparently Linksys routers:

    WEP Hexadecimal Password Entry:

    If you network rejects your password: Preface your code with a “$” so you might enter: “$D0EBDEED2101555CF5123AEB56A”
  • Lawrence Finch Level 7 (34,005 points)
    The "$" prefix is not a router standard, it's an Apple standard. So it should work with any router.
  • OddsNEnds Level 1 (80 points)
    Thank you, thank you, thank you!

    I just got my iPhone today and could not get on my home network with WEP encryption enabled. No encryption, no problem.

    But, until I read about adding the "$" my iPhone connected right away.

    Thanks and happy new years to you all!
  • Robin Blomquist Level 1 (0 points)

    It did start to work for me when I used the $ key before my 26 characters 128 bit wep key!

    I have en Linksys router.

    strange that it was tough to get it to work


    It wont remember the wep code, I need to enter it ever time and often I need to "forget" the wifi network to get it to work...

    anymore ideas?

    Message was edited by: Robin Blomquist