10 Replies Latest reply: Feb 8, 2008 2:14 PM by solle257
Klippenberg Level 1 Level 1 (0 points)
Hi,

We got lots of complaints from clients thats no longer able to connect to FTP without using a FTP application.
How can they connect to FTP without using an application?

using go > connect to server > ftp://server.name.com
does no longer work correctly.

Any work around?

Cheers,
Kai

G5 and MacBook Pro, Mac OS X (10.5)
  • bigj6360 Level 1 Level 1 (15 points)
    I have the exact same problem. I cannot connect through Go >connect... , and I cannot connect via the terminal, or X11 either. I have tested successful connections through the ftp client "transmit" on my mac, and my linux machine at home connects and uploads fine. I have connected successfully using both anonymous and my username, using these two alternatives, but I don't have a site license for transmit, nor do I have the time to install linux on my machines.

    Here is the error I am receiving.

    mymac:~ myaccount$ ftp anonymous@192.168.1.225
    Connected to 192.168.1.225.
    220-Welcome to Pure-FTPd.
    220-You are user number 1 of 8 allowed.
    220 You will be disconnected after 180 minutes of inactivity.
    230 Anonymous user logged in
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> put /Users/youthsound/Desktop/test
    local: /Users/youthsound/Desktop/test remote: /Users/myaccount/Desktop/test
    229 Extended Passive mode OK (|||40450|)
    553-Can't open that file: No such file or directory
    553 Rename/move failure: No such file or directory

    This isn't a permissions issue, and the file does exist. I am looking at it now. I also didn't type in the location, it was a drag and drop, so there is no room for typos. I have also tried typing it in with the absolute path and the relative path. It was a no go both times. Everything looks fine, and it all works fine on everything but my macs running leopard.

    Anyone know how to solve ftp connection woes on leopard? Oh and this problems exists on ALL our leopard machines (15). Not a single one works.

    -Thanks
  • Joseph Kriz Level 5 Level 5 (5,050 points)
    Mine works....

    Not sure why yours doesn't.....
  • bigj6360 Level 1 Level 1 (15 points)
    Looking at the original post, I guess I should rephrase mine a little different. At first glance I thought they were the same issue, but they are not. I can connect, and I can also download, but I cannot upload.

    before I figured out it was an OS X problem I reinstalled the server as well, because all I had to troubleshoot at the time were macs and all of them did not work. I have also been through the linuxquestions.org forum and no one can duplicate the problem with my pureftpd.conf, vsftpd.conf or my proftpd.conf files on either windows or linux computers.. and now that I have duplicated their success with ftp uploading using both windows and linux computers (as well as our copier) and all our leopard macs don't, I have decided it is a problem with Leopard.

    I have a friend who has a laptop with Tiger installed. I will try that today to see if it is specifically Leopard, or if tiger doesn't work either, but I have a hunch Tiger will upload without a hitch. We shall see.

    What types of ftp servers are you successfully uploading to? Is it a mac, windows, or Linux? what servers are they running?

    thanks,
    -Me

    Message was edited by: bigj6360
  • stanman Level 1 Level 1 (0 points)
    I have recently encountered this problem since moving to Leopard. I cannot connect to server via FTP. Problem is not consistent as I have no problem in two out of three sites connected to same host. Problem appears to be between connecting to the server, which is succesful but will not connect after asking for password. Using terminal I had the following:
    ftp> open hosting9.123-reg.co.uk
    Connected to hosting9.123-reg.co.uk.
    220 ProFTPD 1.3.1rc2 Server (123-reg Web Hosting) [195.224.48.74]
    Name (hosting9.123-reg.co.uk:username): name32-2070014
    331 Password required for name32-2070014
    Password:

    421 Service not available, remote server timed out. Connection closed
    ftp: Login failed.
    ftp> close

    Using a PC to make the same connection was successful. I use an imac with OSX 10.5.1
    I never experienced this before OSX 10.5
  • Aussie Susan Level 1 Level 1 (95 points)
    Not that it adds much to the conversation, but I have experienced exactly what you have described ever since I got my MBP with 10.4.5 (?), 18 months ago. Tried all(?) of the free and shareware FTP clients but the same problem with all of them.

    When I used bootcamp, the Windows OS could FTP nicely, so I believe I can discount any hardware, LAN, router and ISP issues. I recall using Windows FTP under Parallels with Tiger OK, but that does not work for me now either (Leopard).

    My guess has always been something to do with the firewall settings, but these are set to 'allow all incoming connections (or whatever the wording is). Perhaps some finer level of control needs to be provided by Apple.

    As far as I am aware, mine is a completely standard clean install of Leopard (not an upgrade from Tiger).

    I would really love to get to the bottom of this!

    Susan
  • Barney-15E Level 8 Level 8 (42,635 points)
    I can connect, and I can also download, but I cannot upload.

    bigj6360, Mac OS X has never been able to upload via connect to server... You've always needed an FTP client to upload.

    As for the OP's problem, have you tried toggling the Passive Mode setting in the Network Advanced preferences?
  • Klippenberg Level 1 Level 1 (0 points)
    We have tested this many times now using different Macs and we only got it to work on a few systems without installing a ftp client.

    Our clients (mainly Mac users) is not very technical and don’t want to fiddle around with things like this, and they should not have to. One of the arguments for choosing a Mac is that a Mac works from the box.

    If Apple just implemented better ftp support in their OS including upload, many users would be very happy.

    If a Mac user on Leopard (without a ftp client) receives a mail with a link to a ftp server or is clicking on a link to a ftp server in Safari, it does not work. This is not good enough.

    It works fine on any PC and should be working on a Mac as well.

    Best regards,
    Kai
  • Barney-15E Level 8 Level 8 (42,635 points)
    If Apple just implemented better ftp support in their OS including upload, many users would be very happy.


    This is just a guess, but being that ftp not very secure (passwords sent clear text), I'm not sure Apple is putting much effort into making it better. You should set up an sftp server and have everyone use an sftp client. With Fugu, for example, I'm not sure how having a window of your local files right next to a window of the remote server files is too technical, but maybe I underestimate your clients.

    What messages do they get when it doesn't work? Any console messages?
  • Skrocki Level 1 Level 1 (135 points)
    The freeware "ClassicFTP" works for me.

    http://www.nchsoftware.com/ftp/
  • solle257 Level 1 Level 1 (0 points)
    I am having this same exact issue with one particular FTP server that I use for work. That server is Windows 2000 and I am able to connect to several other servers with no issue. I have found that FileZilla works very well, but it doesn't help that I would like to use an IDE with a FTP client which suits my work-flow.

    I have a MacBook Pro running OS X 10.5.1

    Using terminal to connect to the server, I can often log in successfully, but then when I issue a ls command, it hangs and I get:

    "421 Service not available, remote server timed out. Connection closed"

    Sometimes I get this while trying to log in. Most FTP clients will not even let me get that far... I have had the most luck with CyberDuck and FileZilla. I can connect with no problems from my PC as well as my virtual Windows XP instance from my MacBook Pro.

    This is getting extremely frustrating. I have even tried installing a different FTP Server on the host (FileZilla) instead of the native Windows FTP server in IIS with no improvement.