12 Replies Latest reply: Dec 31, 2007 11:47 AM by scum
OeRtKiD Level 1 (55 points)
Hello,
I am running 10.5.1 Leopard on a brand new MPro and for some unknown reason Mail will not open anymore. The menu will come up but the rest of the app won't load. Then it won't quit and I have to force quit to close it.
So I did a search on here and here's what I did:
I reinstalled the mail.app from the leopard CD - didn't work
I moved the mail.plist - didn't work
I removed spam sieve - didn't work
Repaired permissions - didn't work
I made sure the junk filter was off - didn't work
Then finally I did a complete archive and install and it still won't work!

I need my mail desparately for work because its my memory, without it I'm lost.

Any ideas?

Pete

15'4 Macbook Pro 2.2 ghz, 2 gb - iphone, Mac OS X (10.4.10)
  • OeRtKiD Level 1 (55 points)
    Hate to reply to my own post but here is the console. It looks like when I installed daylite a day earlier it caused this issue.

    12/12/07 9:06:00 AM Mail[477] Assertion failure at /Users/aj/Developer/Clients/Marketcircle/CocoaApps/Groupware/Bundles/DayLiteMai lIntegration/MORuntimeUtilities.m:85 (self=<MessageEditor:0x2700960>, cmd=_MOreplaceSelector:withMethodForSelector:isFactory:): MO_replaceInstanceSelector:withMethodForSelector: - replaceSel must be implemented in order to replace it, but class MessageEditor does not implement selector send:


    Can anyone tell me what i need to do to remove the corruption. I removed all the daylite / marketcircle stuff but obviously its still there.
  • OeRtKiD Level 1 (55 points)
    Does anyone know how to get this bug out?
  • Overworked554 Level 1 (0 points)
    I'm having the same problem you described above, but I'm not using any addons. Originally this started out with the mail window loading and just freezing. Now it won't even load the window, it just hangs. Nothing in the console logs indicate any issues.
  • Ernie Stamper Level 8 (37,545 points)
    Pete,

    Not sure of everything you have done, but if you reinstalled Mail from the Leopard DVD, then the version does not match 10.5.1. You would need to download and install the standalone Update for 10.5.1 over the existing OSX to now update Mail. This might be the problem, despite having removed daylite.

    More info, please.

    Ernie
  • Jon G. Hall Level 1 (0 points)
    Dear OrEtKiD,

    I'm seeing behaviour I don't like in Mail-the viewer window doesn't always refresh-but I use the WideScreen.mailbundle which might have something to do with it. That said I don't want to lose mail in the way you have. So I hope to help.

    I'm not clever with this stuff, but have you looked at the Mail bundles folder in your library? ~/Library/Mail/Bundles and (after quitting Mail, if it's running, which of course it's not) deleting stuff to see if it affects the problem you're having.

    It could be that the Bundles folder is empty, in which case that's not your problem.

    It may also be that you've solved it yourself, and don't need this. If you did, please post what you did!

    Best wishes, Jon
  • Booze Level 1 (0 points)
    I too have experienced this problem, and it seems to come from Time Machine. I had just installed Leopard today using the upgrade option. Everything worked as normal until I started time machine. I normally keep my mail open in the bottom right-hand corner of my screen (I have a 30" display), and I noticed when Time Machine began to run, all of the sudden my e-mail disappeared. When I clicked the Mail icon on the Dock, the menu bar displayed at the top of the screen, but the mail message window did not. I then restarted Leopard, and Mail worked fine, until Time Machine kicked in again. I have since disabled Time Machine to see if truly that is the culprit. (I'm running 10.5.1)
  • Booze Level 1 (0 points)
    Well, I rescind my last statement that this happens when Time Machine starts. I have Time Machine turned off and when I was just scrolling through an e-mail message, the message window just disappeared and I can't get it back except to restart Leopard. I knew I should have waited longer to install Leopard!
  • JoshSuggs Level 1 (0 points)
    I had this same issue as well. Uninstalling DayLite didnt help any. I finally resolved the issue by removing the ~/Library/Mail/Bundles/DayLightMailIntergration.mailbundle directory and relaunching Mail.app.

    Hope this helps.


    -Josh
  • Godding Level 1 (0 points)
    hi there,



    am having the same problem too.  mail just won't open but i can activate the menu screens at the top. it's obviously receiving mail as the red icon tells me my mail count.  
    also, not sure if this is a bad coincidence but i did a verify disk permissions through disk utility and it crashes the machine after a couple of mins.



    any help would be great...



    cheers,
  • katrinafee Level 1 (0 points)
    I am having this problem, and have been since I installed 10.5.1. The menu loads, and then the app quits. I don't use Daylight, I don't use iCal, I don't use Growl, or Time Machine. I have already reinstalled, removed the mail.plist, fixed file permissions, etc etc--most of the things suggested in these forum discussions...

    This is what it says in Console:
    29/12/2007 17:18:20 com.apple.launchd[64] ([0x0-0x16016].com.apple.mail[113]) Exited abnormally: Segmentation fault

    If I can't get Mail back up and running, I have lots of really important emails on my system that are saved in Mail--is there any way I can get them out and into Thunderbird or Entourage?

    Thanks.

    Katherine
  • Paul Burkimsher Level 1 (0 points)
    Dear Katherine,

    I too have exactly the same problem in Mail 3.1(914/915). I haven’t fixed the underlying issue of the mail application exiting, but I can now make it stay open enough to read the mail folders that are stored locally on my machine. Basically I had to disable my mail account. It needs a bit of very quick typing! You have to do these steps whilst mail is open, before it crashes. It took me several goes to be dextrous enough with the mouse, but I got there in the end.

    Start Mail.
    In the main menu, Click Mail>Preferences. The Preferences window opens.
    Click the “Advanced” button (the rightmost one of the three.)
    Untick the first box that is labelled “Enable this account”.
    Press the red traffic-light “close window” button.
    Click “Save”. The “save changes” window retreats.
    If you get that far before it crashes, you’ve won

    Even if mail crashes now, you should be able to open it again and this time it will stay open. You can browse your messages stored “On my mac” at will.

    The above does not fix the basic problem though.
    In case it is of any use to anyone, what follows are a few pieces of information that I found when investigating.

    I also tried (first archiving!) and then deleting the biggest of my “On my Mac” mail folders – in case absolute size was becoming a problem. It didn’t help.

    My email worked yesterday, but not today, so I went on Webmail and read all my new emails. I then deleted (and purged) all those new emails on webmail. Back in mail, it was no better. (I don’t know what is different now though…)

    I opened the Activity window. (Mail>Window>Activity).
    Three things seem to happen in parallel.
    “Copying messages”
    “Adding messages”
    “Traversing mail hierarchy”
    around the time it crashes.
    I have seen “copying a message” complete apparently successfully.
    My reasoning says “be suspicious of “traversing mail hierarchy” but just watching the progress bars and seeing it crash again and again I have a gut feeling that it’s the “adding messages” (whatever that means!) that is the problem. I have no hard evidence for this though.

    This all seems a rather serious problem. Hallelujah for webmail.
    Apple, We need a fix soon please!

    Paul Burkimsher
  • scum Level 1 (10 points)
    Exactly my issue. I thought rebuilding my mailbox might be of some help, but ended up just blanking out my local copies of mail, continuing to freeze when attempting to re-download the messages.