Previous 1 2 Next 17 Replies Latest reply: Apr 20, 2008 8:45 PM by jhardman
Sorelli Level 1 Level 1 (0 points)
Hi folks,

I'm having problems to restore my iPod Nano.
When I connect it to my iTunes it says that there is a iPod in Recovery Mode and I start the restore process.

BUT, after downloading the restore file and extracting it pop's up the message: "The iPod "iPod" could not be restored because it is busy".

Does any one knows how to solve this problem ?


Regards,
Rodrigo

MBP 2.4 Ghz, Mac OS X (10.5.1)
  • deggie Level 9 Level 9 (50,445 points)
    Are you running Norton Antivirus?
  • Rodrigo Sorelli Level 1 Level 1 (0 points)
    No I'm not running any kind of anti virus...
    Another detail when I try to erase through the Disk Utility it says ' Input / Output ' error.

    I think that the flash memory of my iPod is gone ...

    Regards,
    Rodrigo
  • deggie Level 9 Level 9 (50,445 points)
    Have you tried a different USB port? A different cable? A different computer?
  • Sorelli Level 1 Level 1 (0 points)
    I've tried 2 differents Mac's and 1 PC.
    Different USB ports and 2 cables ...
  • deggie Level 9 Level 9 (50,445 points)
    I would say it is a goner. You could try a 3rd party repair site, such as http://www.iresq.com for a repair estimate, or Google for more similar sites.
  • ckheadley Level 1 Level 1 (0 points)
    Don't throw that iPod away just yet. I was having the same problem and was able to fix it by forcing the nano into "Forced Target Disk Mode"

    Make sure the iPod is connected to your computer

    First reset the iPod by moving the hold switch back to the hold position and then back to the operating position.

    Then press and hold the menu and select buttons for 6-10 seconds until the iPod force reboots.

    The moment the iPod reboots and you see the Apple logo, release both buttons and immediately press both the play and select buttons. The iPod screen should says it's in disk mode.

    iTunes will again suggest that the iPod needs to be restored.

    For some reason, this works for me when all else fails. The iPod is working great.

    Chris
  • Christian Kennel Level 1 Level 1 (5 points)
    I have the same problem with my Nano. I haven't found a fix yet but if you google it you will see we are not alone. From what i can tell, it has something to do with an update to iTunes. The firmware just doesn't work or iTunes fried it somehow. I have been able to get mine to restore briefly but as soon as I try to reload songs it goes wacko again. I first had this problem about 2 months ago and I thought Apple would have addressed it by now. From the various posts I have been following, they definitely know somethings up. I can tell you right now it's not a cable, a computer, a port or anything other than a conflict with the Nano and iTunes. I have tried everything. Really strange. If anyone has actually found a fix let me know. I have also tried the disk mode solution to no avail. I am not sure if this is just a Nano 1st Gen issue or not.
  • Christian Kennel Level 1 Level 1 (5 points)
    I went to an Apple Store Genius Bar today just to see what they would say. They plugged in the iPod and it went through the restore protocol and while it was loading the guy turned to me and said my iPod wasn't updated and that was the issue. Well, this wasn't true as I was running the latest iPod update and when he turned around he saw the "ipod cannot be restored because it is busy". I told him that the issue started happening to lots of people sometime in September when Apple released an itunes update. He said that this was the first he heard about it so I told him to just check the boards. We are not alone. What was interesting was that he said flat out that the drive was bad and Apple no longer services Nano's and that I should just recycle it and buy a new one. He said my Nano is already 2 generations old! I told him my Audi Quattro and my Toshiba TV are both about 3 generations old but both still run perfectly. I told him recycling it was crazy because it was working fine before the iTunes update. Apple will admit the issue eventually.

    So...I went home and I started doing more research. I found an excellent link on how to go into the hidden diagnostic screen and I ran through every test including the last one that says "reset". After I did this, I was able to restore my nano and when I did I ran Disk utility and disabled "Disk Mode" because I have a theory that was one of the reasons why it wouldn't restore. I also only loaded my 4GB Nano 25% for now. I am going to test it but so far things seem to be working fine. Glad I didn't throw it away at the Apple store. I am pasting in the link on how to access the hidden diagnostic screen on 1st Gen iPod Nano's. Please keep in mind this only works with the 1st Gen iPod Nano's and no other iPods.
    http://1gbps.wordpress.com/2007/11/07/how-to-hack-a-1st-generation-ipod-nano/

    I hope this helps. By the way, I am using my nano with a MBP not a PC.
  • joedon Level 1 Level 1 (0 points)
    It said this to me about five times then i put it in to diagonostics mode and did a reset from there and it worked

    maybe you should try that
  • bonehead23 Level 1 Level 1 (0 points)
    I have a click wheel 20 gig iPod that's giving me the same message, and refusing to be restored or initialized.

    Two iTunes updates ago, concurrent with the introduction of the first iPhone, I ran into a problem where most purchased songs wouldn't load, and then a new version fixed it.

    I am hoping that this will be the case, but this is getting frustrating.

    FYI, I tried the fix that was mentioned for 1st gen nanos, and didn't get anywhere with it (as I was warned).

    Any suggestions will be appreciated.
  • bonehead23 Level 1 Level 1 (0 points)
    I was able to load the diagnostic screens. However, it won't reset from there, either. Disk mode won't work to alter the path either.

    It gives me an HDD scan pass, and iram and sd ram passes, but hdd r/w fails.

    When I have iTunes fired up, it gives me the following error message:

    iTunes has detected an iPod that appears to be corrupted. You may need to restore this iPod before it can be used with iTunes.You may also try disconnecting and reconnnecting the iPod.

    After attempting to restore, it says:

    The ipod "ipod" could not be restored because it is busy.

    If I don't have iTunes working, I get the following error:

    Disk Insertion
    The disk you inserted was not readable by this computer.

    I choose Initialize, and get the following error:

    Disk Erase failed
    Disk erase failed with the error:
    Input/Output error

    I have used firewire and usb connections in different ports, and reinstalled iTunes, forced it into disk mode, and none of it works.

    I was thinking that I could go cro-magnon on it and load some third-party disk utility to initialize it, but I'm hoping that Apple will fix the issue via update.
  • RobertMarchiano Level 1 Level 1 (0 points)
    Christian - my heartfelt thanks. I was able to restore my 11 year old daughter's prized possession - her nano thanks to your post.
  • unAndalusGus Level 1 Level 1 (0 points)
    Hack worked GREAT!! Thanks so very much Christian!
  • steve237 Level 1 Level 1 (0 points)
    After trying the suggestions in this thread, I was still getting the "ipod is busy" error. However, I pulled the USB cable out of my Belkin hub and plugged it into the USB port on the back of my display and that did the trick... Hope this helps others. Good luck!
Previous 1 2 Next