4 Replies Latest reply: Jan 1, 2008 3:34 AM by vincas
laurel922 Level 1 Level 1 (10 points)
I have a disk with music saved to it in my mac book. I have been trying to get it to eject for hours now. I have tried the rd eject button, dragging to the trash, pushing eject next to the disk icon in finder, restarting with the mouse button depressed(I got the whirly rainbow ball for about 10 minutes and gave up. Finally had to power down and start over.) I also pushed the power button and then the eject key. Any ideas?

My computer is running very slowly and I also get the rainbow whirly when I move over the top right corner of the screen (The mag glass.)

Please help!

macbook, Mac OS X (10.5.1)
  • Kappy Level 10 Level 10 (252,505 points)
    Open the Terminal application in your Utilities folder. At the prompt enter:

    drutil eject

    Press return. This should eject the disc.
  • JDTagish Level 1 Level 1 (30 points)
    You can also try: Restart the computer. As soon as you hear the tone when it is starting, hold down the mouse button, and the disc should eject.

    Also, I'd avoid that disc in the future. I just had a huge issue with a disc I burned not ejecting, and had to go to the Apple store to get the disc out. For some reason, the disc was hanging the computer. If the contents are important for you to have on your MacBook, try copying them on a thumb drive or external hard drive to transfer them to the computer.
  • JDTagish Level 1 Level 1 (30 points)
    Sorry - missed the part where you tried the restart & mouse button.

    The disc came out at the Apple store with a gentle shake - highly technical, I know, but it worked for them.

    If you have another bootable drive (bootable version of your OS on an external drive or a BootCamp drive) you can try booting from the other drive and see if you can get that to eject.

    You can also try starting iTunes and attempting to eject the disc from there.

    The last option I know of is to restart the computer, and immediately after the start tone is to hold down COMMAND, OPTION, O, & F keys to open the firmware. When you get a prompt, type: eject cd and press RETURN, then type mac boot and press RETURN.

    Hope any of these help.
  • vincas Level 1 Level 1 (40 points)
    i've had a similar problem with my MacBook, but it happens with all cds / dvds. i need to hold the drive downwards for any cd or dvd to eject.