9 Replies Latest reply: Dec 19, 2007 9:39 AM by Nathan C
Sarah Bella Level 1 (0 points)
Hoping someone can help.
my iPhone receives email but won't send.

I first tried the automatic sync through iTunes as I am on an iMac and use the Mail client. That didn't work.

Then I deselected 'sync' and set up the account directly on my iPhone. First I did it just like my blackberry (which always worked) - as a POP account, with the same settings as on my computer.

Then i tried it as an IMAP and Exchange account. didn't work.

Please tell me it's something simple I'm doing wrong - here are the details:

Incoming mail server:
host: mail.website.com
user: sarah+website.com
password

Outgoing Mail Server:
smtp.earthlink.net - also tried smtp.website.net, with and without SSL
sarah+website.com
password - tried it with and without user + password (as i never needed this on bberry)

If anyone has any suggestions at all I would be grateful -

thanks so much,
sarah

iMac, Mac OS X (10.4.11)
  • Allan Sampson Level 10 (123,405 points)
    Earthlink also has an authenticated SMTP server which you need to use instead.

    SMTP Server: smtpauth.earthlink.net

    User Name: Your entire Earthlink email address.

    Password: The password for your Earthlink account.

    Authentication: MD5 Challenge Response

    Server Port: 587
  • Sarah Bella Level 1 (0 points)
    hi Alan,
    thank you for writing in -

    I don't have an Earthlink email address - is that what you mean? Earthlink is my ISP, so from home I use mail.earthlink.net as my outgoing server, but I believe from my iPhone I would use my website/mail server.

    Let me know if I have misunderstood, I am desperate to get this solved
  • Allan Sampson Level 10 (123,405 points)
    You're welcome.

    If Earthlink is your ISP, you have an Earthlink email address.

    Unless your website's SMTP server is authenticated, it isn't likely you will be able to use this SMTP server to send messages with your website email account but if you use Earthlink's authenticated SMTP server with the settings I provided, you will be able to.
  • Bill Swartz Level 1 (145 points)
    Allan,

    I am having a similar problem, not being able to send email from our iPhone. I configured Mail on our Mini exactly as you described (we have Earthlink, and the Mini sends email just fine), but after syncing, the iPhone still refuses to send email, either via AT&T or over our home wireless network. I have confirmed that the settings were indeed synced to the iPhone. The iPhone is up-to-date with the latest firmware.

    Any other thoughts?

    Thanks.
  • Allan Sampson Level 10 (123,405 points)
    Deselect the sync option, then delete and manually create the account on the iPhone.

    Sometimes something doesn't get transferred correctly via the sync process even though the settings on the iPhone appear identical.
  • Q-fam Level 1 (0 points)
    We went to the "www.apple.com/support/iphone/mailhelper/" and followed all its directions (you are asked to enter your e-mail address, and it returns with everything you need to enter to set up the info).

    Before this worked, we had to undo the mail sync in iTunes, then select the "eject iPhone" from a pull down, unplug the iPhone. We then deleted the earthlink account we had first created. Then we recreated a new Earthlink account using the info given us from the link above. The only thing we had to change was under Settings/Mail/Authentication ... don't select anything. It defaults to the MD5 thing but doesn't display anything -- just leave it that way.

    I guess that sometimes the sync operation muddles up the process when first creating yor mail accounts.
  • Dr Jekyll Level 1 (0 points)
    I had the same problem for a little while until I was tod that o2 have their own outgoing server that everyone has to use to send mail. Once I'd changed my outgoing server to SMTP.o2.co.uk it all seems to be working fine! Hope that helps!
  • Sarah Bella Level 1 (0 points)
    original poster here.

    I finally called Earthlink (after trying everything else) and Alan was right: I DO have an earthlink.net email address that I was not aware of, and it does have a password that I needed in order to set up outgoing mail.

    I have no idea why my email worked on my blackberry for years and not on the iPhone with the same settings, but there you go.

    For anyone who is having similar problems, I recommend calling your isp provider.

    For anyone on earthlink, here are my final settings:

    outgoing mail server:
    smtpauth.earthlink.net
    name@earthlink.net
    password from earthlink

    Use SSL
    Server port 587
  • Nathan C Level 5 (6,260 points)
    Sara Bella,

    Blackberry handles outgoing email by relaying through their servers or their software installed on your mail server at an additional cost.

    The iPhone instead uses your existing SMTP server to relay or if that is not available your wireless carriers SMTP server.

    Hope this helps,

    Nathan C.