11 Replies Latest reply: Feb 8, 2008 9:54 PM by gmstrowabarton
Glynn West Level 1 Level 1 (5 points)
I've been through all relevant troubleshooting pages and I still can't get my 4th Gen ipod to show up on my computer or itunes. I have managed to install a driver, so the device manager recognises there is an ipod fitted.

Is it because I have WIndows Vista? I've checked that its fully upto date.

Please help, its highly frustrating.

Gen 4, 20 GB
  • YoJimbO45 Level 1 Level 1 (0 points)
    I've also got this problem with the same 20Gb 4th-Gen type.

    What's worse is that since updating on Vista my iPod's been faulty, and now it's just stopped working alltogether - when I switch it on a symbol referring me to www.apple.com/support/ipod appears, then it switches off...
  • soniks Level 1 Level 1 (0 points)
    download the latest itunes and upgrade in your machine.
  • arunsethi Level 1 Level 1 (0 points)
    Exactly the same problem with my computer (windows XP). I've installed the latest iTunes, looked in the device manager and disk manager but no luck. My 3rd G nano doesn't work, neither does my sister's classic. I used to have an iPod photo that worked on my computer about 6 months ago.

    Glynn: Where can I download a driver installer?
  • YoJimbO45 Level 1 Level 1 (0 points)
    EDIT: Double Post

    Message was edited by: YoJimbO45
  • YoJimbO45 Level 1 Level 1 (0 points)
    I have the latest version of iTunes (v7.5), what do you mean by "upgrade in your machine"?

    Even if I didn't have the latest version, would updating iTunes make my PC detect my iPod, including Windows Explorer?
  • jsymonds Level 1 Level 1 (5 points)
    Check your USB Ports. My iPod will not work on a 1.0 USB; they require 2.0 USB ports.
  • arunsethi Level 1 Level 1 (0 points)
    All of mine are 2.0 USBs as well, I've checked everything on the trouble-shooting page for this problem, as Glenn has I think.
  • darnUipod Level 1 Level 1 (0 points)
    I need help with this as well. (Of course, like the others, I have also checked the various support pages and googled the problem to no avail.)

    Basically, I want to connect my ipod to my work computer so I can charge it while listening to music. I did not have trouble with it in the past (I was able to connect it without itunes, ipod would charge once plugged in to a usb port - it showed charging "do not disconnect" message; I could also charge it while listening by ejecting it through windows - right clicking the ipod drive listed and selecting eject) and it's connecting to my co-worker's computer just fine! So I think it's a usb problem on my computer but i have no clue as to what to do... >_<

    When I got to work today and plugged my ipod into my computer, it mysteriously did not show up under the windows explorer as a drive so I could not eject it as normal to charge and listen. Originally, this morning it did JUST charge (plugged ipod in and "do not disconnect" message appeared), but after I fiddled around and selected to stop device under the device manager it would not connect again. So now it is not even connecting to charge.

    I've tried installing itunes, rebooting various times, resetting my ipod, turning it into disk mode, changing it back... - all nothing.
    Although...when it changed from disk mode back to regular ipod mode and I plugged it into the usb drive it did charge for a while (as if it was on aka i could play music; it didn't show the "do not disconnect" screen), but when I touched the click wheel it stopped charging!!!

    this is very frustrating so any help would be appreciated
  • darnUipod Level 1 Level 1 (0 points)
    never mind. i was able to fix things myself with the article below. it WAS a usb thing. if you're having problems still maybe give this a try?

    http://docs.info.apple.com/article.html?artnum=305136
  • cmcolfax Level 1 Level 1 (0 points)
    Sounds like the same problem I am having... except my iPod does not show up at all.

    Even when I dig in to Device Manager, it simply lists it as "Device Not Recognized".

    Disableing and re-enableing devices did nothing.

    Anyone else?
  • gmstrowabarton Level 1 Level 1 (0 points)
    I am having a similar issue i have a 2gen ipod that uses firewire which until the upgrade to version 7.6 i think made it so i can't even get my ipod to start in windows the ipod says on it that it is ok to disconnect and device manager sees it but says device will not start. this is on a windows vista 64bit but it was working before the new itunes. now i can take the ipod plug it into my other pc which wasn't updated with the new itunes and with the same pci firewire card pulled out of the other machine and installed it works like a charm. gone thru every troubleshooting page on the web-site been like this since the beginning of dec 2007. Anyone have any ideas?