13 Replies Latest reply: Mar 16, 2008 4:49 PM by Philip Flores
JustCallMe Dude Level 2 (240 points)
Hello all
I seem to have a problem I just cant figure out, my Pioneer DVR-111D will not recognize DVD's, it reads CD's with no problem but, when I pop in a DVD I get nothing at all, any idea ?
Thanks

G4, Mac OS X (10.4.11)
  • Ohluckyme Level 1 (0 points)
    I'm having the same problem as well. Recently purchased a refurbished
    Power Mac G4 with the cd/dvd/rw and system will only read cds, have not tried
    playing a dvd yet. I need to be able to burn my cd's for backup files.
    In OSX 10.2 when I insert a blank cd I get a message window saying system could not find any suitable drivers to burn discs. I have tried in OS 9.6 classic and it does allow to prepare the disc and create directory. It allows me to drag files or folders to the blank cd. End result is I cannot burn the disc because the device is not supported. I have tried the patch download with no results. Have not been able to find suitable driver on the net so far. Was wondering if this cd/dvd unit could be an after market installation or native to the G4.
  • WWJD Level 6 (15,825 points)
    You may need to get Toast Titanium for your issue. 10.2 is very "old" and OS-level support for non-Apple drives is nil.

    Regards,
  • WWJD Level 6 (15,825 points)
    There are separate lens systems for CD and DVD discs. You could try a cleaning disc and see what results. Could also be the DVD laser is non-functional. What drive do you have installed? See System Profiler for details on the drive.

    Regards,
  • bobfenster Level 1 (0 points)
    Mine's a DVR-104, but my problem is slightly different: I can read and burn DVD-R, but it won't recognize the blank DVD-RWs. Having just opened a spindle of 25, I am chagrined to find out it won't even recognize them. Not sure the store would even take them back (assuming I can't figure out what's going on).

    I haven't cleaned the drive yet (have to run back out to the store to take care of that), but why would it read -R and not -RW?

    Could it be a driver issue? Pioneer only provides drivers for Windows... although I did find someone's personally made Mac firmware upgrade, but I didn't want to touch that unless I became desperate. Thanks for any help you can provide.
  • Malcolm Rayfield Level 7 (28,075 points)
    The DVR-104 is old, and may not work with some media that didn't exist at the time the drive was made. Try some different (maybe lower speed) DVD-RW discs, such as Verbatim.
  • bobfenster Level 1 (0 points)
    Thanks for the suggestion. These are only 4X, though (Memorex).

    Maybe I should just buy a new drive and be done with it. I just have to figure out what's compatible with my system.
  • Malcolm Rayfield Level 7 (28,075 points)
    My original drive was a Pioneer 103 and it would work (at 1X) with Verbatim DVD-RW 1X-2X discs, so they should work with a 104. I have seen bad reports about Memorex media.

    If you want to replace the drive, get a Pioneer. I think the current model is 115. I have a 110, and it works fine (at 8X because of the slow optical ATA bus on the Quicksilver) with all the OSX software.
  • bobfenster Level 1 (0 points)
    Thanks. Not being 100% sure that the 115 works with the G4 (or whether the Quick Silver can take advantage of its speed), I just ordered the 112 for $40 included shipping.

    No point in spending any more time/effort on this... just replace the sucker. Thanks for your help.
  • WWJD Level 6 (15,825 points)
    I was able to return my unused "coasters" to the place where I purchased my discs. You might try the same.

    Regards,
  • bobfenster Level 1 (0 points)
    No need. I ordered the 112 from OWC, installed it and am currently recording my first DVD-RW. Thanks for the suggestions.
  • WhiteDovey Level 1 (0 points)
    I'm having the same problem with my new-to-me G4.

    Slightly comforting to know that I'm not the only one having this problem, but frustrating none the less... where did you get a new drive for $40? Looks like I'm in the market for one also.
  • WWJD Level 6 (15,825 points)
    newegg.com is one location.

    Regards,
  • Philip Flores Level 1 (5 points)
    Hi,

    I've got a similar problem with my DVD drive...I have a relatively new Pioneer DVR-112D Drive, and for some reason it doesn't read any DVD's or DVD-R discs...it's not a problem with my discs since my other drives and players read them fine. What's weird is this is the first time it's been acting up on me...I've had it since November 2007...

    I've tried a lens cleaner and it hasn't worked thus far...is there a special DVD lens cleaning disc? I just have a CD lens cleaner, but I figured it'd do the same job.

    My firmware is 1.21, and I'm running 10.4.10 on my Dual 1 Ghz Power Mac G4 Mirror drive...