Previous 1 2 Next 18 Replies Latest reply: Feb 2, 2008 9:02 PM by wonkabar
Woop Level 1 Level 1 (40 points)
There is a thread ( where people have about the same issue, but it says that it is solved. My issue is not resolved.

In my trash is an alias that looks like this: \\\õ\\.õ\ - however, the slashes are symbols that are the letters NUL staggered. There is also a character that is hiding before the first each set of NULs as well as the last one.

Okay, so here is the problem. This alias file won't leave the trash bin and it's not clear what this file is. I had help from Apple support - a phone call just short of 1 hour. As I already stated, this is still not resolved.

• Empty Trash doesn't work.
• Secure Empty Trash doesn't either.
• It can't be renamed.
• It can't be moved.
• Any combination of Shift, Option, and Command while selecting Empty Trash makes no difference.
• Get Info is the only function that, while it does nothing really, makes the Trash icon change to empty. Once Trash is opened, it reveals that the alias is still in Trash, and the Trash icon changes to full again.

Safe boot did nothing. The support agent had me enter Safe boot and send the Caches from my Home/Library folder. Then I was instructed to do Empty Trash. This deleted Caches and left the unwanted alias.

Next thing I tried with him was to create a different Administrator account and log into it. Trash under this account was empty, even after opening Trash.

At the end of the call, his superior recommended to either reinstall Leopard completely, or via the option "Archive and Install." I thought about this and decided to "Archive and Install." Nothing is different.


This drives me nuts. I just hope that someone will be able to help.

Oh, on a side note, I wish Apple would have better informed agents. This tech said that there is no anti-virus software for Mac because Macs don't have viruses.

MacPro, Mac OS X (10.5.1)
  • scb Level 5 Level 5 (5,380 points)
    Go to, and see if you can find Delete It. Try that.
  • Woop Level 1 Level 1 (40 points)
    I forgot to mention before that the agent already told me to Repair Permissions in Disk Manager.

    Delete It doesn't even display anything in my .Trash folder where it should be. FileXaminer is a different program I tested, and it was able to display the file in an open dialog but returned an error on Get Info option, as if the file wasn't available anymore.

    I'm not all that experienced when it comes to OS X, but I tried other things suggested online. I tried opening Terminal for this:

    sudo rm -rf ~/.Trash/*
    sudo rm -rf ~/.Trash

    I tried to paste the title of the alias into sudo rm -rf ~/.Trash/, but it changes it to ␀␀.õsudo rm -rf ~/.Trash/␀␀␀õ. It's strange. If I paste first, without hitting return, terminal simply says Logout.

    Thanks for the reply and suggestion. If you or anyone else have more ideas I'd love to hear it.
  • scb Level 5 Level 5 (5,380 points)
    delete it has a Trash icon in it's tool bar. Nothing shows? OK, that's a togh one. Do this. Grab a copy of some of the characters in the file. Do a forum search. I think this can be found elsewhere, and maybe a solution, too.
  • Woop Level 1 Level 1 (40 points)
    Here's another 2 thread with the same issue -,

    This worries me.. I suppose I can try to go in Safe boot or the install disc and try Disk Utility's Repair Disk.
  • joeuu Level 5 Level 5 (5,075 points)
    From the macworld link that doesn't seem to work:

    Start by creating a new user in the Accounts System Preferences panel. It doesn’t really matter what name or access level you give the new account; it’s going to have a very short existence. Once the account is created, move the troublesome file from the trash into the /Users/Shared folder. Now (via Fast User Switching or a traditional logout/login), log in as the new user. Open the /Users/Shared folder, and move the troublesome file into the new user’s trash.

    Now logout of the new account and log back into your main account. Return to the Accounts pane in System Preferences, select the account you just created, and click the minus sign (or just hit Delete). The system will put up a dialog box asking if you’re sure you want to do this, with three options: Cancel, OK, and Delete Immediately. Select Delete Immediately, and the troublesome file (along with the new user and the disk space they used) will disappear. (If you just press OK, the files from the deleted user will still reside on your drive.)

    It may seem a bit time consuming to delete a file in this manner, but it’s very safe (much safer than the Unix solution), and will work on files that seem immune to all other solutions.

  • Woop Level 1 Level 1 (40 points)
    It was just missing the L in HTML.

    I can't move the file in the first place.

    Super Empty Trash didn't help at all either.
  • KJK555 Level 4 Level 4 (2,895 points)
    try this:
    boot into your leopard dvd, click the language screen.

    On the apple menu at top of screen under utilities open a terminal

    #change directory to your user directory#:
    cd /volumes/macintosh\ hd/users/<your user name>

    #using the move command change name of directory#:
    mv .trash mytrash

    #recreate the .trash directory with make directory command#:
    mkdir .Trash


    shutdown and reboot

    After rebooting you will find the new "mytrash" directory in the root of your user directory.

    Open up the mytrash directory with finder and see if you can rename the stubborn file

    sorry about the dead url:
    here is a good one for whoever needs it:
  • Woop Level 1 Level 1 (40 points)
    Thanks, KJK555, I appreciate the help.

    I tried that just now, but it didn't work. I had other files in Trash which were moved to mytrash, but the unwanted file remains in the Trash bin.
  • KJK555 Level 4 Level 4 (2,895 points)
    Try using fsck to repair the illegal characters.

    1. Reboot the OS X and during the start-up, press and hold both 'Command‘ and ‘s‘ keys, this will boot your Mac into the ’single-user mode ‘.

    2. Then you will be presented with a terminal-like environment, then type ‘fsck -f‘.
note: (fsck: filesystem consistency check and interactive repair)
3. When fsck finishes, type ‘reboot‘ to restart your Mac.

    If this doesn't work, a third party utility like disk warrior will repair the illegal characters.
  • scb Level 5 Level 5 (5,380 points)
    broken link.
  • Woop Level 1 Level 1 (40 points)
    Thanks again. I tried that fsck, but it didn't work.

    Disk Warrior is $99 software, so I won't be finding out if that works.
  • macjack Level 9 Level 9 (50,670 points)
    If the sudo rm did not repair it, the item is from another volume. Are you running Windows?

  • joeuu Level 5 Level 5 (5,075 points)
    Maybe try with a Terminal window:
    First, make it so you're positioned in the Trash directory (folder):

    cd ~/.Trash

    Then display the name of all files in the Trash:


    It should show just the one file, "xxx.yyy".

    To delete that one file:

    rm -i xxx.yyy

    The "-i" makes it ask for confirmation: "remove xxx.yyy?"

    Type "y" (yes).

Previous 1 2 Next