9 Replies Latest reply: Jan 3, 2008 9:01 AM by HalanJ
myst1c Level 1 Level 1 (0 points)
hi, im having troubles with my ipod touch. i have a linksys wireless router. i believe it is a wireless-N . i use a normal router for internet on my pc, so i just ran a cable from the regular router to the linksys router specifically for my ipod touch wifi connection.
my problem is: on the wifi networks under choose network. it identifies the linksys router( wich is great but...)
im not sure what to do next
DHCP/ BootP/Static
i chose DHCP and it automaticaly set the information from my router
(ip addy, subset mask, router.) just the dns an search domains are blank
so i close out an it shows i am connected. BUUUT
when i try to use safari it says
"safari can't open the page because it cant find the server"
for youtube and itunes it says "Cannot connect"

basicaly, it detects my wifi router but does not connect

can i get any help please

Message was edited by: myst1c

pc, Windows XP Pro
  • Andrew A B Level 1 Level 1 (110 points)
    This is a prblem with the way your router is connected. You will have to have a look at configuration of that first.

    Could you maybe varify everything is correct by connecting your computer to the Linksys?

    So you would have
    Router -> Linksys -> Computer

    Instead of having it run straight from the router. This will check that it is not just your ipod.

    From your post everything else looks ok..
  • gitte995 Level 1 Level 1 (0 points)
    i've got the same problem... i know that theres something wrong with the router but i don't know what settings to change... en where i have to change them... i've got to a linksys router and i have windows vista... i can connect to the network but it can't find the server...
  • mrtotes Level 6 Level 6 (11,815 points)
    Hello and Welcome to Apple Discussions.

     

    How have you configured the two routers to pass traffic? To me the simplest solution is to remove the wired router from the network and simply put the Linksys wireless router in it's place.

     

    At the moment your iPod touch is connecting to the Linksys wireless router but does the Linksys know how/where to find the internet? Are the wired router and linksys on the same subnet?

     

    cheers

     

    mrtotes

  • rhjauckens Level 1 Level 1 (10 points)
    check your wiring between your "normal router" and "linksys router", cable must be connected on internet port on "linksys router"

    if that is not the problem so may be your "normal router" is not passing the right info to the "linksys router" to know how to find the door to internet, check your ip address on "linksys router" on the internet side, it should be one internal ip address of your "normal router" as your computer has
  • downinitjr Level 4 Level 4 (1,435 points)
    Make sure that dhcp is turned off on the second router, the linksys wireless router.
  • Michael Harnest Level 2 Level 2 (415 points)
    downinitjr has it right. You must login to your wireless router's settings and turn DHCP off. This effectively turns your linksys router into a wireless access point. I don't have a linksys myself, but I'm daisy-chaining two routers and DHCP must be disabled on the second.

    To do this, plug your computer directly into the second router (the wireless one). Enter your router's address into your favourite browser. The address would have come with your router, perhaps on the setup CD. It'll look like something like '192.168.10.1'. This sort of logs you into your router. Search for settings somewhere, and you want to turn DHCP off (ie, set it to 'Static'). It will likely prompt you for some info. Enter:

    IP Address: 192.168.1.x (x = any number from 1 to 254)
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.1.1*

    *The correct default gateway is the address of your other router (your first one, the one your wireless router will be receiving the internet connection from).

    Save those changes. Make sure your getting internet access on your CPU first, before worrying about the touch.

    If your CPU has a connection, turn on your touch and try again. If that doesn't work, search on your computer for its DNS Server (I don't know where you'd find that in Windows). It'll be a number like '64.71.255.199'. Write down that number, go back to your touch, go Settings > Wifi > select your home network (click the blue arrow to the right of its name) and manually enter the DNS setting you got from your CPU. Try connecting again.

    I've given you a bunch to go on. Give it a go and report back!

    Michael

    PS - This is so complicated because, frankly, routers aren't really designed to be daisy-chained. The easiest solution is using one router (ie, your wireless one). I couldn't because first router is built into my wall.
  • iloveoak Level 1 Level 1 (0 points)
    I have had the same problems reported but finally figured it out. I have a Linksys G router

    so this is what I did. I decided to start from scratch so I turned off security and enabled

    the SSID so the IPOD could see the network. Once connected, this can be turned off again.

    Whatever your settings are, this is going back to basics, and if your router is not set up

    as described, you may want to check it out. Otherwise, your neighbor should be thanking you

    for a free ride to the internet. If your settings are already set up as described, use what

    you already have. I have my router set up to be a DHCP server which gives the IP to the

    IPOD.

    1) sign in to your router via Exploror, firefox, etc.
    2) go to the tabs Wireless/Basic wireless Settings. Set the Wireless SSID Broadcast to

    Enable. Save the change.
    3)Now go to the Wireless Security tab and set the Security mode to Disable. Save the change.
    4) Go to the Wireless MAC filter tab. Set the Wireless MAC Filter to Disable. Save the

    change.

    5) Now go to your IPOD and WI-FI settings. You should see the name that your Router is

    broadcasting. Select it and the Check Mark should appear by the name. Now go to Safari and

    bring up a URL site. This should be working. If not, try resetting the network settings on

    the IPOD. If your router is set for DHCP broadcast, and if you go into the IPOD settings you

    will see the IP address that was assigned. Make a note of this IP as it will be used later

    to help identify the IPOD's MAC address.

    6) If you can connect, we'll now add security back in. The steps below should be turned on

    to lock down your network. I also suggest to change the Master Login and password for the

    Linksys Router.

    6b) While your at it, on the router go to Status/Local Network and click DHCP Clients Table.

    If you compare the IP address you got on your IPOD with the one in here, write down the MAC

    address next to it. This is your IPOD's MAC address. This will be used to put in the another

    table.

    ** Now Let's Lock it Down. **

    7) Go to the tab as in step 2 and disable your SSID. Make sure you can still browse. Turn

    off the IPOD and reconnect to make sure you can still browse.


    8) Go to the tab as in step 3. Set the security mode to WEP. Set the Default Transmit key to

    1. Set the encryption to 128 bits. Put in a Passphrase off choice. Example, 'IPODisforme'.

    Hit the Generate button. The value you get in Key 1 is the PASSWORD the IPOD keeps asking

    for. Save the settings. Turn off the IPOD and connect to your router. It should now ask for

    the Password. Put in the 26 Hex Digits. I'm not sure if they are case sensitive, I put in

    upper for the letters. Once done, you should be able to browse, still.

    9) You should now have SSID turned off, WEP enabled, now the last step is to only permit the

    MAC address of devices you want on your network.

    10) Go to Wireless/Wireless MAC Filter and select the Wireless MAC fileter to Enabled. Also

    make sure the Permit Only is set. Go to the Edit MAC Filter List and put in the MAC address

    you copied down earlier. Make sure you Save the change. Try the IPOD again.

    11) That's it. Hopefully it's all working fine. I hope this helps some of you who are having

    problems. Good Luck.
  • Gamestop Level 1 Level 1 (0 points)
    I had the same problem for two days in a row (right after Christmas). I finally broke down and called my local PC/MAC dealer. He told me to bring in my router, I-Touch, and passcode/login info (but not my computer). He had me wi-fi up and running in 1 hour. Only cost me $50 bench fee - Well worth it to be rid of the headache of trying to do it myself and waiting on Apple's helpline response. I'm new to music downloading - On my third song right now. It's great! Get to a professional soon, you'll be glad you did!
  • HalanJ Level 1 Level 1 (0 points)
    I've seen this problem else where about the net. I also have a Linksys wireless A+G router. This was only modified to broadcast the router's SSID so that the Touch WiFi function could find it.

    I also had the same problem with my new Christmas Gift and found that replacing the DNS addresses on the Touch corrected it for me. These replacement DNS addresses were define at OPENdns.org

    As always, check Linksys for the latest firmware update for your router.