11 Replies Latest reply: Feb 10, 2008 10:38 AM by cainusrising
jenny42653 Level 1 (0 points)
I got a new printer when I purchased a MacBook with Leopard and setting it up to use on that computer worked just fine with a direct USB connection. When I installed the software on my iMac I cannot get it to work properly, either with Airport or a direct USB connection. I have tried uninstalling the software and reinstalling as well as going to the Epson site to download the latest updates. Whenever I try to Add this printer I do not see this particular model in the Epson Model list. As some on the discussion groups have suggested, I have tried choosing other drivers which use Gimp-Print v. 5.0.0-Beta2 but with no luck. I have gotten as far as getting the printer to run when I click Print, but it wants to keep printing either blank pages (more than the 1 page I have checked) or pages with gibberish on them--there is definitely a communication problem between the computer and the printer. How can I get the correct driver for this particular printer to appear in the printer list? Ideally I'd like to use it through my Airport network with my new MacBook, but even a direct USB connection would be good at this point. I have succeeded in getting a printer (Epson CX4200) to work through Airport on both computers--but of course that driver is on the printer list.

iMac Intel, Mac OS X (10.4.9), MacBook OS X (10.5),G3 Blue & White Mac OS 10.1.5, 30G iPod with dock, 80G Video iPod
  • odonovansmith Level 1 (0 points)
    I'm having this exact problem, as well. Did you ever resolve this? When adding a printer, I can select the Stylus CX6400, 6600, 8300 or 8400, none of which solve this problem.
  • jfredkno Level 1 (0 points)
    I am also experiencing the same thing with the Epson CX7400. I got it for 70 bucks at Comp USA close out today and was told it would be fine but it ain't jiving so far. I have scoured the net tonight to find a gimp print driver for it but to no avail.

    Anyone got any ideas?

    Thanks in advance,

    J Fred in Nashville
  • imac007 Level 3 (845 points)
    I suspect you have 10.4.11 since 4.1 won't run on an Intel Mac.
    This is the Leopard forum not Tiger.
    In the Finder click on Go>Utilities and double click on printer setup utility.
    Once the program loads click on Printer Setup Utility menu and choose to reset printing system.
    Direct connect the printer via usb and turn it on.
    Check the Epson web site and there is a printer driver dated Nov 19 posted for your machine.
    Download and run the installer.
    If you find an uninstall option when opening the installer uninstall first, the reinstall.
    Then restart the computer.
    Then test to see if the printer shows up when you go to print in the print dialogue.
    Report back.
  • eplantz Level 1 (0 points)
    same deal here. Got a Cx7400 along with a new Macbook Pro which is running Leopard.

    I installed the latest driver from the Epson site (dated Nov 2007).

    Under OSX, the printer always shows job as STOPPED and cannot be convinced to print.

    This printer was hooked up to an HP notebook running XP and worked fine. Back on the Macbook Pro, I installed the Windows driver in Parallels and CAN print from Windows on the Macbook which tells me it is not a hardware problem. There are no error messages and the printer itself displays no error code. The print queue just fills up with jobs shown as stopped.
  • imac007 Level 3 (845 points)
    Open the Print & Fax preference and option click on the - sign and reset the printing system.
    Then re-add your printer.
  • komra Level 1 (0 points)
    Thanks imac007, this solved the problem
  • jcb1964 Level 1 (0 points)
    Did you ever resolve your issue with the Epson CX7400 printer? I looked at the other postings on this issue, but didn't get any help. So, just wondering. I tried everything and still no results. Thanks.
  • jcb1964 Level 1 (0 points)
    I did that several times, but still can't find the correct drivers when I want to add the printer. Do you know what driver at Epson needs to be downloaded? Thanks.
  • imac007 Level 3 (845 points)
    Epson America, Inc. - Support: Macintosh Leopard Support for the Stylus CX7400
    http://www.epson.com/cgi-bin/Store/support/SupportLeopardDetails.jsp?BV_UseBVCoo kie=yes&oid=89902#stage1
  • odonovansmith Level 1 (0 points)
    I've followed all of your instructions, and I still can't solve this problem. I've reset the Printer Setup Utility, downloaded what seems to be the appropriate driver (10.4.4-10.5), and restarted my computer. After downloading the file, I run the Vise X installer, which says "EPSON Stylus(TM) CX7300/CX7400/CX8300/CX8400 printer software." After installing the driver, shouldn't it show up in the list of drivers, under "EPSON"? Do I need to do anything more? This is getting incredibly frustrating.

    For reference, I'm running OS 10.4.11 on a brand new MacBook.

    Thanks.
  • cainusrising Level 1 (0 points)
    I followed the directions that were given above with no luck. I tried about 3 or 4 times, following the directions to the T. In my frustration, I got up to go grab a beer and when I cam back, the computer had recognized the new driver and now it works perfectly. The moral of this story is that patience is a virtue. All the previous times, I would go to the drop down list to see if the printer had been added to the list. All the while the little progress wheel was spinning away and was looking for the driver and I was to impatient to let it do its job. So if you have had no luck at all, then give it about 5 minutes to search for the driver. BTW, I am on a 700MHz G4 Emac with 512 Mb memory and it works like new.