5 Replies Latest reply: Jan 15, 2008 7:36 PM by Andy Calado
William Strieber Level 1 Level 1 (35 points)
My iphone duplicates the birthday entries on the calendar. The iPhone info tab in iTunes seems to have the option to synch Birthdays from the calendar even after i deselect all options to synch birthdays. *Is there a way to delete the Birthdays option from the iTunes:iPhone:info tab?* If I select the synch Birthdays tab, it puts the Birthdays Calendar on my iphone, but not on my iCal. If I choose to synch Birthdays in iCal I have it on iCal and on the iPhone. There are then two "Birthdays" options to select from the iTunes:iPhone:info tab.

MBP-iMac FP-iphone, Mac OS X (10.5.1)
  • Jennifer_B Level 4 Level 4 (1,760 points)
    wcstrieber,

    It sounds like you may have a Birthdays calendar already in iCal (maybe you added one manually?) Then when you select the Show Birthdays option in iCal, it pulls up a second Birthday calendar, which is why you are getting duplicates when you sync the iPhone.

    If you uncheck "Show Birthdays Calendar" in your iCal preferences, do you have a Birthday calendar still listed? If all the birthdays listed in that remaining calendar are the same ones added by the "Show Birthdays" option, you may want to delete the manual calendar and only use the "Show Birthdays" calendar to prevent those duplicates.

    Hope this helps,
    Jennifer B.
  • djsglobal Level 1 Level 1 (0 points)
    Success!

    I found I had this problem too. I didn't have birthday's manually entered into iCal, but had chosen to have them added by the Address Book/Contacts (through the iCal preferences).

    It seems to have been fixed by going into iCal preferences, unchecking the "Show Birthdays Calendar" option, syncing the iPhone (having noted that a birthday calendar was no longer available for synching), going back into iCal preferences, re-checking the "Show Birthdays Calendar" option, and then re-synching the iPhone having choosing to synch the birthday calendar option in iTunes.

    Sorry this is a bit long-winded, but as I said, it seems to have worked for me - birthdays are only showing up once on the iPhone now.
  • romanostudio Level 1 Level 1 (0 points)
    Awesome I was having the same problem and this fixed it. thanks
  • applhlp Level 1 Level 1 (5 points)
    djsglobal - THANK YOU! Your solution worked for me! I'm sure your post has helped thousands of us iPhone enthusiasts! THANKS!
  • Andy Calado Level 1 Level 1 (25 points)
    That solution didn't solve the problem for me. I too had Birthdays showing up twice in the "Sync... Selected Calendars" list. What worked for me was disabling syncing of all info in iTunes and .Mac sync, quitting all applications and deleting the following folders:
    ~/Library/Application Support/MobileSync/
    ~/Library/Application Support/SyncServices/

    The tilde character (~) signifies your user account's home folder. Once I did that, I attempted to resync the info with the iPhone, but I found the contacts, calendars and Mail accounts lists empty as though there was nothing to sync with. So I opened Address Book and tried to sync again and suddenly all the contact groups appeared in the list. Launched iCal and tried to sync again and suddenly all the calendars appeared. Same thing with the mail accounts. Not sure if launching the seperate apps was necessary, iTunes may just have needed a bit of time to rebuild the links to the application data. Everything is working fine again and this time, I don't have duplicate Birthday calendars.

    Just as a side note, those folders I deleted I believe contain cached information related to synchronization, and I believe the problem stemmed from corrupt or duplicate information which was resolved by deleting them and forcing iTunes/.mac/Sync Services to rebuild them. There is no important data stored in either folder that won't get recreated by the apps in question, although it's probably a good idea that you do a complete sync of both .mac and your iPods/iPhone before deleting them. In my case, the Mac I was using contained the 'master' databases for all apps, so I didn't hesitate to tell .mac to replace it's contents with the information on my Mac. Proceed with caution if you have multiple Macs that may not be in sync with each other.