7 Replies Latest reply: Sep 5, 2005 2:05 AM by Matteo Cacciari
Matteo Cacciari Level 1 (30 points)
I report a detailed post form another forum, because is exatly the same things that happen to me.. and my english is not so good...

The chase: I have removed two disks from a 10.3.9 software mirror RAID
set using the 10.4GM diskutil.
One now has a partition map with slice 4 of type "Apple_RAID", the
other disk has slice 4 of type "AppleRAIDOfflineV2". How do I get one
or both back to being normal Journaled HFS+ volumes without wiping their

At the very least, I need technical doc for Software RAID - a google for
yields absolutely no hits - nor does a search on Developer Connection.

Disclaimer: I know what I did here was wrong and that I need to go back
to a backup. No need for anyone to waste their time on a helpful post to
tell me this - but thanks in advance for the thoughts anyway.

The detail:
It started out as a sunny day in Sydney, Australia. Life seemed good.
The night before I had upgraded a 2x2Ghz G5 PowerMac from Panther Server
to Tiger Server successfully.
Kerberos, AFP, DHCP, DNS were all smoothly up and running, as was Samba,
Apache and even JBoss.
I had gotten IMAP and POP running where others had failed - Apple
includes an invalid TLSNames attribute in the cyrus config file that
needs to be deleted to allow mail delivery to kick off.
The jewel in the crown... My HP5510 printer was even behaving properly
with the new server and print serving was finally working again using
IPP - it had been broken under Panther.

So, I thought, before I go to bed I had better just check the world is
good with disk utility.
Alas, I found that my software mirror was in a 'degraded' state. I had
forgotten that before I did the Tiger upgrade I had attempted to split
one drive from the array and leave it powered off Just In Case.

The array failed to boot with the missing disk, so I had reluctantly
plugged it back in, intending to rebuild the array before the Tiger
upgrade. Mistake #1 - I forgot to do so.

In any case, to its credit, the Tiger Server installer happily upgraded
the OS on the degraded array and left it in the same state.

So, I thought, I know I can't repair that array volume because it is the
startup disk. I'll have to reboot with the Tiger Server DVD and rebuild
the array then.

Once booted with the Tiger DVD, I found Disk Utility to be a little
whacked. (I later learned that there is a difference between Panther
RAIDsets and Tiger RAIDsets but at the time I was ignorant). It was
unable to rebuild the array or do anything with the existing
configuration - except show little padlock icons next to each disk. I
now attribute ths to differences between Tiger and Panther RAID.

So, I thought, this can't be right. And off I trundled into the Terminal
app to hunt down the problem with Disk Utility.

I determined my only option was to attempt to rebuild the RAIDset using
diskutil repairMirror <mirrorname> <offlinediskname>.
I kicked this off - no dice.
Figured it didn't 'take' - so kicked it off again.
Nothing. No activity whatsoever. Mistakes #2 and #3 had just happened.

Figured it might be like some old Promise RAID implementations I've used
in the past and that rebuild might start only on reboot.

Rebooted the system (that had never previously failed to boot).
It failed to boot - with a big "no" symbol where the Apple normally is.
(That's 'no' as in 'no smoking' but without the cigarette)

So, I thought, time to boot the server install DVD again.
Once more, the graphical Disk Utility was useless. Back to terminal.
Sure enough, a quick diskutil showRAID revealed that there was one
"online" disk, one "offline" disk and two unknown disks - a total of
four drives - now involved in my 2-physical-disk mirror RAID set.
No amount of checking, removing, or otherwise could do anything to get
rid of the "unknown" disks from the RAIDset - I now suspect these were
created by trying to rebuild a 10.
  • Matteo Cacciari Level 1 (30 points)
    ...to rebuild a 10.3 array in 10.4 Disk Utility.

    On a whim (mistake #4) I thought I'd try to rebuild the mirror again,
    having no real other option, so I fed diskutil the disk marked as
    'offline'. Lo and behold, the mirror began to rebuild. A quick "diskutil
    checkRAID" confirmed progress was being made.
    Sometime between 80% and 100% something bad must have happened
    when I came back in the morning I found that the rebuild had terminated
    normally, but there was no change in the mirror status - it was still
    degraded, with one disk offline, one online, and two phantom unknown

    Finally, in desperation I decided to split the offline disk from the
    array using diskutil removeFromRAID. It worked!!!
    The array was still all funky with those other drives so I also then
    removedFromRAID the online drive, thus completely destroying the RAIDset
    - but at least those phantom disks are gone. Mistake #5

    Now I figured, I could simply add either (but preferably the formerly
    online) disk back into a new array using diskutil enableRAID mirror
    diskname, then rebuild it with repairMirror feeding it the other.

    Unfortunately, enableRAID requires its disk to be mounted. A quick
    diskutil list showed me neither of my offline mirror halves were indeed

    So, I thought, a quick diskutil mountDisk will fix my last problem.
    Mistake #6. It turns out that the 4th slice of each of the individual
    mirror disks now have non standard partition types. One is Apple_RAID.
    The other is AppleRAIDOfflineV2.

    However the rest of the disk partitions look good and I know these disks
    have not been written to since I started this whole messy process.

    My belief is that incompatibilities between Apple_RAID v1 and v2 exists
    and that I am partially a victim of this problem - largely just my own
    stupidity and lack of caution.

    So, the question is, does anybody out there know about how I can convert
    these disks back to standard bootable drives - or even where to find
    details on the partitioning scheme used by Apple. And ideally, how can I
    overwrite the drive partition map data but not mess up the data?
  • Matteo Cacciari Level 1 (30 points)
    the drive appear like this:

    diskutil list
    #: type name size identifier
    0: Applepartitionscheme *76.7 GB disk0
    1: Applepartitionmap 31.5 KB disk0s1
    2: AppleDriverOpenFirmware 512.0 KB disk0s2
    3: Apple_Boot 128.0 MB disk0s3
    4: AppleRAIDOfflineV2 76.6 GB disk0s4
    #: type name size identifier
    0: Applepartitionscheme *76.7 GB disk1
    1: Applepartitionmap 31.5 KB disk1s1
    2: AppleDriverOpenFirmware 512.0 KB disk1s2
    3: Apple_Boot 128.0 MB disk1s3
    4: AppleRAIDOfflineV2 76.6 GB disk1s4
  • Ralf Draeger Level 1 (0 points)
    Hi There,

    Just to let you know you are not the only one!! After my mirror degraded I tried to set it up again and ended up with an AppleRAIDOfflineV2! i checked the internet for a few days now and haven't found anyting useful. Did you managed to access you data again? I will store the one slice safely somewhere until someone can tell me how to mount this disk again, and of course I DON't have a good enough backup!! Oh well...
  • Matteo Cacciari Level 1 (30 points)
    No news from different forum
    at this link the only reply i've found.. not useful I think

    for now I made a backup like you..
    for the next time I plan to use this software (maybe I think is better than apple raid)

    Apple???? nothing reply for us???
  • Scott Weiser Level 1 (10 points)
    Don't know how helpful this will be, but I also had a Tiger G5 RAID mirror set up with two 500GB Lacie firewire 800 drives. It was working fine till at some point I must have kicked the power strip, and the system went down. When it came back up, the RAID array was broken.

    I could not get the Tiger software to separate the raid disks, so in a panic (more than 40 hours of digital video on the disks and in the middle of postproduction) I connected them to my G4 and inspected them with the Panther disk utility. I was able to mount them in the utility, so in dispair, I decided to break the RAID array, despite the dire warnings that all disks would be erased. THIS IS A LIE, at least when it comes to a RAID level 1 MIRROR array. What you get when you break the array is two separate disks that are identical.

    I then did all the tests I could on both disks, which both seemed fine, and everything went along fine from there.

    Until, that is, one of the Lacie drives started bugging on me... I had added more video content since the RAID debacle, and hadn't made a new RAID array because, again, the disk utility warns that CREATING a RAID array will "erase all disks." I thik this is wrong, and that if you create a RAID MIRROR array on disks with stuff on them, it just shoves files around till both are identical. BUT I'M NOT SURE ABOUT THIS!!! Which brings me to my problem.

    With the failing Lacie containing most of my media, including stuff not on the other drive, I tried to copy files to the good drive, and had about 30% of more than 2000 files fail to copy due to corruption...or, it seems just a sick disk...

    After shutting down and unplugging the bad drive, letting it cool all day, then booting it back up, I seem to be being able to copy files again. WHEW! We'll see if it works...about another hour yet to go.

    So, I suggest you try to disconnect the RAID pair using some other computer, and hope you end up with two separate, but identical disks. Then run all the diagnostics/repairs you can on both disks to correct any corrupted files.

    I have no clue if this will work, and if it dumps your drives, I apologize.

    So, MY question is, can you, in fact, create a mirror RAID level 1 array using disks with data already on them without destroying the existing data?
  • Matteo Cacciari Level 1 (30 points)
    Hi, thanks for the info
    to rebulid a raid from disk that contain data,
    I found this "tutorial" on another forum
    I hope is useful for you

  • John Holley NZ Level 2 (205 points)
    From my experience you need to do the following. (If you are not comfortable with running diskutil at the command line, then find someone who is - this is not for the faint-hearted!)

    1) If this is your system volume that has failed then boot off a Install CD and bring up Terminal when you get to the point where you can, otherwise just launch Terminal. (You may want to familarise yourself with diskutil before hand - "man diskutil" is a good start)
    2) Run "diskutil checkraid". This will show, often, one disk offline and the other as spare - no guarantee here but my experience has shown that the spare disk is the failed one. The key thing is to work out which disk has failed in the raid. (You can also use "diskutil list" to get more info on your disks.)
    3) Physically remove the disk and add a new disk.
    4) Use "diskutil addtoraid member <newdisk id> <raid id>" to add the new disk to the raid.
    5) Run "diskutil checkraid". You should now see the offline disk online and the new disk being rebuilt. Sit back, drink some of your favourite beverage and wait
    6) Run "diskutil checkraid" every now and then to check progress.