11 Replies Latest reply: Mar 2, 2008 1:28 AM by Phil Purviance
buyayo Level 1 Level 1 (0 points)
Hi all,

I connected my MBP to my TV via a DVI to HDMI conversion cable ($24 from Fry's), but the highest resolution I am getting is 1080i (confirmed on the computer, and the system readout on the TV). Are there other settings that I missed (in the computer or the television) that I need to configure in order to get full 1080p out of this setup? Or is it the cable? Any help on the matter would be great!

I was hoping that the picture quality from the MBP to the TV would be greater, so being able to output 1080p would really help out. I haven't tried connecting via the DVI to VGA cable, but I'd really like to run this through my receiver, and my receiver does not have a VGA in, thus my want to use HDMI.

Also, is there a setting in OSX that allows you to close the computer without it powering down into sleep mode?

Computer: Apple Macbook Pro 17" High-res 2.4 GHz
Television: Sony BRAVIA V3000 46"
Receiver: Onkyo TX-SR605

17" Macbook Pro, Mac OS X (10.5.1)
  • buyayo Level 1 Level 1 (0 points)
    Just an update, I connected the MBP to the TV using a VGA cable and the DVI to VGA adaptor that came with the computer. Works nicely and the picture quality is markedly better than using the DVI to HDMI cable. But I'd still like to be able to connect through HDMI and my receiver, so any help with getting true 1080p through the DVI to HDMI cable would be great. Thanks!
  • My White Dog Level 2 Level 2 (195 points)
    #1 I don't know if the MBP DVI out is 1080p
    #2 Does the TV produce 1080p from HDMI
  • Joshua256 Level 1 Level 1 (0 points)
    I have the same problem.. tried on two Full HD LCD Samsungs using a 6' DVI/HDMI cable I bought at the Apple Store. In both cases DVI/HDMI drops to interlaced.. I suspect this isn't the issue however what do the pins on the DVI-side of your cable look like as per: http://www.datapro.net/techinfo/dvi_info.html

    (see end of page)

    I'm going to test w/ more cables however I think this might be an OSX issue as my friend is having the same issue w/ a Mac Pro (Nvidia 7300 GT)..
  • Alliass Level 1 Level 1 (10 points)
    It is interesting subject for me as well since I have bought Sony Bravia 40X3500 and I am waiting for cables came through. I got DVI to HDMI crossover.
    The thing is I have ordered HDMI v1.3. Apparently those version of HDMI cables are design for 1080p. But I will see myself next week and I will tell you about my experience.
    Regards
  • BSteely Level 5 Level 5 (7,635 points)
    Others have reported that 1080p is a missing option within Displays preferences and have found the following procedure to restore 1080p as a selection, though I don't understand why it works. Anyway, here is the procedure to try:

    With the TV hooked up through the DVI port, go into Displays preferences and click on the "Show displays in menubar" checkbox.

    Go the the resulting icon in the menu bar and click on it to drop down the menu

    Select "Number of Recent Items" and set it to 5 (or 10?)

    After doing the above, you may have to restart. Some have claimed that the above procedure causes a 1080, 60 Hz (1080p) timing to show up in Displays preferences. Good luck.
  • buyayo Level 1 Level 1 (0 points)
    UPDATE: Used a v1.3 HDMI cable coupled with a DVI to HDMI converter and the picture quality has drastically improved. I guess the old cable (which says it was rated to carry a 1080p signal) was what was negatively affecting the picture quality. However, the signal is still 1080i and not 1080p.
  • buyayo Level 1 Level 1 (0 points)
    UPDATE: I followed the steps outlined, and tried setting the "Number of Recent Items" to both 5 and 10, but neither caused 1080p to show up on the Displays preferences. So still trying to figure this out. Anyone have any success stories, or heard of other settings to tweak?
  • AllanJ Level 1 Level 1 (0 points)
    Hi guys, I just got my Samsung LE40M87BD working on my MacBook Pro running Leopard in full 1080p resolution. Steps:

    Install DisplayConfigX from www.3dexpress.de
    Start DisplayConfigX
    Select the correct monitor in the top dropdown list
    Under Monitor, my settings are (mostly default):
    Refresh rate 45.00-61.00
    Horizontal frequency 10.00-120.00
    Pixel Frequency 138.50 (specified in the Samsung manual)
    Default refresh rate 60 (specified in the Samsung manual)
    Under Resolution, I created a new setting:
    Kind = Timing
    H V
    1920 Active 1080
    48 Front Porch 3
    32 Sync 5
    80 Back Porch 23
    Untick Interlaced if it is ticked!
    Select Pixel Frequency and type in 138.500
    Check the following (if the numbers are not correct, you have made a mistake above):
    Check that Horizontal is 66.587 KHz (specified in the Samsung manual)
    Check that Refresh rate is 59.934 Hz (specified in the Samsung manual)
    Check 'Enabled'
    Click Done
    Go to Install, click Install
    Restart the system as suggested

    Your monitor not here? The challenge is to find the Front Porch, Sync and Back Porch settings that work for your monitor. The trick is to check if they are in the manual, and if not, assuming that the horizontal and vertical frequencies are, Google the horizontal and vertical refresh rates - they are pretty certain to yield the right settings! E.g. I Google'd '66.587 59.934 front porch'. Alternatively, try this if you are more technical: http://www.vesa.org/Public/CVT/CVTd6r1.xls

    Hope this helps!
  • Jaisen Level 1 Level 1 (30 points)
    I've tried everything as well. This is very frustrating, and yet I happen to know that my macbookpro can output 1080p with these cables because bootcamp running Windows does send out the 1080p to my projector.
  • Phil Purviance Level 1 Level 1 (15 points)
    Thanks for the tip! Only 1920 x 1080 (interlaced) was showing up in my display settings for my HDTV. For a while I was a little disappointed that the settings did not go higher to 1080p (non-interlaced). But for some reason setting the "Number of Recent Items" to 5 or 10 shows an additional resolution. It now shows:

    1920 x 1080, 50 Hz (PAL), Millions
    1920 x 1080, 60 Hz (NTSC), Millions
    1920 x 1080, 60 Hz (NTSC), Millions

    The second 1920 x 1080 resolution is sent to the TV as 1080p!! The Display preferences panel still states that is is the interlaced setting, but just ignore that. Thanks again for the tip, and I hope that the setting becomes standard in the settings in the future.
  • Phil Purviance Level 1 Level 1 (15 points)
    Oh, and you may need to turn off video mirroring to get the full effect and have your the video fill your TV screen. So far, it looks incredible, although I've only tested it with a couple movie trailers. It is pretty taxing on the cpu and/or graphics card, so there were some stutters.