5 Replies Latest reply: Sep 21, 2005 12:12 PM by Finlay
Garth Humphreys Level 1 Level 1 (15 points)
I'm having some difficulty logging in to our Xserve (running 10.4.2) from Terminal running on local machines on our network. I ssh admin_user@X.X.X.X, hit enter and it just sits there (i.e. I never get the prompt for the password)

I can ping the serve fine through Terminal (either the IP address or the local name), file services and all the other services are running fine for the client macgines in OS X, but it doesn't responde to ssh connections. I can also log in fine with that admin user account (including inside Terminal) if I go and sit in front of the server itself.

Any ideas?
  • Jeremy Matthews Level 3 Level 3 (635 points)
    Could this be prevented by a firewall (port 22) ?
    Perhaps the user does not have access, or does not have a default shell set in WGM?

    -jeremy
  • Garth Humphreys Level 1 Level 1 (15 points)
    The log in name is an administrator account on the server and has a default shell set. It's all happening on our local network inside our firewall so I don't think that's causing the problem.

    Cheers

    Garth
  • Matt Richard Level 2 Level 2 (160 points)
    Does the server have it's firewall turned on? If so, check out the server's firewall rules. Turn on firewall logging while you work on this to see if your packets are being blocked.

    Have you enabled or disabled SSH access for individual users? With Server admin, click on the server (as opposed to one of the server's services) and click Settings (bottom right) and hten Access (top right).

    -Matt
  • junkopardner Level 1 Level 1 (15 points)
    When i have a system in this state, "sometimes" the following works:

    ssh system.foo.edu bash
    (you will not get prompt, but things like ls may produce output)
    shutdown -r now

    or for that matter: ssh system.foo.edu "shutdown -r now"
  • Finlay Level 4 Level 4 (2,415 points)
    Hi Garth,

    Can you post the output of this command:

    ssh -o LogLevel=DEBUG3 admin_user@X.X.X.X

    Hopefully that might shed some light on the problem.