13 Replies Latest reply: Feb 8, 2008 12:08 PM by teofilo
kwal Level 1 Level 1 (0 points)
I just got a new ipod classic (160 gb) yesterday. I use a Mac G5 with Mac OSX.
Yesterday, it loaded my entire library onto it. No hitches.
This morning, I hooked it back up and it told me that my firmware was out of date. When I tried to update the firmware, the ipod suddenly ejected itself. This repeated several times.
When I tried it on my laptop, the same thing happened.
After reading some of the posts here, I decided not to upgrade the firmware and just wanted to manually update the ipod. When I tried to do that, it ejected itself just before I was able to check the manual box.
I have re-set the ipod several times. I have rebooted the computer. I tried it on different computers. I tried a different cord. None of this has made a difference.
Any thoughts on how I can fix this? Really aggravating.

IMac G5, Mac OS X (10.4.11)
  • velvet11 Level 1 Level 1 (0 points)
    I have the same exact problem. Very frustrating...especially since my old iPod worked like a charm.
  • T-Maaz Level 1 Level 1 (20 points)
    I wanted to add my info to this thread, as I am having the same problem (with an added twist).

    I got my new iPod home, registered, declined the free videos, and started the sync -- it took many hours to get everything loaded up, but finally finished.

    I noticed the "version 1.0.3 update available" after I had already started the sync... so once the sync was finished, I clicked on the Update button -- and one of two things happens repeatedly, no matter how many times I have tried:

    1) As soon as the unpacking progress window opens, the iPod suddenly ejects itself (e.g., the screen on the iPod says "Ejecting - you may now disconnect" -- this causes the update to fault out, giving the iTunes error "The update can not be completed, because the iPod "xx" cannot be found"... even though the iPod is still visible on the desktop, and in the iTunes sidebar (while the iPod itself, however, has switched over to it's charging screen, as if it's not connected but still plugged in.)

    2) It goes through the "Unpacking Software" progress window, asks me to Authenticate, spins for about 3 minutes... then pops an error message "the iPod "xx" could not be updated", with an error # of either 1430 or 1462.

    I went through the "5 R's" repeatedly, to no avail. I really do not want to do a restore and start over -- it took nearly 10 hours to get all my music and videos on there -- from the sounds of the posts on here, it doesn't sound like that will work either.

    Would love to hear if anyone has seen or heard anything about this, as it's definitely not just a couple isolated incidents. Pretty frustrating - I've never had an issue with the 4 other iPods I have owned up to this point.
  • fontan75 Level 1 Level 1 (10 points)
    I am also having the same issue, I am trying to do the update and my ipod ejects and then reconnects. even if I tell it not to install the update it does the sync and the automatically ejects. I am about ready to take it to Apple and talk to them, but then I have to drive an hour for that.
  • lobornik Level 1 Level 1 (0 points)
    I have the same Problem with my iPod Classic 160G.
    The iPod is also really slow. It takes a while to flip between menues or change a song. I hope that this is solved after an update, but the update ist just not possible.
  • T-Maaz Level 1 Level 1 (20 points)
    After scouring the message boards, I found an unrelated issue that had an interesting solution, so I decided to try it... and lo and behold!! I was able to update my Classic iPod's software to 1.0.3, without getting disconnected or having the auto-eject happen.

    Here's what you do:

    1) Fully charge your iPod.

    2) Disconnect your iPod from everything.

    3) Put your iPod into "Disk Mode"
    a) Toggle the Hold switch on and off. (Slide it to the Hold position, then off again.)
    b) Press and hold "Menu" and the Select button, until the Apple logo appears (about 6 to 10 seconds).
    c) Once the Apple logo appears, release the "Menu" and the Select button.
    d) While the Apple logo is still visible, quickly press and hold the "Play/Pause" and Select button, until the "Disk Mode" screen appears. (This looks like an old-school black and white Macintosh Finder window, with a check mark in it.)
    e) Once the iPod is in Disk Mode, release the "Play/Pause" and Select button

    4) Connect your iPod to your computer -- the iPod will stay in Disk Mode

    5) Open iTunes (if it doesn't open automatically)

    6) Click once on the iPod icon in the left-hand column, then click the "Update" button in the main Summary view.

    7) Follow the prompts.

    I hope this works for everyone else -- it finally allowed me to update the software to 1.0.3... we'll see if it rectifies the auto-eject issue after synching.
  • Davey A Level 1 Level 1 (0 points)
    I bought myself and my son an ipod classic each and they had the self disconnect problems.
    They connected OK but if you moved them slightly, picked them up or moved the wire they disconnected.
    I cleaned the contacts in the bottom of the iPod with a soft lint free cloth , polished rigourously, then, while the USB was not in the Mac, I held the connection clips in on the iPod end of the cable and pushed it in and out several times to clean the contact surfaces where they touch each other.
    This seems to have done the trick.
    There must be a manufacturing residue on the contacts which just needs coaxing off with the cloth.
    I would be interested if this cures other peoples connecting problems for my own peace of mind if anything.
  • roger peppe Level 1 Level 1 (0 points)
    i have exactly the same problem (80GB ipod classic, upgrading to 1.03 from 1.02);
    unfortunately following the "disk mode" fix above did just resulted
    in the same problem (unknown error (1462)).

    i had exactly the same problem trying to upgrade to 1.02; i gave
    up for a month or so, then tried it again on a whim, and
    it just worked. i remember that i tried the "disk mode" fix
    before, and it didn't work for me then either.

    my ipod is totally vanilla (other than the music, video and
    photos i've loaded onto it) - i've not put any different software
    on it, or used it with anything that wasn't iTunes, so i'm
    surprised that everyone isn't getting this problem!

    does anyone know anything about the underlying cause of this problem?
    it's really annoying!
  • roger peppe Level 1 Level 1 (0 points)
    to reply to my own post, i've just found a fix to the problem. i was
    plugging the ipod in through an external 4-port usb hub - it worked when i
    connected directly to the computer.

    i had to reboot in order to do so though, as i've got an
    old mac mini with only two USB ports, one of which i use
    for an external 500GB drive with my entire home directory
    on it, including all the itunes files, the other port has the hub
    with mouse, keyboard, etc.

    usb hubs seem to work transparently in all other situations - why
    should this be different?!
  • scullypdx Level 1 Level 1 (0 points)
    Well, this is the weirdest thing ever. I've had the disconnect/connect/eject thing going on with my ipod classic 80gb (first ipod ever). I tried the 5Rs and everything else I could find on this forum. Nothing worked.

    Then I tried to think about what I'd changed recently. The only think I had done was enable "cover flow" in itunes. I turned that off, went back to normal view -- and damned if my ipod didn't connect and sync perfectly!! No idea why.
  • teofilo Level 1 Level 1 (0 points)
    I managed to update my ipod after turning on the option "use as harddrive" (don't know the exact english name).
    I was operating in disk mode when it worked but I think the last time (upgrading to 1.0.3) I toggled this option too before the update finally worked.
  • teofilo Level 1 Level 1 (0 points)
    I forgot: I also deactivated automatic sync in the itunes options.
  • Roger Meier Level 1 Level 1 (0 points)
    I got errors 1462 and 1432 when trying to update my 160Gb Classic to version 1.1. Synchronizing otherwise worked fine. I had it plugged into a Belkin USB hub.
    When plugging it directly into the Mac, it update without a problem
  • teofilo Level 1 Level 1 (0 points)
    meanwhile while upgrading to 1.1 I'm quite sure you can keep the ipod from ejecting by using the "use as harddrive" option. At least it worked with mine.