Skip navigation
This discussion is archived

Canon Pixma MP780 scanner won't work w/ Leopard -- can u help??

2255 Views 5 Replies Latest reply: Jan 4, 2008 3:47 AM by PAHU RSS
doctorbecky Calculating status...
Currently Being Moderated
Dec 27, 2007 7:37 PM
Hello everyone ... I have read what everyone says about getting the Canon scanner to work ... and I have gone to the Canon site and downloaded everything there is ... still ... NO GO!! I tried VueScan and it won't get my scanner to budge, either. I have tried using ScanGear, and no way will it work. When I try directly from the scanner itself, or through Photoshop Elements 4.0, it will not respond. I was working on a family movie (for Christmas) last month when I made the mistake of downloading Leopard ... all of a sudden the scanner wouldn't scan. I ended up spending hours and lots of $$ at Kinkos scanning photos on a PC of all things!! This should not have happened ... I should have been scanning for free on a MAC in the comfort of my home. If you guys can offer any advice I would certainly appreciate it. I don't want to hate Leopard, but I'm starting to ...
Pwerbook G4 & G5 Tower, Mac OS X (10.5.1)
  • PAHU Level 6 Level 6 (14,400 points)
    If you have upgraded from Tiger to Leopard, then it is likely you have some scanner driver version conflicts.

    Open Finder and navigate to HD/Library/Image Capture/TWAIN Data Sources. Here you should see the Canon MP780.ds file. Trash this file.

    Then navigate to your home folder/Library/Preferences/Canon and delete the ScanGear folder. Empty the trash and restart.

    Next, download version 12.13.0 of the MP780 Scanner Driver from the Canon web site and install this.

    Now try scanning using Image Capture and see if this works. If it does, then try it using Elements and VueScan.
    MacBook Pro, Mac OS X (10.4.11), Mac Pro (10.5), G4's, G3's, G5's, Mini's, iMac's, Xserve G5
  • GrowFins Calculating status...
    Thanks!!!!!! It worked!!!!
    Scanning from Photoshop works perfectly, again.
    power mac G-5, Mac OS X (10.5.1)
  • PAHU Level 6 Level 6 (14,400 points)
    doctorbecky wrote:
    It still doesn't work if I try to scan directly from the Scan Gear icon in the dock, but it does work when I scan from Photoshop Elements from File/Import/pick your printer.

    I think the ScanGear icon you mention has more to do with MP Navigator. I don't have this application installed as I previously found on Tiger that it was the cause of system crashes. So I only have the scanner driver installed and use applications like PhotoShop to do the scanning.
    Do you have Kinko's in Australia??

    Yes we do, although I have never used them. My company has plenty of colour printers and copiers to cover my printing needs
    MacBook Pro, Mac OS X (10.4.11), Mac Pro (10.5), G4's, G3's, G5's, Mini's, iMac's, Xserve G5

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.