3 Replies Latest reply: Feb 18, 2008 4:26 PM by RJAVHH
Gerardo Tamez Level 1 Level 1 (25 points)
How do I switch to 24 hour format in iCal. I've tried everything, I don't have that option in iCal Preferences. My computer clock is set to 24 hour format too.

iMac G4, Mac OS X (10.4.11)
  • Pascal Bouvier Level 4 Level 4 (2,880 points)
    go to system preferences>international>formats and choose the time format you would like to use on our computer.

    hope this helps
  • Gerardo Tamez Level 1 Level 1 (25 points)
    Issue persists. My time format is already 24 hour. Nonetheless I went to International in System Preferences, but that gives me only personalize options. On the other hand I double checked the option 24 hour in Date and Time (System Preferences).
  • RJAVHH Level 1 Level 1 (0 points)
    I have to say I am extremely disappointed in Apple with regards to these setting issues. The only way I was able to get rid of the annoying AM/PM indicators in iCal was to follow a suggestion to switch the settings to UK. (Just setting preferences to US and switching to a 24-hour format yielded a 24-hour clock and AM/PM indicator in iCal!)

    Recently having switched (back) from Windows machines, these "inflexibilities" are a surprise to me. I though Apple would be on top of their game in this regard. Also, in Europe, people use week numbers. I don't see any option for that in iCal either.

    I really hope this gets fixed. It seems to be a very basic issue...