6 Replies Latest reply: Dec 29, 2007 8:43 AM by brainslice
bfdhud Level 1 Level 1 (5 points)
I have a linux server in my living room running Samba. Windows can play with it just fine (read & write)

However, when I'm on my macbook I can only read from the share, whenever I try to write to it I get this extremely vague and irritating error message

You cannot copy the item "Flip4Mac WMV.mpkg" because the name is too long or includes characters that the disk cannot display.


Now replace Flip4Mac WMV.mpkg with the name of every file I have ever tried to do this with.

Also a note, this only happens when I drag and drop into the finder window. If I use Cyberduck I can sftp into it just fine and have full read/write access. This is also the same linux/samba user that I use on windows and have full read / write priv. So I don't think that my linux permissions are the problem.

Macbook 2.2ghz 4gb ram 200gb 7200 rpm hdd, Mac OS X (10.5.1)
  • mreckhof Level 2 Level 2 (405 points)
    What happens if you open Terminal and copy the file manually?
  • mreckhof Level 2 Level 2 (405 points)
    Looks like it's an NLS setting on the Linux box.

    Make sure you're running the latest Samba and configure smb.conf to use utf-8.

    Here's a link to a page that discusses this: http://www.nslu2-linux.org/wiki/Optware/Samba

    International character support or Unicode support

    If you want to store files from Windows using foreign characters from languages like Chinese, Japanese, Korean, etc you definitely need Samba 3, as it supports this out of the box.
    Here is what you should add to [global] section of the smb.conf for Samba 3.X.X to enable Cyrillic (Russian) support for Windows XP clients

    unix charset = UTF-8
    display charset = UTF-8
    dos charset = 866

    I use these settings for support of Norwegian and Portugeese characters in filenames under Unslung 6.8 (samba 3): unix charset = UTF-8 dos charset = CP850 display charset = ISO-8859-1 I put these settings into /unslung/smb.conf and put the rc.samba in the same directory (comment away the first line). You also have to change the config file name in /unslung/smb.conf.
  • bfdhud Level 1 Level 1 (5 points)
    No dice, That actually made Samba unusable in OS X.


    but not windows.

    Message was edited by: bfdhud
  • mreckhof Level 2 Level 2 (405 points)
    Interesting.

    I suspect it still has something to do with NLS differences. I'd recommend digging along that route.
  • bfdhud Level 1 Level 1 (5 points)
    You're probably on to something, I just noticed on the distro's support forums that other people have gotten 10.5.1 and Samba to work together. I'm going to pursue this there.


    Thanks for all the help though
  • brainslice Level 2 Level 2 (410 points)
    Have you tried watching your syslogs when the failure happens? This may give some indication on what's going on. I agree with the above posts that this is likely an issue with the the version and/or configuration of your smbd.

    fwiw, samba 3.0.24-2.28 running on SLES10 works with Leopard no problem. If you don't have any luck with your current setup you may want to have a look at openSuSE http://www.opensuse.org It's a nice distro and is very easy to set up samba and other network services.