Previous 1 3 4 5 6 7 Next 90 Replies Latest reply: Aug 19, 2010 7:19 AM by Jay Bullock Go to original post
  • SteveB1983 Level 1 Level 1 (0 points)
    Downloading and re-installing latest cominbation update works!

    I just wanted to confirm the fix by theolog, as well as actuarius in the following post:

    http://discussions.apple.com/thread.jspa?messageID=10033810

    If you want to avoid copying files, doing plists, repairing permissions and all of that, download the latest MAC OSX Combination update and re-install it (or install it for the first time). This resets everything and when that first popup appears regarding incoming connection, ALLOW it and you should be good to go.
  • Gizmomatic Level 1 Level 1 (0 points)
    There's an easier fix (for OSX 10.5 and newer, may work for older versions)
    The fix includes adding the services configd and etc...
    to your firewall rules and setting them to "allow connections"

    steps
    1) Open System Preferences
    2) Select Security
    3) Select Firewall
    4) Make sure the OSX is managing the firewall and click on the add sign "+"
    5) Now open finder and on the top menu click on "Go" and select "Go to Folder"
    6) Type in "/usr/sbin"
    7) locate "configd"
    8) Drag configd to the open dialog box for the firewall and you'll see it selected.
    9) Then click on add
    10) Now just make sure it's set to "allow all connections"

    Typing this up took longer to do than the actual fix. Actual fix is quick and easy wish I had some illustrations as they're easier to follow, sorry.
  • rbtwrld Level 1 Level 1 (5 points)
    I have found that sometimes this bug is related to the creation date of this files:

    configd, mDNSresponder

    They show 1969, this was causes because my computer was shutdown in a bad way.

    To fix this files you need to edit the creation date, use this software:

    http://www.gideonsoftworks.com/filexaminer.html

    And go to finder and press altshiftg
    Then access /usr/sbin

    Doing this I have fix my computer without going to another mac to get those files and replace them.
  • Arjan van Bentem Level 1 Level 1 (0 points)
    A note from Apple in Mac OS X 10.5 Leopard: About the Application Firewall that might be related with the theory of the ad-hoc signature, as suggested by jamus j:

    Some applications check their own integrity when they are run without using code signing. If the Application Firewall recognizes such an application it will not sign it, but then it will re-present the dialog every time the application is run.
  • Matti Haveri Level 6 Level 6 (8,840 points)
    Running the Mac OS X Combo 10.5.8 Update fixed this problem for me, too. Thanks!!

    My problem was that sometimes I could not connect to the Internet. Then sometimes after some tweaking and rebooting I could, but even then the AirPort Utility.app failed to find the AirPort Extreme Base station.

    Luckily I then happened to glance the Firewall log and saw the "Deny mDNSResponder" error. Googling it led me to a few sites that revealed the problem and the fix. Whew, I'm a long-time Mac user but fixing this needed some serious sleuthing. I already was planning to reformat and reinstall everything (my older backup system as well as all other WiFi gear was OK so I suspected a software problem).

    Another thing: I noticed that letting the Applejack utility empty the caches and check the preference files reintroduced the error, so I then had to run the Combo Update again. So now I'm very cautious of running Applejack again.
  • Matti Haveri Level 6 Level 6 (8,840 points)
    letting the Applejack utility empty the caches and check the preference files reintroduced the error, so I then had to run the Combo Update again


    OK, Applejack is innocent here:

    Just resetting the Power Management Unit (PMU) and PRAM reintroduced the error. I noticed that mdnsresponder and configd dates were then set to 1970 (because resetting PMU resets the clock) -- maybe that also unsigned them ("adhoc" output was present again)??

    Running the 10.5.8 Combo Update set those dates to Jun 18 2009 and fixed the error (again!).
  • MrGoteman Level 1 Level 1 (0 points)
    Yes! I think this might have solved the problem for me as well. Thanks for your help buddy!
  • jdm73 Level 1 Level 1 (0 points)
    Good stuff. I got configd and mDNSResponder signed back by the Combo Update. But how would I get nmblookup resigned? Unfortunately, I didn't know about Time Machine until now so I don't have any backups from which I can get a legitimate file.
  • romad Level 3 Level 3 (590 points)
    Thank you all. I had the exact same problem on my PowerBook running 10.5.8. A re-install of the 10.5.8 COMBO Update seems to have fixed it.
  • RKanes Level 1 Level 1 (0 points)
    I had exactly the same set of DNS symptoms occur after a major power outage, and now show "Signature=adhoc" on both configd and mDNSResponder. (Like the others on this thread, if I temporarily set my Firewall to "Allow All Incoming Connections", I get a working IP address). I need a little more detail on the fixes in this thread: is it better to re-run the latest combo updater, or copy files from an earlier TimeMachine backup? If the latter, could you please be very specific about how to do it? I have Pacifist, but I need precise details on how to extract the files, copy them over, and where to replace on the affected machine. I'm not a unix power-user, but I can follow detailed instructions, and use the Terminal if required. Thanks in advance.
  • Juju Banton Level 1 Level 1 (0 points)
    Just wanted to confirm that this method worked for me too. Didn't have to go into Terminal though. Here's what I did:

    1) In Finder, under the Go menu, I chose Go to Folder and entered: /usr/sbin and clicked OK.

    2) Highlight the configd file.

    3) Go into Time Machine. In the same Finder window from step 2, highlight my Time Machine drive under Device on the left-hand side of the window.

    4) Click the arrows in the Time Machine interface to go back in time before my logic board was replaced. If your Finder is set to show the path bar (View > Show Path Bar), you'll see the path of where you are along the bottom of the Finder window. You can use this to confirm you're in the right place. Mine said:

    - From Step 2 above: (Name of my computer) > usr > sbin > configd

    - From Step 4 above: (Name of my TM backup drive) > Backups.backupdb > (Name of my computer) > (Date I had gone back to) > (Name of my computer) > usr > sbin > configd

    5) Click Restore and restart.

    Note: The date on the configd files was the same, so I didn't think it would work. But it did.

    That's it! Some context in case you wanted some:

    I had my logic board replaced because of the documented Nvidia graphic card failure (thankfully my machine fell within the 3-year grace period, mid-2007 MacBook Pro, so I got the repair for free).

    Also ran into networking issues post-repair, Airport kept having a self-assigned IP address, even connecting to my router directly via Ethernet didn't work..

    This thread helped me figure out that my firewall was not allowing configd through. Had to keep "Allowing all incoming connections," wait for Airport to get a working IP address, then switch the firewall back to "Set access for specific services and applications."

    I didn't want to run the 10.5.8 combo update since I wasn't sure if there would be issues: i.e. Safari is currently version 4.0.4 and the combo update page says the included version of Safari is 4.0.2. Without knowing if the update was smart enough to leave more up-to-date files alone, I didn't want to risk making things worse.

    I tried another solution offered in this thread: 1) navigating to Macintosh HD\Library\Preferences\System Configuration, 2) archiving com.apple.network.identification.plist and com.apple.smb.server.plist, 3) restarting so new files would be created. No success.

    The Time Machine solution above worked. Even after sleeping all night, my computer still has an IP address, so I hope it sticks.
  • MichelA Level 1 Level 1 (25 points)
    For those who don't have Time Machine, the only PERMANENT solution that I found was to reinstall Leopard (make sure to back up or archive your old files).
  • John Sawyer1 Level 2 Level 2 (230 points)
    This (adding these items to the list of allowed items) doesn't always work for a lot of people. When it doesn't work, (re)installing the Combo updater usually does.
  • John Sawyer1 Level 2 Level 2 (230 points)
    The following worked for me when I had some of the problems with OS 10.5.8's firewall, internet connection problems, etc. discussed in this thread, after I accidentally unplugged my Mirrored Drive Doors G4. It's mostly a detailed explanation of how to perform some of the suggestions posted here earlier, particularly what user lstnmysphr suggested here about replacing the com.apple.alf.plist file with a backup:

    Run the latest Combo updater appropriate for whichever version of OS X you're running.

    Open whichever prefpane (depending on the version of OS X you're running) that contains the firewall settings tab (in OS 10.5 and later, it's in the Security prefpane; in earlier systems, it's in the Sharing prefpane). Select the firewall tab's option to allow all incoming connections, then close this prefpane and open the Network prefpane. Select its button to renew the DHCP lease. Close the Network prefpane, then open the firewall tab again, and change the setting to whatever you had it at before ("set access for specific services and applications", etc.), then close the firewall tab's associated prefpane. This works permanently for some people, but only temporarily for others, until the next restart.

    If that doesn't help, or doesn't remain permanent, open the firewall tab, write down the names of all the items you selected to allow incoming connections, then close the prefpane, and drag out the plist file com.apple.alf.plist, at /Library/Preferences, to some holding location like the Desktop (in case you need it again), then place a backup copy at /Library/Preferences, using the system's backup copy that's at /usr/libexec/ApplicationFirewall. (OS X normally replaces the active copy of com.apple.alf.plist at /Library/Preferences if you just trash it, but some people taking this approach find the com.apple.alf.plist file that the system recreates no longer fixes the problem at next restart, so it's best to replace it from the backup.) Restart the Mac. If you wish, add back the whitelisted items you wrote down, but it might be best to add them one at a time, and restart the Mac each time, to see if any of them cause the trouble you were originally seeing. The first time you open the firewall tab after replacing com.apple.alf.plist, it won't contain anything except a single entry for Printer Sharing, but as you allow items to accept incoming connections, more items will get added here (mainly to the plist file's "applications" section, visible using something like Property List Editor, or even just TextEdit). This plist file already contains the items mdns, configd, mDNSResponder, and many other things, but they don't appear in the firewall tab (contrary to what some people think) unless you specifically add them, which may be redundant. Though you can manually add these items to see them in the firewall whitelist, this is usually unneccessary--I think the better way to get these items working again, is to replace the com.apple.alf.plist file. After doing this, you may no longer see entries (or may see fewer entries) in the Console logs about mDNSResponder, configd, etc. being denied ("Deny configd data in from 192.168.1.1:67 uid = 0 proto=17"), unless something else is wrong. However, seeing these "deny data" messages in the logs may not automatically mean there's a problem with these.
  • jenjewlz Level 1 Level 1 (0 points)
    I have the same issues with my Mac I think there may be something serious going on. First my battery will not hold a charge(I have a MacBook which I bought last Nov. it's not even a year old, I have to keep it plugged in and if I unplug it, it resets the date & time and the mdnsresponder, configsd, and nmb lookup connections request appears. I am a newbie to Macs so I googled the issue and there was a suggestion to reset the PMU and these messages appeared ever since. Also, I have all types of console errors that have increased tenfold since I did the PMU including crashes enable stealth mode etc.. I was going to post the actual message but I seem to have written a ton already! Has anyone else experienced ALL of this?
Previous 1 3 4 5 6 7 Next