Previous 1 2 3 Next 90 Replies Latest reply: Aug 19, 2010 7:19 AM by Jay Bullock
SolRayz Level 1 (0 points)
Everytime I boot up now I recieve these annoying messages that say
[QUOTE]Do you want the application "configd" to accept incoming network connections[/QUOTE]
[QUOTE]Do you want the application "mdnsresponder" to accept incoming network connections[/QUOTE]

If I click on deny on both I have no inernet connection. Also if I go to System Preferences and set my Firewall to "receive all incoming connections" essentually turning my firewall off these messages stop occuring on reboot.
I think this all happened after trying to recalibrate my MBP battery but I am not sure. When I installed Leopard over a month ago I did a fresh install and all was fine, until recently.
Anyone have any ideas?

15" Macbook Pro 2.4, Mac OS X (10.5.1), AEBS
  • madprof4 Level 1 (0 points)
    I have the same problem, just started a couple of days ago. Perhaps it was the last system update? I'm reluctant to let applications I can't recognize get through the firewall, so as a workaround I've been starting each session by allowing all connections in the firewall System Preferences panel, then restricting them once everything is up and running.
  • David Poller Level 1 (35 points)
    I'm getting the same messages, just started two days ago after I recalibrated the battery on my Powerbook.

    Any ideas?
  • sinjunkie Level 1 (110 points)
    This just started for me after I had to reset the SMU and PRAM on my G5.
    Also nmbd showed up it the firewall around the same time.
    What do theses mean?
    Why does Leopard keep asking every startup even if I allow?
  • Martin Capps Level 1 (30 points)
    Just been getting the same message these last few days. Only new thing I've been doing is trying, unsuccessfully, to use iDVD. Every time I try and use iDVD the program just shuts down. And now I keep getting these annoying messages on boot up.
    Come on Apple - I expect better, never had problems like this on Tiger.
    Very frustrating.
  • dhowell626 Level 1 (0 points)
    I'm having this EXACT problem, since I got my Macbook back from Apple service Thursday for a hinge issue. As far as I know, all they did was fix the hinge, I don't know what they would have even done to any software. But this is the exact thing I'm getting, with the errors about mDNSResponder and configd, and I also had "nmdb" show up in the "good" list in my firewall. I'd really like to see some info on this issue, I don't like having my firewall off. I've never had any problem like this before.
  • Ten23 Level 1 (0 points)
    I was having this same annoyance/problem after resetting the PMU on my 15" Powerbook G4. I fixed it by deleting the keychain entry for my wireless network's encryption key. Naturally, the next time I connected to my wireless network I had to type in the encryption key, but I was not bothered with the "allow" or "deny" dialogs after rebooting. I hope this fix works for you guys too.
  • Simon69 Level 1 (30 points)
    I have half an answer, but have been unable to fix the problem myself.

    I also just got my Macbook back from repair, and when it first started up the time needed setting as it had gone back to 2001 or something.

    This is where my problems started.

    I have had a good look around and discovered that some of the Keychains and certificates are now missing in the "System" area, whereas they were there before.

    These are: and

    I have tried all sorts to export them from another machine, but can't figure out how to do it (maybe you're not supposed to be able to ?)

    In the end, I decided to backup my files and reload everything from the DVD, this worked, but a little extreme.
  • interconnect Level 1 (0 points)
    hmmm, i tried your suggestion and it did not work for me. i've had firewall problems since day one with leopard. first it was "qmasterd", which i got to go away recently by clearing all entries in the allowed applications list. now it's "mdnsresponder" and "configd" which like the rest, started popping up upon boot-up just recently.
  • mammonist Level 1 (10 points)
    I am having these same problems with my son's iBook, running Leopard. We finally got to the point where we couldn't get him Internet access until I simply shut off his firewall. I am not thrilled to have it off but I don't know what else to do. Any suggestions would be very welcome.
  • Eric Thompson Level 1 (20 points)
    I am having the same problem since I had a battery problem and had to reset my PMU and PRAM. I have to shut off my firewall to get a DHCP config then turn the firewall back on. This usually happens each morning when I startup. Apparently both of those apps are needed to pick up DHCP settings, but the firewall on strict settings won't let them thru. I cannot find a way to permanently allow them through. Hopefully someone will figure out a solution for us all.
  • WendySH Level 1 (0 points)
    I have the exact same problem with mdnsresponder and configd and nmblookup. nmblookup will eventually show up in my allowed list in the firewall settings, but the other two will not. It all started for me when I restarted after running boot camp and the date and time needed to be reset. (The time needs to be reset every time I use boot camp - another bug - but the date usually is fine.) I got a warning that some things may not work correctly if I didn't reset the date, which I did immediately. Ever since then each time I restart I have to either allow them or allow all incoming connections to get networking to function.

    One of the above posts mentions that and need to be replaced. Could this be done from a time machine backup? If so where are they supposed to live exactly? I tried deleting the network keychain items and re-entering them but it did not help.

    I, also, never had problems with Tiger and have had a number of things like this occur with Leapord that seem not to be able to get resolved. Very disappointing.
  • Dez Chesterfield Level 1 (10 points)
    Reading this article, <>, it says that the certificate is machine-specific, so I suspect that even if you could export it from another Mac, that won't help you.

    Looking at my own Macs, I can see the certificate is indeed different on each one. So is the systemdefault certificate.
  • Dez Chesterfield Level 1 (10 points)
    I have also found this article <> about resetting the KDC's certificate and key pair. NB: I haven't tried it!
  • Heinrich Level 1 (0 points)
    I had exactly the same problem. Now I added


    to the allowed applications in the Apple firewall. The annoying messages after rebooting have gone away!
Previous 1 2 3 Next