8 Replies Latest reply: Jan 13, 2008 11:21 AM by SKDrives
pierredeparis Level 1 Level 1 (0 points)
please reinstall iTunes....

I have tried to reinstall iTunes, QuickTime, reboot, clean registry... and I always get the same error when connecting iPhone to my laptop.

Ps The first time I connected it was working fine.... it went to the iPhone activation page... but not anymore...

Please share your experience

Iphone 1.1.2, Windows XP
  • Lawrence Finch Level 7 Level 7 (32,640 points)
    Open the Task Manager (CTRL><SHIFT><ESC> and verify that AppleMobileDeviceService.exe is running (on the Processes tab; click the Image Name heading to sort).

    If it isn't open Control Panel/Administrative Tools/Services and find the service. Right click and choose Start. If it starts try syncing again.

    If it was running to begin with you need to dig further. Let us know what happens.

    See also:
    http://docs.info.apple.com/article.html?artnum=305716
  • Jason L Community Specialists Community Specialists (10,990 points)
    Hey pierredeparis,

    FIrst uninstall the related Apple software from the computer as described in this article:
    http://docs.info.apple.com/article.html?artnum=93698

    If you run into a problem uninstalling or getting iTunes, Quicktime or the Apple Mobile Device service uninstalled or installed take a look at this article:
    http://docs.info.apple.com/article.html?artnum=93976

    Jason
  • pierredeparis Level 1 Level 1 (0 points)
    Lawrence, Jason,

    You were right.... AppleMobileDeviceService is not there... I mean it is not installed. However it is physically on the disk... I don't want to reinstall iTunes again as I am sure the service will dissapear as ussual after new iTunes install...

    I think my computer (company one) removes certain settings after reboot as for example it removes DNS server names in my TCP/IP connection after each reboot.

    Is there a way to install the service myself without full iTunes installation?

    thank you in advance
    Paul
  • Lawrence Finch Level 7 Level 7 (32,640 points)
    If you go to Control Panel/Administrative Tools/Services is it listed there? If it is, can you right click on it and start it?

    If it isn't there I think you are stuck, as the only way to add a service is to edit the Registry and if they block services they certainly won't let you edit the registry.

    It's also possible that your spyware filter, antivirus or security application is blocking it. Do you have access to the settings for any of these?
  • pierredeparis Level 1 Level 1 (0 points)
    Indeed the service is not listed.

    I have found in the registry editor branch under HKEY LOCAL MACHINE
    SOFTWARE
    Apple Inc.
    Apple Mobile Device Support and the key : InstallDir pointing to C Progran Files\Common Files\Apple\ Mobile Device Support

    And this is the only place telling about Mobile Device Support in the registry (I have searched using "Apple" as search).

    Shall I add it in registry in some other way?

    I turned off all the protection, anti virus and spyware but still the service is not present after the reboot. I added it in the startup (to run AppleMobileDeviceSupport.exe at startup) but it seems that it is not working this way....
  • Lawrence Finch Level 7 Level 7 (32,640 points)
    That entry is for the installer, so it won't help. You need an entry in the Services key.

    I've provided an Export of my key. If you are very brave, and back up your registry first, you can try adding it. Copy the text between the double lines, paste it in to a new Notepad file with the file extension .reg (eg, "applemobile.reg") then save and execute the file. It should add the key to your registry. Then reboot and see if it shows up in the Services editor. But do a registry backup first (In the registry editor: file/export... then click the "all" radio button and give it a distinctive name).

    As to why the installer didn't add it that may have also been your antivirus or spyware filters. Especially if you use AdAware, which is happiest if you can't use your computer for anything, any time, anywhere.


    ================================
    \[HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Services\Apple Mobile Device\]
    "Type"=dword:00000010
    "Start"=dword:00000002
    "ErrorControl"=dword:00000001
    "ImagePath"=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,00,\
    6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,5c,00,43,00,6f,00,6d,00,6d,00,6f,\
    00,6e,00,20,00,46,00,69,00,6c,00,65,00,73,00,5c,00,41,00,70,00,70,00,6c,00,\
    65,00,5c,00,4d,00,6f,00,62,00,69,00,6c,00,65,00,20,00,44,00,65,00,76,00,69,\
    00,63,00,65,00,20,00,53,00,75,00,70,00,70,00,6f,00,72,00,74,00,5c,00,62,00,\
    69,00,6e,00,5c,00,41,00,70,00,70,00,6c,00,65,00,4d,00,6f,00,62,00,69,00,6c,\
    00,65,00,44,00,65,00,76,00,69,00,63,00,65,00,53,00,65,00,72,00,76,00,69,00,\
    63,00,65,00,2e,00,65,00,78,00,65,00,22,00,00,00
    "DisplayName"="Apple Mobile Device"
    "DependOnService"=hex(7):54,00,63,00,70,00,69,00,70,00,00,00,00,00
    "DependOnGroup"=hex(7):00,00
    "ObjectName"="LocalSystem"
    "Description"="Provides the interface to Apple mobile devices."
    "FailureActions"=hex:80,51,01,00,01,00,00,00,01,00,00,00,03,00,00,00,53,00,65,\
    00,01,00,00,00,60,ea,00,00,01,00,00,00,60,ea,00,00,01,00,00,00,60,ea,00,00

    \[HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Services\Apple Mobile Device\Security\]
    "Security"=hex:01,00,14,80,90,00,00,00,9c,00,00,00,14,00,00,00,30,00,00,00,02,\
    00,1c,00,01,00,00,00,02,80,14,00,ff,01,0f,00,01,01,00,00,00,00,00,01,00,00,\
    00,00,02,00,60,00,04,00,00,00,00,00,14,00,fd,01,02,00,01,01,00,00,00,00,00,\
    05,12,00,00,00,00,00,18,00,ff,01,0f,00,01,02,00,00,00,00,00,05,20,00,00,00,\
    20,02,00,00,00,00,14,00,8d,01,02,00,01,01,00,00,00,00,00,05,0b,00,00,00,00,\
    00,18,00,fd,01,02,00,01,02,00,00,00,00,00,05,20,00,00,00,23,02,00,00,01,01,\
    00,00,00,00,00,05,12,00,00,00,01,01,00,00,00,00,00,05,12,00,00,00

    \[HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Services\Apple Mobile Device\Enum\]
    "0"="Root\\LEGACYAPPLE_MOBILEDEVICE\\0000"
    "Count"=dword:00000001
    "NextInstance"=dword:00000001
    =====================================
    Message was edited by: Lawrence Finch
  • Lawrence Finch Level 7 Level 7 (32,640 points)
    \[test to see if there is a way to escape brackets\]
  • SKDrives Level 1 Level 1 (0 points)
    I had the same problem, but once i completely removed all Apple Components and reinstalled them, i did not get the message and was able to activate and sync my iPhone.

    Did the following-
    Remove iTunes
    Remove QuickTime
    Remove Apple Software Update
    Remove Apple Mobile Device Support

    Re-installed iTunes
    helpful links - http://docs.info.apple.com/article.html?artnum=93698