Previous 1 2 3 4 Next 47 Replies Latest reply: Jun 24, 2008 8:27 AM by Thomas Berglund
M. Philip Level 1 Level 1 (0 points)
I made clean install of leopard and FCS1, and I did exactly what apple says in this article: "Unable to connect to background process"
http://docs.info.apple.com/article.html?artnum=93234

but it still don't work, and i can't encode anything with Dvd Studio Pro either.

I use G5DP 2Gh and Final cut studio 1.

G5DP 2Gh, Mac OS X (10.5), Mac book pro 15" 2.4Gh
  • Thomas Berglund Level 4 Level 4 (1,595 points)
    Have you installed all the updates for Final Cut Studio 1? (check Software Update)

    What happens when you try click the Start Sharing button, in System Preferences -> Apple Qmaster? Do you get an error message about qmasterd? If yes, try starting it using the following command inside the application Terminal (/Applications/Utilities/).

    sudo SystemStarter start Qmaster
    (type your admin password, and hit enter - you can not see what you type, so just type it in and hit enter)

    You might want to try doing a little Qmaster reset too.

    sudo qmasterprefs -reset
  • Channard Level 1 Level 1 (0 points)
    I did what you suggested and what I got after trying to reopen Apple Qmaster in System Preferences was "Preferences Error: You cannot open Apple Qmaster preferences because it doesn't work on an Intel-based Mac." So, Compressor still won't connect to background process. I guess Apple was a little "Microsofty" with Leopard, making it mandatory to upgrade to FCS2.
  • Jacek Level 1 Level 1 (0 points)
    Brilliant - you are a genius.
    Many thanks.
  • William Baum1 Level 1 Level 1 (5 points)
    Thomas,

    I will second the genius comment. I went and downloaded the updates for compressor and Qmaster and followed your suggestion. Everything went well and Compressor is now humming along under Leopard. Many thanks as I have been struggling with this for two weeks.

    Cheers,
    Bill
  • Chris Lucey Level 2 Level 2 (230 points)
    I just did a erase and install then updated Leopard, installed FCS1, updated and tried this and i cannot get Qmaster to run. Any other ideas ?
  • Thomas Berglund Level 4 Level 4 (1,595 points)
    Channard: It sounds like you have the PPC version of Final Cut Studio. Is that the case, or do you actually have the universal binary (Intel) version?

    jacek and Bill, glad I could help

    I just thought I should mention that I got this problem in FCS2, not FCS1, but it seems like the solution works for both versions.

    When I tried to submit a job in Compressor, after updating to Leopard, the Cluster: drop-down menu was blank, and when I hit the submit button I got this message:

    Unable to submit to queue.
    Please restart your computer or verify your Compressor installation is correct.


    Then I checked Apple Qmaster in System Preferences, and got the message about qmasterd not running. I started qmasterd manually by typing sudo /usr/sbin/qmasterd in the Terminal. After some searching around in the Compressor/Qmaster user manuals, I found the SystemStarter command.
  • Chris Lucey Level 2 Level 2 (230 points)
    Well, i went back to Tiger and did a clean install and spent the better part of a day making my Powerbook new, LOL. FCS and Compressor are working perfectly once again. Too bad Leopard does not like my old Macs. Taking down my G5 now !
  • Matthew Judy Level 1 Level 1 (5 points)
    For a lot of people, starting qmasterd manually fixes the issue, but this is tedious, and you have to do it every time you log in or start up. I posted a fix for this in this thread, which automatically starts qmasterd at startup using the correct method (launchd) proscribed by Apple. I hope it works for you!

    --Matt
  • vsweet Level 1 Level 1 (0 points)
    well, i'm confounded,
    my compressor works fine on my g4 laptop but not on my old g4,
    the only difference is that when i upgraded my osx to tiger so that i could use fcp studio 1, i just upgraded the laptop and did a clean install on the tower.

    ah! now i was considering upgrading to the new g5 thinking of course throwing 3grand at the problem would solve it but reading this discussion is quite discouraging.
    I want to edit, not mess around with tech problems.

    I am new to qmaster and quite frankly don't even know what it's purpose is.
  • provideofxdrew Level 1 Level 1 (0 points)
    I installed the program you attached and followed all the instructions. Still no change I still get the error. I have all the updates and I restarted my computer but still nothing! Any suggestions.
  • provideofxdrew Level 1 Level 1 (0 points)
    I am on a imac 24 inch and I just updated to leopard and I already had final cut pro 2 on my computer. Every since i upgraded to leopard compressor wont work and I get the same exact error. How do I run the qmaster and type in sudo /usr/sbin/qmasterd.
  • carlart Level 1 Level 1 (0 points)
    Matt, I followed your instructions to the letter on installing Lingon and typing in the commands to force QMaster to turn itself on. It doesn't work. Nothing works. I am losing time and more importantly money because the a-holes in Cupertino who assured all of us that "everything was fine with Leopard." were lying through their teeth. I should have ignored that marketing dept. drivel. Never again. I will wait for a solid year before upgrading when the next OS comes out. So sick of this.
    Oh yeah, I forgot to mention I'm trying to launch Compressor 2.1--and yes, I have manually deleted the receipts and apps and reinstalled them from the disk and updated them through System Update.
    I have no idea what to do now. Can you help?
    Thanks,
    Carl
  • jesusali Level 1 Level 1 (55 points)
    I just had success restarting qmasterd on a server that suddenly lost it between transcoding batches.

    Muddling back and forth in Terminal and the Preference Pane eventually did the trick.

    Thanks for these commands!

    _sudo SystemStarter start Qmaster_

    _sudo qmasterprefs -reset_
  • ~DT Level 1 Level 1 (0 points)
    Don't know if this is going to help, but I've been running the PPC version of FCPS1 and have encountered the same issue to no resolution.

    After uninstalling Compressor/QMaster via Apple's recommended process, I was able to install the Universal Binary version of Compressor & QMaster from my local Mac retailer's NFR discs this evening (never hurts to ask --and you're not asking for a serial#). After a few software updates (keep doing the restarts and re-checking until there are no more), qmasterd finally stays running and Compressor works perfectly.

    So, at least for me, it was the PPC version that was the problem w/ Leopard.
Previous 1 2 3 4 Next