Skip navigation
This discussion is archived

My external hard drive won't eject so I can unplug it... and other problems

12927 Views 7 Replies Latest reply: Jan 18, 2008 11:31 AM by larrygal316 RSS
larrygal316 Calculating status...
Currently Being Moderated
Jan 3, 2008 10:04 AM
I bought an external hard drive to use with TM. It is 160 GB Western Digital Travel one. When I initially plugged it in, before I even messed with TM, I partitioned it into 2 drives about 70 GB each, one for TM and one to take stuff off my laptop to create space and store it else where. All was fine and dandy until I turned off my computer and unplugged my external hard drive because I had to take my lap top and didn't want to lug the drive with me. When I plugged it back in and just clicked on TM to see what was available, nothing was there. With it being 2am and me being frustrated I turned it off and am trying to fix it now, except this morning when I plugged in my external hard drive, it can only find my "Extra Stuff" partitioned drive and not my designated "Time Machine Drive" (it doesn't show up on the desktop). I have gone into the disk utility to see if I could repair it, or just erase the TM partition and start over. It currently is trying to "repair" the volume and it says that it is ok, but I didn't know if there were any other suggestions to fix this. It still is not showing up in my desktop.
So far I'm not too impressed with TM. I'm unsure of the best way to disconnect my external hard drive and prevent this from happening again. When I try to simply drag the drive to "eject" to essentially unmount it and then safely unplug it from my USB it asks if I want to "eject all" (meaning the 2 partitioned drives) I click yes and it comes up saying one is still in use. Instead I turn off my computer and unplug it after the computer is off. This is probably a bad idea, but I don't know what else to do. Any suggestions? Do I have to go into the disk utility each time I want to take off my external hard drive and click "unmount"?
Sorry for such a lengthy explanation. Usually programs like this on macs are so simple. TM seems to be less user friendly than their other programs and it has thrown me for a loop.

Message was edited by: larrygal316
macbook, Mac OS X (10.5.1), External hard drive is a USB powered WD Passport
  • mattathayde Level 3 Level 3 (565 points)
    try to unmount it in disk utility instead of just ejecting (unmounting) by dragging to the trash

    i had so many issues when i tried to partition my external drives i just gave up (but the only reason i really wanted the partition was to back up my other external drive but with TM i accomplished that)
    -matt
    MacBook Pro 2.33 Ghz, Mac OS X (10.5.1), Breaking macs since OS 6.0.5 | 20 gb 4th Gen iPod | 8 gb iPhone
  • Peggy Lynn Level 4 Level 4 (2,470 points)
    If Time Machine is running it you will get the message that the disk is busy and you can't eject it. Right or control-click on the Time Machine icon in the dock and pick Stop Backing Up. You should then be able to safely eject the disk.
    Mac Mini, 1.42 GHz, 1 GB RAM, 80GB HD, SuperDrive, Mac OS X (10.5.1), Maxtor One Touch 160GB, HP LaserJet 1320n, Epson R800
  • mattathayde Level 3 Level 3 (565 points)
    ooo you said you dont have any info showing up right, it might not have backed up the first time or it might be trying to back up all your info now since it does not see any info there and maybe hanging up. that might be why you get the message saying the disk is active. the partition may also be messing it up, in theory it shouldnt but it could be

    why did you want to partition such a small drive, i assume you have less than 70 gb of info on your machine if you partitioned the drive down to that so why not just put all that other info that you put on the storage partition on your machine and not deal with the partition.

    -matt
    MacBook Pro 2.33 Ghz, Mac OS X (10.5.1), Breaking macs since OS 6.0.5 | 20 gb 4th Gen iPod | 8 gb iPhone
  • gryyphyn Calculating status...
    I'm having the same issue. Time machine isn't actively running, though just to be sure I turned the service off through the TM utility: no go. Still can't eject. Getting 'resource busy' from umount (sudo umount /dev/disk1s1, that's my external drive name). Umount on the volume says not mounted. Checked activity monitor and couldn't see any time machine processes running, only fsevents, which has to stay running.

    I threw the following:

    sudo umount -vf /dev/disk1s1

    and the drive umounted. -v is verbose, just in case there were any errors thrown I wanted to know, and -f is force umount, which forces the drive to unmount. Check 'man umount' from terminal to see more info on these.

    After doing this a couple times (I was doing some testing with some other things to find a faster solution than having to open terminal and umount) it just started umounting correctly. I have no idea why, but it did. So just keep that command in mind, just in case.

    Gryyphyn, out.
    MacBook 13", Mac OS X (10.5.1), USB HDD
  • mattathayde Level 3 Level 3 (565 points)
    ooooo just remembered something that happened to me

    i tried to eject my 2 drives that are daisy chained and i was able to eject one but not the one closer in the line to the machine... at least according to my desktop, my device listing in a finder window didnt have it shown. and for some reason that was keeping it from unmounting. so i drug it into the device list and then ejected it again from there and it unmounted.

    dont know if that really helps you at all or not
    -matt
    MacBook Pro 2.33 Ghz, Mac OS X (10.5.1), Breaking macs since OS 6.0.5 | 20 gb 4th Gen iPod | 8 gb iPhone
  • Peggy Lynn Level 4 Level 4 (2,470 points)
    Welcome to Discussions.

    +I'm having the same issue. Time machine isn't actively running, though just to be sure I turned the service off through the TM utility: no go. Still can't eject.+

    Check in Activity Monitor to see if Spotlight is running. The Spotlight processes start with "md".
    Mac Mini, 1.42 GHz, 1 GB RAM, 80GB HD, SuperDrive, Mac OS X (10.5.1), Maxtor One Touch 160GB, HP LaserJet 1320n, Epson R800

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.