4 Replies Latest reply: Jan 4, 2008 9:18 AM by wonkknows
wonkknows Level 1 Level 1 (0 points)
I was trying to print in grayscale from my MP530 canon printer when to my surprise I am not able to choose grayscale.

I have a fresh install of Leopard - only three days old.

My MP530 works find from windows XP -- go figure.

For Leopard I have attempted to reinstall the drivers again and again. In System Preferences, when I add the printer and am to select a driver (it automatically chooses the Canon IJ Printer), there are only two others (Canon Pro9000, Canon Pro9500 series) for canon. Yes -- I've tried the latest drivers -- within the last three days from Canon's website.

Yes, I know about the little blue triangle but it does not allow you to change the color to grayscale.

After the Canon IJ Printer driver is chosen, when you select the "options and supplies" button, then the "driver" tab, the Canon MP530 bar is grayed out and in the dialog box below says:

"To take full advantage of your printer's options, confirm that they are accurately shown here. For more information on your printer and its optional hardware, check the printer's documentation."

Er.. so that isn't helpful is it? There are no printer options listed below this message.

Again, I have downloaded new drivers from the Canon site. What more can I do?

Help?

mac pro, Mac OS X (10.5.1), fresh install of Leopard
  • PAHU Level 6 Level 6 (15,750 points)
    I don't have the MP530, but with an MP600R connected to 10.5.1 and using the v5.8.3 driver that is included with Leopard, I can open Quality & Media and under Print Mode I can select Grayscale.

    You mention Windows is okay. Are you sharing this printer from your Windows PC to the Mac?
  • wonkknows Level 1 Level 1 (0 points)
    I physically unpluged the printer and tried it on XP -- I am not sharing the printer. The printer is directly plugged into my mac pro. There are no options showing for the printer as outlined in my first post. Since this was a fresh scrub-and-install of Leopard I have tried both the drivers which came with Leopard and the ones downloaded from Canon -- something is amiss...
  • PAHU Level 6 Level 6 (15,750 points)
    Your first post says that you look in 'Options and Supplies' and this is grayed out. This is what you should see. There are no options to set in the driver.

    The setting of grayscale appears under the Quality and Media tab. When you are in an application, such as Preview, if you click on the menu showing Preview, do you see Quality and Media? If you do, this is where you enable grayscale.

    If you don't see Quality and Media, then there has been a problem with the driver installation. Probably caused by adding the Canon drivers you downloaded, as Leopard has the MP530 driver as part of the installation, providing you didn't do a custom installation and deselected the printer drivers. I would then recommend using the following procedure to remove then reinstall the MP530.

    1. Open Print & Fax, select the MP530 and remove it (click the -). Then hold Control and click on the Printer list and select Reset Printing System.
    2. Close the Print & Fax..
    3. Go to Library > Printers > Canon and delete the contents of the BJPrinters folder.
    4. Go to Library > Receipts and delete the file Canon MP530 xxx.pkg
    5. Empty the Trash
    6. Unplug the MP30 USB cable and restart the Mac
    7. Run the installer for the MP530 v4.8.3 driver you downloaded from Canon.
    8. Once the driver installation is complete, go to Applications > Utilities and open Disk Utility. Run the Repair Disk Permissions option.
    9. Reconnect the MP530 USB cable. The printer should be automatically added. Open Print & Fax to check the printer is listed. If not, add it.

    Now open an application like Preview and see if you have the Quality and Media tab.
  • wonkknows Level 1 Level 1 (0 points)
    Hi Pahu - Thanks for your list of steps to try to fix.

    I have been unable to find the 'Quality and Media' tab you mentioned.

    Yes -- my install was partly custom as I removed all other printers except for Canon and also removed quite a few language options as I installed.

    I tried the sequence you laid out twice and still no luck on seeing the settings tab you mentioned.

    One quirk I had was when I moved the items indicated to the trash it would not let me empty the trash because it said they were in use.

    Another quirk was the driver install wants to restart to complete -- I tried doing the disk permissions repair after the restart on the first try and before the restart on the second try.

    It never would automatically pick up the printer -- I would have to go and add it. It would show the following in a list to choose from:

    MP530 USB
    MP530 FAX USB

    The first one would have a driver pre-selected which was not shown in the list if you tried to choose another driver. The second one had no drivers able to be selected for it.


    Still no luck -- I cannot get the menu item for setting gray scale and such to appear You would think by now developers (I am a software developer) would have the "how to get a printer to interact with an OS" down pat.