12 Replies Latest reply: Mar 28, 2008 9:54 PM by William Pokorny
hecktorjade Level 2 (245 points)
I have a non-booting MacBook Pro that will POST (Apple chime) and boot to a grey screen.
I consider myself a pretty advanced troubleshooter but this one stumps me. Here is a summary of most of what I have tried so far, not necessarily in this order:


Reset PMU

Attempted to boot to DVD Command + C

Attempted to boot to Target-mode Command + T

Attempted to selected startup disc manually Command + Option

Attempted to boot to SUM Command + S

Attempted to re-image firmware using CD

Attempted to boot diagnostic CD Command + D

NONE of these work. I have fixed many Macs in my day and have not encountered an issue like this!

MacBook Pro, PowerMac G4, Macmini, iBook G3, Mac OS X (10.5.1)
  • Soft Reset Level 4 (1,790 points)
    Do you have an external firewire drive that you can boot to? Have you enabled an open firmware password? Your inability to perform all of those operations line up directly with things you can't do with an open firmware password set.

    I vote for trying to boot to an external drive and see if that solves the issue. If it's passing POST then the next logical troubleshooting step is to take the HD out of the equation.
  • hecktorjade Level 2 (245 points)
    -No OF password set

    I do have an external FW drive. However since the unit will not boot to the DVD (I tried 2 different discs) I am doubtful that will make a difference. However I am going to give that a shot since I have not done that yet.
  • raimee1 Level 1 (0 points)
    I am having the same issue as you. I have also tries all of the same methods to resolve as you and can not get my Mac to boot. I am going to keep trying and if i resolve the issue i will post back letting you know what i done to fix the issue. If you get the issue fixed could you post what you did to fix it?
  • raimee1 Level 1 (0 points)
    i got mine to finally boot from the dvd!!!! instead of holding the command + c just hold down c as it is starting up. it worked for me!!!
  • mcna Level 1 (0 points)
    I am having the same problem. It powers up to a plain grey screen. It won't boot from disk "C" or "D", nor will it connect to another computer through a firewire connection. It does give me the firewire symbol when I press "T" but the other computer does not recognize it.'

    Do you find a solution yet?
  • yetanotherpunter Level 1 (0 points)
    I am having this issue too, i really need my computer so any help would be very much appreciated
  • S.U. Level 6 (8,360 points)
    Do you also get fan noise and clicking in the upper left corner? Someone else had this problem, and none of the suggestions in KB article # 300357 worked. The other person also could not get the Mac to boot from a disc.

    No solution so far, but it looks like you're not the only one with this problem.
  • yetanotherpunter Level 1 (0 points)
    Hi there, thanks for the quick reply. i do get fan noise and quiet clicking. It will also spin up the DVD but not read it (or if it does it does nothing about it!)

    Getting in touch with applecare!

    Do you think it is a logic board issue or a hard drive issue?
  • S.U. Level 6 (8,360 points)
    I've been through both a logic board failure and a hard drive failure on my iBook, and neither had these symptoms. Since the article I referred to had to do with having no video, my guess would be that it is the logic board but I don't really know. It doesn't really sound like hard drive failure to me, or at least it's nothing like the way mine failed.

    Since the article wants you to reset the PMU in an older Mac, and I suppose the SMC in a newer Mac, I wonder if actually it is the SMC which has gone bad. The SMC is an integrated circuit after all, and if it were to go bad and not be able to be reset, then that might explain what's going on here.

    But I'm just speculating. It will be interesting to see what Apple has to say. Please let us know.

    Good luck!
  • yetanotherpunter Level 1 (0 points)
    Hi there, got in touch with apple care, it was a hard drive failure. I have a new one with new install of leopard and its nice and dandy.

    Except... the whole thing died as i was trying to use time machine, this is probably wandering onto a different post now but incase anyone has any ideas i will post it here. Now when mount the sparsebundle from the time machine drive and show the package contents of the .inproggress file within i can see some of my files (files i want back) when i try and copy them to the desktop it sounds like it has copied but it is not there. That said the mp3s copy into itunes fine!?! any thoughts?
  • yetanotherpunter Level 1 (0 points)
    Ok, so here is the answer! you can move them using the terminal command "cp" (and for directories (and hence apps) "cp -R") for some reason "ditto" throws up errors.

    Hope that helps anyone else in a similar situation!

  • William Pokorny Level 1 (45 points)
    I have these same symptoms, too. I can get mine to boot every now and again, but it's becomign more rare. Thus, I have it sleeping and never shutting down until I get it fixed.

    I went to the Apple Store in Tampa, tonight and the guy at the Genius Bar said it's a Logic Board problem. I can't send it off yet, because I have a stupid test next week.

    But anyway...it sounds like you have a logic board problem. Get it to an Apple Store or Apple service provider ASAP and back up your HD if you can!