9 Replies Latest reply: Jan 17, 2008 2:28 PM by bgalvanized
Diane Thomas Level 1 Level 1 (0 points)
I have 2 hard drives installed in my Intel MacPro. One is a 250Gb drive that is just for my software and the other one is a 500Gb drive which I use for all my documents. *It's the 500Gb drive that I have a problem with. It used to be in the sidebar of Finder, but somehow during the installation of my wireless network it disappeared!*

The only way I can find it is by searching for it in Finder. It opens when I double click on it. However, it will not mount to the sidebar! I was successful in dropping the icon to the dock.

*This is a 'big problem' because I cannot access the drive at all from my new Mac BookPro* which was set-up today. The search function doesn't even work.

All help is greatly appreciated.

Oh, I need to add that I am still a newbie with my Mac. I am a graphic designer and worked on PCs up until April 2007. Do I love my Mac? You betcha!

Intel Mac Pro, Mac OS X (10.4.11), 2 Hard drives (1 @ 250 Gb, 1 @ 500 Gb)
  • 1. Re: Hard Disc #2 icon not showing on desktop
    The hatter Level 9 Level 9 (58,880 points)
    Finder Preferences control whether disk drives show on desktop or sidebar.
  • 2. Re: Hard Disc #2 icon not showing on desktop
    Diane Thomas Level 1 Level 1 (0 points)
    Thank you Hatter for your response.

    I have Hard disks checked in the Finder General and everything is checked in Finder Sidebar.

    My 2nd hard drive still does not show up on either the desktop or sidebar. So, apparently something else has gone astray.

    Any suggestions?
  • 3. Re: Hard Disc #2 icon not showing on desktop
    AppleNewton Level 2 Level 2 (185 points)
    if you open Disk Utility does it show up there? maybe you need to verify the disk or insert the OS X install discs and run a hardware test and a disk utility verify disk option.

    very strang, my .02 for now.
  • 4. Re: Hard Disc #2 icon not showing on desktop
    Diane Thomas Level 1 Level 1 (0 points)
    Yes, it shows up in Disk Utility and it passes the verification process. But it STILL doesn't show on the sidebar or desktop.

    I do have an icon for it on the dock and can access it that way. However, I need to access the disk on my laptop via my network too because all my data is on this hard drive!

    Thank you for your help.

    Diane
  • 5. Re: Hard Disc #2 icon not showing on desktop
    nebor Level 1 Level 1 (0 points)
    same problem, but with startup volume. computer starts up, everything work fine, volume accessible from terminal, it is possible to access it via "go/go to folder/" then entering "/volumes" path. file system is ok, disk visible in disk utility, it is possible to mount and dismount it when starting from another device (hdd or dvd), but it doesn't appear on desktop or sidebar.

    so i check finder preferences (general and sidebar), then delete .ds_store on it, then all possible .* files, then "desktop db" and "desktop df" but nothing. looks like the only solution is archive and re-format.
  • 6. Re: Hard Disc #2 icon not showing on desktop
    The hatter Level 9 Level 9 (58,880 points)
    When the volume shows in /Volumes, it often means there is a "-1" there also from when the volume failed to mount.
  • 7. Re: Hard Disc #2 icon not showing on desktop
    Diane Thomas Level 1 Level 1 (0 points)
    *Thank you to everyone who responded to my request. You are all wonderful and I appreciate everyone's help.*

    I called Apple Care and with the help of a very understanding Product Specialist we solved the problem. *The hard drive in question contained all my data, so I backed it up and we erased and 'renamed' it.* I named it the same as it was originally and when we restarted 'there it was' on my desktop and in the sidebar.

    It was critical that I be able to rename the drive the same so that all my graphic files and images would 'link' properly.

    I still don't understand 'why' this happened, but am grateful that it is fixed and no data was lost!

    Again, thank you to all for your help.
  • 8. Re: Hard Disc #2 icon not showing on desktop
    The Buffster Level 2 Level 2 (170 points)
    I had this problem and after much investigation I booted from a different drive and rebuilt the directory with Disk Warrior and that solved my problem.

    Too late now but it saves a lot of grief!





    B
  • 9. Re: Hard Disc #2 icon not showing on desktop
    bgalvanized Level 1 Level 1 (0 points)
    The same issue has happened to my main drive. Am I going to have to wipe the drive and start from new again? Oh man that *****.