Previous 1 2 Next 20 Replies Latest reply: Feb 21, 2008 8:35 AM by Tom Wolsky
Phillip Litchfield Level 1 (0 points)
I have a Canon GL2. I am using Final Cut Express 2.0.3
Until recently, I was able to Capture into FCE and using iMovie 4.0.1 was able to import from the camera. I have been reading through most of the threads that seem to be the same problem as mine and can't seem to get FCE or iMovie to communicate with the Canon GL2 using any of the tips that were given, such as throwing out the preferences, zapping the P-Ram, turning the camera off and on, checking the connections etc.
I can't figure out what I did to break my connection with the camera (I am thinking a software update may have done something?)

Please help, any ideas are appreciated.

Thanks!

iMac G4 PowerPC, Mac OS X (10.4.11)
  • Ian R. Brown Level 6 (18,615 points)
    1. Easy Setup should be "DV-PAL (or NTSC) FireWire Basic" for Canons.

    2. Have you got a FireWire Hard Drive (especially LaCie) attached ?

    3. One of the latest versions of QuickTime can cause capture problems.
  • Ian R. Brown Level 6 (18,615 points)
    I believe it was QT 7.3 that caused the problems.
  • Phillip Litchfield Level 1 (0 points)
    1. Easy Setup should be "DV-PAL (or NTSC) FireWire Basic" for Canons...I believe my set up is good, I am on NTSC

    2. Have you got a FireWire Hard Drive (especially LaCie) attached ? Yes, I do have the LaCie FireWire HD attached...Is that a good or bad thing?

    3. One of the latest versions of QuickTime can cause capture problems. Yes, I do have QT 7.3! and I think that was one of my latest updates too...What is the solution?
  • Ian R. Brown Level 6 (18,615 points)
    1. Physically double-check that your Easy Setup is correct.

    2. To rule out clashes with the LaCie, disconnect it and set the internal HD as your scratch disk. Then see if it will or will not capture.

    3. If the fault is not caused by the first 2, you must get rid of QT 7.3. You will have to search the forum to find what others have done. (Just put in "QuickTime 7.3" and wade through the results that come up.)
  • Phillip Litchfield Level 1 (0 points)
    Okay, I Googled the "QT 7.3 not capturing" and found the answer on the apple Quick Time forum. It's QT 7.3 that's the problem not meshing with FCE 2. +THANKS A BUNCH APPLE FOR THE PROBLEMS!+

    Thanks for your help Ian!

    I'm still not sure about the LaCie external HD though...let me know what I should be doing there?
  • Ian R. Brown Level 6 (18,615 points)
    The problem lies with Canon who have never implemented the FireWire protocol properly - unlike all other manufacturers.

    If all the FW sockets are on the same bus this can cause problems. Some people find that daisy-chaining helps, others the opposite !

    Some find the only way they can capture is to use the computer's HD and then copy across to the FW one.

    However, if you have used the LaCie OK in the past it will probably not be that.
  • Phillip Litchfield Level 1 (0 points)
    I ejected and unplugged the LaCie external HD and....it worked, QT 7.3 and all! Thanks again Ian!

    Since you use LaCie HDs, know anything about the Porche USB HD? Mine is seen by the computer but the icon doesn't appear? Any suggestions?
  • Ian R. Brown Level 6 (18,615 points)
    Sorry I can't help with the icon problem.

    USB 2.0 HDs can be used with FCE but they are not recommended. FW is much better.

    However, if you have a clash between your Canon and the FW HD it might be worth trying the USB 2.0.
  • Steve Garfield Level 1 (5 points)
    I am not too happy about not being able to capture with my Canon GL2.

    I sent the GL2 back to Canon and got a new Firewire interface, got a brand new MacBook Pro.

    I'm running QuickTime 7.3.1 and have a chain of La Cie Firewire drives connected to the MacBook Pro.

    I purchased a Belkin FireWire Express Card to relieve the system of having to capture video.

    Now when I connect to Log and Capture in FCP, I have a connection at first, then the connection is lost.

    I got around it by capturing with iMovie.

    So the open issues are:

    1. Canon never implemented Firewire correctly?

    2. The new QuickTime broke FCP log and capture with Canon GL2?

    Can someone reply who is addressing each of these issues? Thanks.

    PS. I have found that placing the GL2 cable as the last cable on the LaCie chain, if connected to the MacBook Pro with FW 40, Not 800, sometimes works.
  • Joeboyboy5 Level 1 (0 points)
    Nothing I've read had worked for me but I have found something that does. I have no idea why this works but I have found that when I connect my sub cable to my mac, it recognizes my camcorder. I the can unplug my sub and then plug in my firewire and I am on my way.
  • Tom Wolsky Level 10 (115,500 points)
    What's a sub cable? What computer is this?
  • Sam Valenti Level 1 (35 points)
    I read this posting and having similar issues. I am using QT PRO 7.4.1. I am using a Canon GL2 to capture. I have tried DV-NTSC basic firewire and DV-ntsc converter. Both of them capture the data up to a point then FCE 2 locks up and I have to completely shutdown and reboot. Force Quit does not work on FCE. The captured material is in the capture scratch folder that I assigned. I have another external firewire drive if that would work. I thought using an internal drive would be better.

    Sam
  • Tom Wolsky Level 10 (115,500 points)
    QuickTime versions later than 7.3 do not work correctly with FCE versions prior to 3.5.1.
  • Sam Valenti Level 1 (35 points)
    Tom,
    Although I purchased fce 2 and your book long ago I have been studying your book to begin using FCE 2. Very informative. Should I upgrade to fce 4 or go back to old QT Pro? Or other alternative?
Previous 1 2 Next