10 Replies Latest reply: Jan 9, 2008 6:47 PM by JMT3096
JMT3096 Level 1 (0 points)
I attempted to install Leopard and it encountered an error with my hard drive before installation could begin. It directed me to restart the computer. I did and now it only reaches the Apple Logo and then restarts over and over again. Trying to run Disk Utility to check my hard drive but I cannot boot off of the install disk or get the Leopard install disk out of the drive.

iMac, Mac OS X (10.4.11), 2.0GHz Intel Core Duo
  • myhighway Level 5 (7,270 points)
    Leave disc in optical drive and power down using button. When starting up perform a PRAM reset, then upon hearing the startup chime (chord, gong, or whatever you want to call it) for the second time, quickly release the keys and press the "C" key until under the Apple logo you see the spinning grey progress indicator, after which release that key. Your Mac should then be in the process of booting to the Leopard install disc.

    PRAM reset:
    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.
  • JMT3096 Level 1 (0 points)
    I tried zapping the PRAM previously, but to no avail. The computer has a wireless keyboard and mouse so I am using the wired keyboard - one of the new aluminum keyboards - from my other iMac but no luck. I read another thread which suggested that these keyboards aren't recognized until later in the startup process. Any validity to that statement?
  • JMT3096 Level 1 (0 points)
    The spinning grey progress indicator spins five times before the computer shuts down. It doesn't reset the PRAM.
  • myhighway Level 5 (7,270 points)
    I read another thread which suggested that these keyboards aren't recognized until later in the startup process.


    No, that can not possibly be true, as all Intel-based Macs have the same startup process. Refer to this Apple Support article:
    http://docs.info.apple.com/article.html?artnum=303363

    Have you tried starting up in safe mode?

    Refer to these Apple Support articles:
    http://docs.info.apple.com/article.html?artnum=107392
    http://docs.info.apple.com/article.html?artnum=107393
    http://docs.info.apple.com/article.html?artnum=107394

    OK, now I just realized you're probably referring to a 20-inch early 2006 model white iMac, not to an aluminum iMac. Have the required Firmware Updates been installed to that iMac?

    Refer to this Apple Support article:
    http://docs.info.apple.com/article.html?artnum=303880

    There were two that had to have been installed. However, if you can't successfully boot, I don't know how you'd verify. You'd just have to know the answer. If not installed, there is nothing else you can do except take it in for service. Best of luck.
  • den.thed Level 7 (26,002 points)
    JMT3096

    If you had not actually started the 10.5 install, with the wired keyboard see if it will start-up holding the "Option" key. I'm hoping that the Start-up Manager will allow you to select the 10.5 disk or HD where hopefully 10.4.11 has not been erased....?

    Dennis
  • JMT3096 Level 1 (0 points)
    All firmware updates were current on the computer. I guess the computer needs to go in for service.
  • JMT3096 Level 1 (0 points)
    The install had not started but the computer will not respond to any keys being held down while restarting.
  • den.thed Level 7 (26,002 points)
    Reset the System Management Controller.

    http://docs.info.apple.com/article.html?artnum=303446-en

    +Note: step #4 Plug the power cord back in, making sure the power button is not being pressed at the time. Then reconnect your keyboard and mouse to the computer.+ "Using the wired keyboard"

    Maybe I'm way out there, but I'm hoping that the SMC reset will get the wired keyboard to respond!
  • JMT3096 Level 1 (0 points)
    I attempted that and the computer is still shutting down without taking any input from the keyboard.
  • JMT3096 Level 1 (0 points)
    I can verify that there is a problem with attempting to use the aluminum keyboard to tell the computer to boot off of the CD. I took the computer to the Genius Bar and it was hooked up to an older keyboard. The "C" key command was recognized, the install DVD was ejected, and now I am in the process of data recovery before erasing the hard drive.