3 Replies Latest reply: Jan 9, 2008 1:29 PM by rowergurl
rowergurl Level 1 Level 1 (0 points)
I have a PowerPC G5 and made a bootable backup of the computer's content to an external firewire hard drive. I tested the backup to make sure that it booted and everything was fine. So, I then did a clean install of Leopard to the machine. After the computer restarted, I reconnected my external drive and it mounted fine. However, when I went to use Migration Assistant to bring over all of my applications, it would not recognize the hard drive as an option to migrate files from.

The hard drive is formatted as Apple Partition Map, and works fine as a bootable copy. Does anyone know why Migration Assistant will not recognize it?

I recently did a clean install of Leopard on my Macbook this weekend using a different external drive with a bootable backup of the drive (GUID formatted) and then used the migration assistant to move all of my files and everything worked just fine.

I can't find any reason that I shouldn't be able to get my applications through migration assistant from the external hard drive but maybe someone knows how to fix this or of a workaround.

Dual 2 GHz PowerPC G5, Mac OS X (10.5.1)
  • nerowolfe Level 6 Level 6 (13,070 points)
    Very curious, indeed.
    Welcome to the Apple forums where we do try to sort things out
    Your delineation of the problem and comparison to your MBP is perfect.
    I migrated my G5 from a second internal disk, but actually used the setup assistant when Leopard came alive.
    You might see what happens if you eject your external HD and then do what you need to to connect it back (turn off/on - unplug/plug, etc.)
    Are there any errors when Migration assistant runs?
    It is perhaps that Spotlight is doing its thing and the drive is not available until it is indexed?
    I would remove the external HD temporarily from the SpotLight indexing list and then see what happens.
    I recall that there were some odd issues with external drives taking up to 1/2 hour to be recognized by Leopard, but I don't recall why.
    I am not sure these things will help, but they will eliminate some of the possibilities, and when we have eliminated the probable, what is left is where the answer lies

    I wonder if Leopard is confused by the external drive not being GUID?
    Try this - - connect the GUID external drive to your G5 and see if Migration assistant sees it. Obviously do not migrate anything, but if you can see that one, we may have a solution.
    Keep us posted.
  • rowergurl Level 1 Level 1 (0 points)
    Thanks for the response.

    When I had submitted the post yesterday, I had already tried ejecting and rebooting the hard drive and that didn't do anything to help. Also, I had already waited for the entire drive to be indexed because I too thought that might have been a problem but it still wasn't working in migration assistant.

    Now, as you said, we eliminated those potential problems and that left the possibility that the difference between the Apple Partitioned Map and GUID partitioned external hard drives was causing the problem. Well, when I got back to work today, I brought along the hard drive (GUID formatted) that I had used to back up my Macbook that had a bootable copy of the macbook's hd, luckily I had not reformatted it for time machine use yet. I plugged in the GUID formatted hard drive and success!

    It seems that migration assistant on the PowerPC will recognize a hard drive formatted GUID, even though this would not be a bootable drive on a PowerPC but seems unable to recognized an external hard drive formatted as Apple Partition Map.

    I'm going to reformat my external for the G5 and format the drive to GUID and put the data back. I'll let you know if this process works in the end because I suspect others might have this problem in the future.
  • rowergurl Level 1 Level 1 (0 points)
    So, even after transferring the contents to the GUID formatted hard drive, migration assistant still would not recognize that disk. So, I've scrapped the idea of using the migration assistant and now I am resorting to digging up my old serial codes and software codes.

    If anyone knows how to solve this or has insight as to why this process would not be working, I'll take any advice. I still need to do a transfer on a different G5 after I complete the install on the current one.