Previous 1 2 3 Next 42 Replies Latest reply: Oct 3, 2008 11:59 PM by Rup49
Boul Level 1 (0 points)
Adding printers seems as easy as before. But, apparently, there is some permissions issues.

We have several shared printers on a Windows Network.
I can add all of them without any problems, but any print job is blocked.
After having a look on discussion forum and after analysing the error log, as far as I understand the problem, it seems that no authentication is sent with queued jobs to printers.

When adding a network printer, network id and password are required, but when printing, the job is blocked and error log states :
I 10/Jan/2008:10:23:45 +0100 Job 180 Authenticated by "".
E 10/Jan/2008:10:23:46 +0100 Job 180 Session setup failed: NTSTATUS_LOGONFAILURE

So, apparently, the printer is considered as purely public resulting in a athentication error.

I tried to add printers directly through CUPS interface http://localhost:631, but it leads to the same problem.

Has anyone a workaround to propose?


MacBook Pro, Mac OS X (10.5.1)
  • dpzeh Level 1 (0 points)
    I think I have the exact same problem. I've tried to go to http://localhost:631 and add the printer with smb://<username>:<password>@<ip>/<sharename>
    It connects just fine and adds the printer to my list.
    Each time I try to send a job, CUPS gives me the following errors:

    I [14/Jan/2008:15:10:28 +0100] [Job 13] Adding start banner page "none".
    I [14/Jan/2008:15:10:28 +0100] [Job 13] Adding job file of type application/postscript.
    I [14/Jan/2008:15:10:28 +0100] [Job 13] Adding end banner page "none".
    I [14/Jan/2008:15:10:28 +0100] [Job 13] Queued on "officejet" by "preben".
    I [14/Jan/2008:15:10:28 +0100] [Job 13] Started filter /usr/libexec/cups/filter/pstoappleps (PID 1473)
    I [14/Jan/2008:15:10:28 +0100] [Job 13] Started filter /usr/libexec/cups/filter/pstocupsraster (PID 1474)
    I [14/Jan/2008:15:10:28 +0100] [Job 13] Started filter /usr/libexec/cups/filter/rastertogutenprint.5.1 (PID 1475)
    I [14/Jan/2008:15:10:28 +0100] [Job 13] Started backend /usr/libexec/cups/backend/smb (PID 1476)
    E [14/Jan/2008:15:10:28 +0100] [Job 13] Session setup failed: NTSTATUS_LOGONFAILURE
    E [14/Jan/2008:15:10:28 +0100] [Job 13] Session setup failed: NTSTATUS_NO_SUCHFILE
    E [14/Jan/2008:15:10:29 +0100] [Job 13] Session setup failed: NTSTATUS_LOGONFAILURE
    E [14/Jan/2008:15:10:29 +0100] [Job 13] Tree connect failed (NTSTATUS_ACCESSDENIED)
    E [14/Jan/2008:15:10:29 +0100] PID 1476 (/usr/libexec/cups/backend/smb) stopped with status 2!

    I am running with CUPS version 1.3.3

    I hope somebody has a solution to this, because printing has really been pain since we upgraded to Leopard

  • Boul Level 1 (0 points)
    I reply myself to my question since I solved the issue.
    Maybe it can help others.
    In fact, when adding Windows Network Printers via preference panel, the registered IP address was not complete.
    The address must be of the form smb://username:password@IP/printerID
    or : smb://username:password@Workgroup/ServerName/PrinterID

    When browsing windows printer via the preference panel, the registered address does not contain the Windows Workgroup! This issue is still present in 10.5.2

    I changed the address through the CUPS Web interface (http://localhost:631) and add simply the workgroup name to the address. Now it works fine.
    Should be possible to performed this directly through the fax/Printer preference pane using the "advanced" button (must be added customizing the toolbar)

    Hope this will help....
  • Pintom1 Level 1 (65 points)
    Note to all after the latest security update I've had SMBA authorization problems at my work network. The hint here solved my issue!
  • Guinness' Level 1 (5 points)
    Greetings to everyone,

    I have an intel MBP17 running 10.5.2 (cups 1.3.6) and installed the last 2008-002 security update.
    Printing is not working anymore on smb windows printers

    Had airfoil so did an update of Audi Hijack and uninstall (thread 6862104)

    Now I get jobs: (on hold) authentication required so tried the above solution but all without success.
    This is the cups log:
    I [20/Mar/2008:14:51:02 +0100] [Job 152] Authenticated by "".
    E [20/Mar/2008:14:51:03 +0100] [Job 152] Session setup failed: NTSTATUS_NO_SUCHFILE
    E [20/Mar/2008:14:51:03 +0100] [Job 152] Session setup failed: NTSTATUS_LOGONFAILURE
    E [20/Mar/2008:14:51:03 +0100] [Job 152] Tree connect failed (NTSTATUS_ACCESSDENIED)

    if anyone has a solution or an insight of what this security update is doing with samba ...

  • todd5163 Level 1 (0 points)
    Boul how do you customize the fax/Printer preference pane to include the advanced button as mentioned?
  • fotofilosofia Level 1 (0 points)
    Very useful!
  • abordercollie2 Level 1 (10 points)
    Thank you! My problem was solved when I used your information. Specifically:
    1. http://localhost:631
    2. smb://username:password@IP/printerID
  • tinomen Level 1 (0 points)
    This is a great work around, but hardly a fix. A fix would allow the printing services to use the keychain to store the username and password instead of clear text config files.
  • tinomen Level 1 (0 points)
    1. sys prefs
    2. print & fax
    3. click add button
    4. right (ctrl) click toolbar and choose Customize
    5. add Advanced icon to toolbar
    6. recommend removing *more printers*
  • John Blanchard1 Level 5 (5,230 points)
    Guinness', could you provide some information on your network and Windows configurations, please?

    For the network configuration:

    1. Do you have a local (i.e. your own) DNS server?
    2. Are the Mac and Windows systems on the same subnet?

    For the Windows system configuration:

    1. What version of Windows are you using?
    2. Is the server setup to use "Simple File Sharing" (Control Panel->Folder Options->View)?
    3. What security settings (if any) are set on the shared printer?
    4. What kind of authentication (if any) is used with the Windows system?

    Sorry for the questions, but this will help in tracking down what's going on with the authentication issues. Thank you.
  • Justin Mack Level 1 (35 points)
    That worked perfectly! I don't know what was changed in the latest update, but this workaround works.
  • Hugo Mallinson Level 1 (0 points)
    Saving the authentication in the keychain has definitely worked for me under Leopard. I'm now having this same problem though, but I don't know if it's the 10.5.2 upgrade or the security fix (I don't print to our windows printer very often). Either way someone's screwed up. Any chance of an official word from Apple?
  • Midnightbrewer Level 1 (0 points)
    Another solution depends on the type of printer you're using. We have an Epson here at work, and I was able to connect to it using Epson's proprietary "epsontcpip" protocol. I added it through CUPS, but you can also do it through the Add Printer dialog's Advanced tab (adding the "Advanced" button using the method described previously).

    I personally don't like sending my passwords as plaintext strings and recommend strongly against it.
  • Jedinyt Level 1 (0 points)
Previous 1 2 3 Next