1 2 3 Previous Next 42 Replies Latest reply: Oct 3, 2008 11:59 PM by Rup49 Go to original post
  • 15. Re: NT_STATUS_LOGON_FAILURE
    Michael Lee4 Level 1 Level 1 (25 points)
    Boul,
    Thank you so very much. I have been struggling with this for days! I have an HP Laserjet 1320 that I could not get to print on my window network. I used your smb://username:password@Workgroup/ServerName/PrinterID and it works great. My "IT" department had no clue and does not support my Mac at all, especially if it has anything to do with the network! This really something Apple needs to address if they want to be part of the corporate world. Great solution, thanks again!
  • 16. Re: NT_STATUS_LOGON_FAILURE
    logicalgambit Level 1 Level 1 (0 points)
    Does anyone know if a secure solution is going to be suggested?

    This is my error log file:
    I [25/Mar/2008:16:10:58 -0700] [Job 6] Started filter /usr/libexec/cups/filter/pstoappleps (PID 594)
    I [25/Mar/2008:16:10:58 -0700] [Job 6] Started filter /usr/libexec/cups/filter/pstocupsraster (PID 595)
    I [25/Mar/2008:16:10:58 -0700] [Job 6] Started filter /usr/libexec/cups/filter/rastertogutenprint.5.1 (PID 596)
    I [25/Mar/2008:16:10:58 -0700] [Job 6] Started backend /usr/libexec/cups/backend/smb (PID 597)
    I [25/Mar/2008:16:10:58 -0700] [Job 6] Authenticated by "".
    E [25/Mar/2008:16:10:58 -0700] [Job 6] Session setup failed: NTSTATUS_NO_SUCHFILE
    E [25/Mar/2008:16:10:58 -0700] [Job 6] Session setup failed: NTSTATUS_LOGONFAILURE
    E [25/Mar/2008:16:10:58 -0700] [Job 6] Tree connect failed (NTSTATUS_ACCESSDENIED)
    I [25/Mar/2008:16:10:58 -0700] Saving printers.conf...
    E [25/Mar/2008:16:10:58 -0700] PID 597 (/usr/libexec/cups/backend/smb) stopped with status 2!
    I [25/Mar/2008:16:10:58 -0700] Hint: Try setting the LogLevel to "debug" to find out more.
    I [25/Mar/2008:16:11:01 -0700] [Job 6] Backend returned status 2 (authentication required)
  • 17. Re: NT_STATUS_LOGON_FAILURE
    Norah Esty Level 1 Level 1 (0 points)
    I appreciate this info but I am having some problems making it work.

    I went to the localhost:631 page, and I see the printer and the error, but I don't see how I can change the address. In "modify printer" it only gives me access to the description of the printer, but not the name. (I have a Mac in my office, but my department runs on Windows, and this is the shared printer down the hall). Could you explain how you change the name?

    Also, what is the "workgroup"? I am not sure what that means or how to find out what it is. My printer (currently) has a name like CYCLONUSD225_Faculty_HPLJ4200, if that helps.

    I do appreciate the help.
  • 18. Re: NT_STATUS_LOGON_FAILURE
    Guinness' Level 1 Level 1 (5 points)
    Hi John

    Thanks for your time with this.

    I'm on an office network with automatic IP settings (with DNS and WINS but no Proxy) so same subnet for everyone.
    Printers are shared on XP Pro SP2 servers.
    There are no particular authentication settings on the printers and windows auth is using MS Server domain but i won't be able to get more intel than that ...

    I'll try playing with cups again and see what gives.

    Thanks
  • 19. Re: NT_STATUS_LOGON_FAILURE
    Guinness' Level 1 Level 1 (5 points)
    No fix yet but managed to get it to work with cups.

    Silly thing: it will never work if modifying an existing printer with cups
    Must delete and re-create ...
    in both cases the username:password info dissapears from display.
  • 20. Re: NT_STATUS_LOGON_FAILURE
    John Blanchard1 Level 5 Level 5 (4,750 points)
    Guinness', Thank you for posting back and thanks for posting all of your network information. Unfortunately, I have not made any headway with this, and it looks like Apple will have to release an update to address these issues. I an hopeful that it will be later this week. I'm sure they are working on it, given the number of threads on this. I did submit your network information to Apple via their feedback mechanism, so let's hope someone there is looking at it. Sorry for not being able to help.
  • 21. Re: NT_STATUS_LOGON_FAILURE
    nick.j.s Level 1 Level 1 (0 points)
    This worked for me. Thank you so much...
  • 22. Re: NT_STATUS_LOGON_FAILURE
    Michael Roedig Level 1 Level 1 (0 points)
    I had the same problem and deleted the printers in question. I re-added the printers using the cups utility: http://localhost:631 using the URI: smb://username:password@domain/server/Printershare.
    It works.
    When the URI is displayed in the cups utility or from Preferences->Print and FAX the password is not visible.
  • 23. Re: NT_STATUS_LOGON_FAILURE
    jweaks Level 1 Level 1 (0 points)
    Thank you, thank you, thank you!!!!
    The update had broken my printer access, too.
    Adding the name:passowrd@workgroup into the path fixed them for me.
  • 24. Re: NT_STATUS_LOGON_FAILURE
    John Wagner Level 2 Level 2 (155 points)
    I can confirm that the CUPS workaround does work. I just discovered this problem today as I was trying to print from my two 10.5.2 MacBook Pros to the networked printers hanging off my old XP box at home. The CUPS workaround definitely got things moving again, but smb printing is broken otherwise. Thanks to Boul, and if anyone from Apple is reading this, please fix this in 10.5.3
  • 25. Re: NT_STATUS_LOGON_FAILURE
    VikasT Level 1 Level 1 (10 points)
    Boul,

    Thanks very much, that worked for me. What I do not understand however is how come with new releases, apple solves some problems but creates others? Never had such problems with Windows.

    Cheers
  • 26. Re: NT_STATUS_LOGON_FAILURE
    Sull1958 Level 1 Level 1 (0 points)
    Any suggestions how I fix this for a school library! The fix here has to be applied for each person. Our school has 1200 students.....there has to be an easier way!
  • 27. Re: NT_STATUS_LOGON_FAILURE
    dudebun Level 1 Level 1 (0 points)
    Boul, thanks SO MUCH. Your tips worked wonderfully for me. If only there was a way to email beer.
  • 28. Re: NT_STATUS_LOGON_FAILURE
    logicalgambit Level 1 Level 1 (0 points)
    My password contains special characters and the interface won't allow me to save them. Any other ideas?
  • 29. Re: NT_STATUS_LOGON_FAILURE
    unserrer Level 1 Level 1 (0 points)
    Boul

    Judging by your comments and that of others, your answer seems to solve a huge problem. However I cannot see anywhere in the CUPS interface to modify the smb:// address. Every time I attempt to add a printer in picks up the URI directly from the printer.

    Can you tell me how you used CUPS?